40m QIL Cryo_Lab CTN SUS_Lab TCS_Lab OMC_Lab CRIME_Lab FEA ENG_Labs OptContFac Mariner WBEEShop
  SUS Lab eLog  Not logged in ELOG logo
Entry  Mon Feb 3 17:15:59 2020, Duo, DailyProgress, Electronics, Some confusing noisemon findings 12x
    Reply  Tue Feb 4 17:30:50 2020, Duo, DailyProgress, Electronics, Some confusing noisemon findings p.pdfDataAndCode.zipPhoto_on_2-4-20_at_5.27_PM.jpgnoisemon_v1.pdf
Message ID: 1846     Entry time: Tue Feb 4 17:30:50 2020     In reply to: 1845
Author: Duo 
Type: DailyProgress 
Category: Electronics 
Subject: Some confusing noisemon findings 

I measured the spectrum with the digital system at all test points on noisemon with 10Hz sine drive (1845), but I saw a lot of distortion harmonics and other confusing stuff. At the end, I realized it could be caused by the clipper wire I used to breakout the DSUB9 connector. After talking to Chris today, I also realized that the low input impedance of the digital system could be invasive to the circuit. Considering these potential issues, I repeated yesterday's measurements with SR785 (attachment 3). There is not much difference - instead of using the digital system to send the drive and do the measurements, I used SR785 to drive and measure. SR785 has 1MOhm of input impedance while the ADC has only 10-20kOhm, according to Chris, so it could resolve the input impedance issue. Also, there is no DSUB connectors used; it also let me get rid of the clipper wires. 

I sent a 10Hz, 10mV p-p sine signal to the coil driver and measured all the test points from the output of the coil driver to the output of the noisemon. The results are in attachment 2, plotted in attachment 1. The test points can be referenced in the schematics in attachment 4. The plots with two numbers after 'TP' means the measurement is between the two test points - with postive clipper on one, negative on the other. Others are between the test point and ground. 

We can see there is a little bit distortion lines in the spectrum under 100Hz, but they are very small compared to the response to the drive. I think maybe they could explain the low frequency bump logged in 1843. However, it seems unlikely that they will be a serious issues in the passband, but still needs a little more rigorous justification.

Quote:

Trying to figure out the nature of the distortion found in noisemon (1843), I made a piece of DSUB9 breakout like attachment 1. I just used two wires and two clippers wires to break the DSUB connector into something I can clip into the board.

I sent a 10Hz drive to the coil driver and measured the spectrum at all the test points (including one pair on the coil driver board).

First, I compared the distortion situation at the input and output of noisemon (attachment 2). I measured the spectrum at TP10 and TP12 of coil driver (this is where noisemon picks up the differential input, reference DCC: D070483), and subtracted them quadratically, which gives us the input signal of noisemon. Then I measured the spectrum at the output of noisemon. Looking at attachment 2, it seems the coil driver does not contribute to the distortion.

Then I used the probe and measured all the test points individually. Attachment 3 also shows TP10 and TP12 but instead of measuring them individually and subtracting them, I just put one probe on TP10 and another on TP12. It looks like the coil driver does have a little distortion, contrast to the conclusion above.

Attachment 4 shows the spectrum at the noisemon input. There is a buffer between TP10/TP12 on coil driver and the input of noisemon (reference D070483). It looks like the distortion is less, somehow.

Attachment 5 is the spectrum after the passive filters, between TP3 and TP4. It seems the distortion comes back a little under 60Hz.

Attachment 6 shows the spectrum after the instrument amplifier.

Attachment 7 and 8 shows the output of two stages of high pass filters. The distortions gets much worse after two HP filters.

Attachment 9 shows the output of the low pass filter. We can see the high frequency harmonics are gone.

Attachment 10 is very confusing. Between TP8 and TP9 is just a buffer (LT1128 buffer unfortunately) - why does it give so many lines even without any drive? I tried to see them in the oscilloscope but there wasn't anything significant. Maybe it was the clippers/wires making the noise? I did check the signal at the conjunction point between the clipper and the wire using oscilloscope (attachment 11) - it is indeed bad (attachment 12) - but why these lines only show up in TP9?

I am very confused and need to think about what is going on now. I think a couple immediate questions are:

1. Why do I see so many lines at the output of noisemon even when there is no input? I should only see noisemon noise when there is no drive, but I did not short the inputs like when I measure the noise. I did shorted the inputs and checked the noise after the measurement - it is normal. Thus, the lines could be caused by not shorting the inputs of the coil driver, but I did not short the inputs in other measurements either - I just unchecked the excitation on diaggui.

2. Besides the TP9 confusion, we still see a lot of harmonics in uppersteam testpoints. Considering the TP9 situation, I think we should first ask - are they real? Then, if they are real, how bad are they? Considerations could include the functionality of noisemon board at the sites? This potentially include risk of saturation, increase of the noisemon noise and errors in measuring the DAC noise.

 

Attachment 1: p.pdf  132 kB  | Hide | Hide all
p.pdf
Attachment 2: DataAndCode.zip  93 kB
Attachment 3: Photo_on_2-4-20_at_5.27_PM.jpg  218 kB  | Hide | Hide all
Photo_on_2-4-20_at_5.27_PM.jpg
Attachment 4: noisemon_v1.pdf  1.808 MB  | Hide | Hide all
noisemon_v1.pdf noisemon_v1.pdf noisemon_v1.pdf noisemon_v1.pdf
ELOG V3.1.3-