40m QIL Cryo_Lab CTN SUS_Lab TCS_Lab OMC_Lab CRIME_Lab FEA ENG_Labs OptContFac Mariner WBEEShop
  ATF eLog  Not logged in ELOG logo
Entry  Wed Dec 15 20:16:44 2010, Alastair, Computing, General, more on fb0 
    Reply  Wed Dec 15 20:35:18 2010, Alastair, Computing, General, more on fb0 
Message ID: 1218     Entry time: Wed Dec 15 20:35:18 2010     In reply to: 1217
Author: Alastair 
Type: Computing 
Category: General 
Subject: more on fb0 

I tried commenting out both daqd and nds from inittab, and then running them manually as controls and chown'ing all the data files in /frames.  It still won't let me get the full data in dataviewer.

I can also take a realtime fft in DTT, but can't get data from the past.

Quote:

Separate issue is that Dataviewer on WS2 doesn't work.  Realtime and playback both result in the error :

--> Broken or incomplete installation - read the FAQ!

_____________________________________________________________________________________________________-

Running dataviewer on fb1 will give data for realtime, or from the frames for minute trend and second trend data but not full data.  In the frames folder, the second trend files were owned by root, and the minute trend were owned by controls. The full data files were owned by root also.  The daqd process was being run by root, hence the reason the full data was owned by root.

I manually edited inittab to comment out daqd, then I pkill'ed the process.  I then went to the /frames and chown'ed the directory recursively.  Then I tried running the daqd process as controls by going to the folder /cvs/cds/caltech/target/fb/ and running ./start_daqd.inittab  .  I then checked that the process was runing as controls (it was) and that the new data in /frames was owned by controls (it was also).

I then went back to dataviewer on fb1 again to see if I could pull full data from the frames - I couldn't.

I haven't yet been able to work out how to get inittab to run daqd as controls.  The problems pulling full data from the frames may be something else, I don't know.  It basically just hangs and the terminal window shows:

Connecting to NDS Server fb0 (TCP port 8088)
Connecting.... done
T0=10-12-16-03-08-51; Length=60 (s)
10-12-16-03-08-29

One other thing I notice is that nds is running as root, while on fb1 it is running as controls.

ELOG V3.1.3-