40m QIL Cryo_Lab CTN SUS_Lab CAML OMC_Lab CRIME_Lab FEA ENG_Labs OptContFac Mariner WBEEShop
  40m Log, Page 338 of 357  Not logged in ELOG logo
New entries since:Wed Dec 31 16:00:00 1969
Entry  Sun Feb 28 23:47:52 2010, rana, Update, Computers, rosalba 
Since Rosalba wanted to update ~500 packages, I let it do it. This, of course, stopped the X server from running. I downloaded and installed the
newest Nvidia driver and its mostly OK.
The main problem with the auto-update on our workstations is that we've updated some packages by hand; i.e. not using the standard CentOS
Entry  Thu Apr 26 16:35:34 2012, Jamie, Summary, CDS, rosalba now running Ubuntu 10.04 
This morning I installed Ubuntu 10.04 on rosalba.  This is the same version that is running on pianosa.  The two machines should be identically
configured, although rosalba may be missing some apt-getable packages.
Entry  Mon May 21 19:16:55 2012, Koji, Update, General, rossa X config 
I rebooted rossa and the X sever has stalled.
Entry  Fri Jul 19 17:42:58 2019, gautam, Update, General, rossa Xdisp bricked 
For some reason, rossa's Xdisplay won't start up anymore. This happened right after the UPS reset. Koji and I tried ~1.5 hours of debugging,
got nowhere.
    Reply  Sun Jul 21 22:16:34 2019, rana, Update, General, rossa Xdisp bricked 
"bricked" is to mean that it has the functionality of a brick and can be tossed. But rossa seems to have just gotten some software config corruption.
I spent a couple hours reinstalling SL7 today as per my previous elog notes and the X display seems to work as before.

i.e. it was fine with the default setup, except for the ole "X chrashes if the mouse goes to left side of screen". As before,
Entry  Thu Apr 22 14:49:08 2021, gautam, Update, Computer Scripts / Programs, rossa added to RTS authorized keys 
This is to facilitate running of scripts like the CDS reboot script, mx_stream restart, etc, from rossa, without being pwd prompted every time, whereas
previously it was only possible from pianosa. I added the public key of rossa to FB and the RT FE servers. I suppose I could add it to the Acromag servers
too, but I haven't yet.
    Reply  Sat Jul 20 11:24:04 2019, gautam, Update, General, rossa bricked 

SnapPy scripts made to work on Pianosa.

Entry  Mon Jul 24 19:56:41 2023, Yehonathan, Update, CDS, rossa can't boot 
{Koji, Yehonathan}

I had some issues with the Debian GUI which I thought would be solved upon reboot.

I restarted the machine but the boot sequence would get stuck at the cvs/cds mounting.
Entry  Tue May 22 20:24:06 2012, Jamie, Update, Computers, rossa is now running Ubuntu 10.04 
Now same as pianosa and rosalba.  I'll upgrade allegra on Friday.
    Reply  Sun Sep 5 21:35:41 2010, rana, Configuration, Computers, rossa notes 
**** Deleted
    Reply  Tue Sep 7 10:50:53 2010, josephb, Configuration, Computers, rossa notes 
The controls group is user id 500 by default on most new machines.  Unfortunately, the user ID used across the already existing machines is 1001.  One
method of doing this switch is in this elog.  You can also do the change of the controls
ID by becoming root and using the graphical command system-config-users.  This will  let you change the user ID and group ID for controls to
    Reply  Tue Sep 7 23:17:45 2010, sanjit, Configuration, Computers, rossa notes 


           * rossa needs to be able move windows between monitors: Xinerama?
    Reply  Sat Sep 11 03:16:51 2010, rana, Configuration, Computers, rossa notes 
I wiped out the old CentOS install on rossa and installed CentOS 5.5 on there. The DVDs are on a spindle in the control room; there were 2 iso's, but
I only needed the first to install most things.
It still needs to get all of the usual stuff (java, flash, nvidia) installed as well as setting up the .cshrc and the NFS mount of /cvs/cds. The
    Reply  Sun Sep 12 22:36:03 2010, rana, Configuration, Computers, rossa notes 
I found Sanjit's instructions for doing the Nvidia settings too complicated and so I followed these instructions from Facebook:
After installations, the monitors were autodetected and the Xinerama effect is working.
Entry  Thu Sep 2 21:22:31 2010, Sanjit, Koji, Configuration, Computers, rossa nvidia driver and dual monitor configuration 
Simple steps (but don't try these on a working computer without getting some experience on a spare one, you may find it difficult to restore the
system if something goes wrong):
    Reply  Thu Sep 2 23:35:33 2010, rana, Configuration, Computers, rossa nvidia driver and dual monitor configuration 
Why are we running CentOS 4.8 instead of 5.5 ?    What runs at LLO?     What runs in Downs?
    Reply  Fri Sep 3 11:23:16 2010, josephb, Configuration, Computers, rossa nvidia driver and dual monitor configuration 
At LLO the machines are running Centos 5.5.  A quick login confirms this.  Specifically the release is 2.6.18-194.3.1.el5.

    Reply  Wed Jul 1 18:16:09 2020, gautam, Update, Computers, rossa re-re-revival MCacc.pdf
In an effort to make a second usable workstation, I did the following (remotely) on rossa today (not necessarily in this order, I wasn't maintaining
a live log so I forgot):

Fixed /etc/resolv.conf,
    Reply  Sun Jul 5 16:14:41 2020, rana, Update, Computers, rossa re-re-revival 
maybe we should make a "dd" copy of pianosa in case rossa has issues and someone destroys pianosa by accidentally spilling
coffee on it.

    Reply  Wed Oct 2 20:45:18 2019, rana, Update, Computers, rossa revival 
Formatted and re-installing OS on rossa for the 3rd or 4th time this year. I suggest that whoever is installing software and adjusting video
settings please stop.

If you feel you need to tinker deeply, use ottavia or zita and then be prepared to show up and fix it.
    Reply  Thu Oct 3 21:50:22 2019, rana, Update, Computers, rossa revival 
Got the network to work again just by unplugging the power cord and letting it sit for awhile. But corrupted OS by trying to install Nvidia drivers.

    Reply  Mon Oct 28 18:55:06 2019, rana, Update, Computers, rossa revival 
back on new Rossa from Xi computing

switched to using Display Port for video; this works. The DVi, HDMI, VGA ports are connected to the motherboard rather than the video
card, so they are not active.
runs super slow w/ SL 7.6; maybe some service is running after startup?
install repos and update according
    Reply  Wed Jan 22 16:38:01 2020, rana, Update, Computers, rossa revival 
wiped and install Debian 10 on rossa today

still to be done: config it as CDS workstation

please don't try to "fix" it in the meantime
Entry  Mon Dec 18 17:48:09 2017, rana, Update, Computers, rossa: SL7.3 upgrade continues 
Following instructions from LLO-CDS
fo the rossa upgrade. Last time there were some issues with not being to access the LLO EPEL repos, but this time it seems to be working fine.

After adding font aliases, need to run 'sudo xset fp rehash' to get the new aliases to take hold. Afterwards,
    Reply  Tue Jun 26 22:06:33 2018, rana, Update, Computers, rossa: SL7.3 upgrade continues: DTT is back 
I used the following commands to get diaggui to run on rossa/SL7:

controls@rossa|lib64> ls -lrt libsasl*
-rwxr-xr-x. 1 root root 121296 Feb 16  2016 libsasl2.so.3.0.0
    Reply  Wed Jun 27 19:05:20 2018, rana, Update, Computers, rossa: SL7.3 upgrade continues: DTT is back 
UNELOGGED: someone has changed Pianosa from Ubuntu/Dumbian into SL7. Might be hackers.

Donatella is now the only Ubuntu machine in the control room. I propose we keep it this way for another month and then go fully SL7 if we find
no bugs with Pianosa/Rossa.
    Reply  Thu Jul 9 16:16:20 2020, gautam, Update, Computers, rossa: graphics driver issues? 
I noticed these streaky lines again today (but they were not a problem last night). It is annoying if we have to reboot this machine all the time. I
wonder if this has something to do with missing drivers. When I ran sudo apt update && sudo apt upgrade, I got several lines like (this isn't the
    Reply  Mon Jul 6 00:37:28 2020, gautam, Update, Computers, rossa: lib symlink 
This is strange - I was definitely able to launch medm when I was working on this machine remotely on Friday. But now, there does seem to be a problem
with this shared library being missing.

First of all, I installed mlocate to find where the shared library files are installed. Then I made the symlink, and
    Reply  Mon Jul 6 12:43:02 2020, rana, Update, Computers, rossa: lib symlink 
yes, I rebooted yesterday to fix the 'steaking white lines' problem in the video/display

maybe we're supposed to edit something besides resolv.conf since that gets
over-written on boot for some linux OS
    Reply  Sat Jul 11 00:10:22 2020, gautam, Update, Computers, rossa: more developmental work 
After some consultation with Erik von Reis at LHO, this workstation is progressing towards being usable for most
commissioning tasks. DTT, awggui, foton, and MEDM are all now working well. The main limitation
now comes from the fact that many of our python scripts are written for python2, and rossa doesn't have many dependencies installed for python2.
    Reply  Mon Jul 13 11:33:18 2020, rana, Update, Computers, rossa: more developmental work 
I too, would prefer py3 for everything, but aren't all the cdsutils / gaurdian things still python2?

Is it possible to just make a python2 conda environment on rossa? I would guess that its simple and won't interfere with the regular operation
of that machine.
    Reply  Mon Jul 13 12:37:05 2020, gautam, Update, Computers, rossa: more developmental work 
In fact, all these utilities are now available in python3. There may be some bugs (e.g. this),
but I've checked basic functionality and things look usable enough for development to proceed. While we can have a python2 env on rossa, I think it's
    Reply  Wed Jul 8 22:50:33 2020, gautam, Update, Computers, rossa: more symlinks 
I wanted to try using rossa as my locking workstation today. However, a few problems became quickly evident. Basically, any of our scripts that rely
on the cdsutils package (there are MANY)
will not work on rossa, because of some library error. This machine is running Debian 10, while the 
    Reply  Sun Jul 5 18:39:57 2020, rana, Update, Computers, rossa: printer 
I did

sudo usermod -a -G lpadmin controls
    Reply  Mon Jul 6 12:51:41 2020, gautam, Update, Computers, rossa: resolvconf installed 
Indeed, this is now fixed by following instructions from here.
I rebooted rossa at ~1250 PDT and confirmed that resolv.conf didn't get overwritten. The resolv.conf file also now has the following useful lines at
the head:
Entry  Mon Jun 5 21:53:55 2017, rana, Update, Computers, rossa: ubuntu 16.04 
With the network config, mounting, and symlinks setup, rossa is able to be used as a workstation for dataviewer and MEDM. For DTT, no luck since there
is so far no lscsoft support past the Ubuntu14 stage.
    Reply  Tue Jan 17 03:10:27 2012, kiwamu, Configuration, IOO, rotated lambda/2 plate  
I have slightly rotated the lambda/2 plate, which is used for attenuating the REFL beam's power on the AS table
because the plate had been at an unusual angle for investigation of the glitches since last Thursday.
It means the laser power going to the coating thermal noise setup has also changed. Just keep
    Reply  Mon Feb 4 10:45:51 2013, Jamie, Summary, General, rough analysis of aligned PRM-PR2 mode scan scan-labeled.pdf
Here's a sort of rough analysis of the aligned PRM-PR2 cavity mode scan.
On Friday we took some mode scan measurements of the PRM-PR2 cavity by pushing PRM (C1:SUS-PRM_LSC_EXT) with a 0.01 Hz, 300 count sine wave. 
We looked at the transmitted power on the POP DC PD and the error signal on REFL11_I.
    Reply  Mon Feb 4 11:10:59 2013, Koji, Summary, General, rough analysis of aligned PRM-PR2 mode scan 
The expected finesse is 100ish. How much can we beleive the measured number of 50?
From the number we need to assume PR2 has ~93% reflectivity. 
This does not agree with my feeling that the cavity is overcoupled.
    Reply  Mon Feb 4 19:33:19 2013, yuta, Summary, General, rough analysis of aligned PRM-PR2 mode scan 3peakdata.png
[Jenne, Yuta]

We redid PRM-PR2 cavity scan because last one (elog #7990) was taken with the sampling
    Reply  Tue Feb 5 02:04:44 2013, yuta, Summary, General, rough analysis of aligned PRM-PR2 mode scan PRMPR2scan.png
I redid PRM-PR2 cavity scan using oscilloscope to avoid anti-aliasing effect.
Measured Finesse was 104 +/- 1.
    Reply  Tue Feb 5 03:16:51 2013, Koji, Summary, General, rough analysis of aligned PRM-PR2 mode scan 
0.764 and 0.751 do not give us the stdev of 0.005.
I have never seen any Yokogawa in vicinity.

    Reply  Tue Feb 5 10:09:08 2013, yuta, Summary, General, rough analysis of aligned PRM-PR2 mode scan 
stdev of [0.764, 0.751] is 0.007, but what we need is the error of the averaged number. Statistical error of the averaged number is stdev/sqrt(n).

    Reply  Tue Feb 5 11:30:19 2013, Koji, Summary, General, rough analysis of aligned PRM-PR2 mode scan 
Makes sense. I mixed up n and n-1
Probability function: X = (x1 + x2 + ... + xn)/n, where xi = xavg +/- dx
    Reply  Wed Feb 13 01:26:08 2013, yuta, Summary, General, rough analysis of aligned PRM-PR2 mode scan unbiased.png
Koji was correct.

When you estimate the variance of the population, you have to use unbiased variance (not sample
    Reply  Mon Dec 7 11:11:25 2015, yutaro, Summary, LSC, round trip loss of X arm image1-2.JPGsymmetry.png
On the day before yesterday and in this morning, I measured loss map of ETMX. I reported the method I used to change the beam spot on ETMX below.

Round trip loss was measured for 5 x 5 points. The result is below.

(unit: ppm)
Entry  Wed Nov 25 16:40:32 2015, yutaro, Update, LSC, round trip loss of Y arm 
I measured round trip loss of Y arm. The alignment of relevant mirrors was set ideal with dithering (no offset).


 round trip loss of Y arm: 166.2 +/- 9.3 ppm
    Reply  Wed Nov 25 23:34:52 2015, yutaro, Update, LSC, round trip loss of Y arm 14.png
[yutaro, Koji]

Due to the strange behavior (elog 11815) of ASDC level, we checked if it is possible
to use POYDC instead of ASDC to measure the power of reflected light of YARM. Attached below is the spectrum of them when the arm is locked. This spectrum
    Reply  Fri Nov 27 03:38:23 2015, yutaro, Summary, LSC, round trip loss of Y arm image1.png
Tonight I measured "loss map" of ETMY. The method to calculate round trip loss is same as written in elog
11810, except that I used POYDC instead of ASDC this time.

How I changed beam spot on ETMY is: elog 11779.
    Reply  Fri Nov 27 22:20:24 2015, yutaro, Update, LSC, round trip loss of Y arm log.txt.zip17.png
Here, I upload data I took last night, including the power of reflected power (locked/misaligned) and transmitted power for each point (attachement 1).


And I would like to write about possible reason why the loss I measured with POYDC and the loss I measured with ASDC are different
ELOG V3.1.3-