40m QIL Cryo_Lab CTN SUS_Lab TCS_Lab OMC_Lab CRIME_Lab FEA ENG_Labs OptContFac Mariner WBEEShop
  40m Log, Page 338 of 344  Not logged in ELOG logo
    Reply  Thu Aug 12 23:41:48 2010, Jenne, Update, elog, restarted 

    Reply  Fri Aug 13 13:11:30 2010, Dmass, Update, elog, restarted 

Entry  Mon Aug 16 23:13:25 2010, Zach, Update, elog, e to the log 

    I get so many freebies it's ridiculous
Entry  Tue Aug 17 09:06:08 2010, Alberto, Update, elog, elog was down 
I just restarted the elog after I found it down a few minutes ago.
Entry  Tue Aug 17 23:59:46 2010, Katharine, Update, elog, Maglev update repulsiveforce.pngOSEMcalibration.pngOSEMslopes.png
Katharine, Sharmila

Entry  Wed Aug 18 19:14:59 2010, Jenne, Update, elog, elog dead again 
The elog was so dead this time that the restart script didn't work.  I followed the restart-by-hand instructions instead, with success.
    Reply  Thu Aug 19 01:49:14 2010, Jenne, Update, elog, elog dead again 

            The elog was so dead this time that the restart script didn't work.  I followed the restart-by-hand instructions
    Reply  Thu Aug 19 09:51:43 2010, josephb, Update, elog, elog dead again 
I found the elog dead again this morning, and the script didn't kill again.  I modified the script to use the following line instead of "pkill elogd":
kill `ps -ef | grep elogd | grep -v grep | grep -v start-elog-nodus | awk '{print $2}'`
Hopefully the script will be a bit more robust in the future.
Entry  Thu Aug 19 21:56:02 2010, Zach, Update, elog, restarted 
Entry  Fri Aug 20 13:09:53 2010, josephb, Update, elog, Rebooted elog 
I had to restart the elog again.
At this point, I'm going to try to get one of the GC guys to install gdb on nodus, and run the elog in the debugger, that way when it crashes the
next time, I have some error output I can send back to the developer and ask why its crashing there.
Entry  Sun Aug 22 16:20:24 2010, Zach, Update, elog, restarted (with my phone this time) 
Entry  Mon Aug 23 00:08:24 2010, Jenne, Update, elog, Joe, I think this's your cue... 
Entry  Tue Aug 24 14:29:18 2010, josephb, Update, elog, Elog down for 1 minute 
I'm going to take the elog down for one minute and restart it under gdb (using a copy of gdb stolen from fb40m since I couldn't figure out how to install
an old enough version on nodus from source).  The terminal with information is running on Rosalba under the "Phase Noise" panel, so please
don't close it.  Ideally, the next time the elog crashes, I'll have some output indicating why or at least the line in the code.  I can then
Entry  Tue Aug 24 17:57:57 2010, Zach, Update, elog, restarted 
 Restarted the elog using the script. I had to do it twice for it to work. This is not the first time this has happened---does anyone know why this
might be?
    Reply  Tue Aug 24 22:26:16 2010, Zach, Update, elog, restarted 
took two again

Entry  Wed Aug 25 12:18:47 2010, josephb, Update, elog, Trying new version of elog to see if it helps stability 
So unfortunately, I made the start-elog-nodus script smart enough to kill the debugging run I had (although thats probably good since there might have
been issues with continuing to run - just poor timing on part of the crash).
In related news, I have gotten the latest version of the elog code to actually compile on Nodus.  I had to hack the cryptic.c file (elog/src/cryptic.c)
Entry  Wed Aug 25 12:40:28 2010, josephb, Update, elog, Reverted back to 2.7.5 until further testing is done 
So apparently the themes/configurations didn't work so nicely on some of the logbooks with 2.8.0, so I'm reverting to 2.7.5 until I can figure out (assuming
I can) how to get them to display properly.
Entry  Wed Aug 25 15:55:33 2010, josephb, Update, elog, Staying with 2.7.5 until passwords sorted out 
Turns out the elog version 2.8.0 uses a different encryption method than 2.7.5.  This mean the encrypted passwords stored in the elogd.cfg don't
work with the new code.  elogd includes functionality to generate encrypted passwords, but unfortunately I don't know the administration passwords
for some of the logbooks.  So I'm going to leave 2.7.5 running until I can get those added properly to the 2.8.0 cfg file.
Entry  Tue Sep 7 14:42:02 2010, Dmass, Configuration, elog, elog restarted 
elog crashed on an upload. restarted and it worked fine with the same file.
    Reply  Tue Sep 7 22:21:47 2010, Dmass, Configuration, elog, elog restarted 

            elog crashed on an upload. restarted and it worked fine with the same file.
Entry  Mon Sep 27 21:57:59 2010, Zach, Update, elog, elog restarted 
 took two runs of the script as usual
    Reply  Wed Oct 13 09:35:41 2010, rana, Update, elog, start script edited 
The existing elog restart script was running the kill process in the background using the '&' symbol before starting new elog process. This is a
BAD idea since there's no way to make sure that the background process has actually worked before the new one tries to start. 
That's why you sometimes had to run the script twice. I've removed all of the background "cleverness" so now it will take ~2s
Entry  Sun Oct 24 19:23:41 2010, rana, Configuration, elog, ELOG 2.8.0 
[SIZE=4][COLOR=blue][FONT=Comic Sans MS][B]I stopped the ELOG and restarted us on 2.8.0.[/B][/FONT][/COLOR][/SIZE]

To make sure nothing got lost, I killed the old process, copied over the logbooks/, themes/, and elogd.cfg to the new 2.8.0/ directory before starting
    Reply  Mon Oct 25 02:23:47 2010, Koji, Configuration, elog, ELOG 2.8.0 
When I push the reply button, the raw html shows up in the edit window and have to use HTML to write the entry.
Does this happen only to me??? 
    Reply  Mon Oct 25 23:59:37 2010, Koji, Configuration, elog, ELOG 2.8.0 -> ELOG 2.7.5 
ELOG reverted to 2.7.5 due to editing difficulties

- /cvs/cds/caltech/elog/start-elog.csh reconfigured to launch 2.7.5
    Reply  Tue Oct 26 07:02:05 2010, Alberto, Configuration, elog, ELOG 2.8.0 -> ELOG 2.7.5 

            ELOG reverted to 2.7.5 due to editing difficulties
    Reply  Tue Oct 26 10:50:08 2010, Koji, Configuration, elog, ELOG 2.8.0 -> ELOG 2.7.5 -> ELOG 2.8.0 
ELOG restarted with 2.8.0 again.
- moved elog-2.8.0/script dir to elog-2.8.0/script.orig
- copied elog-2.7.5/script to elog-2.8.0/script
Entry  Wed Oct 27 11:52:45 2010, josephb, Update, elog, Elog needed to be restarted 
I had to restart the elog on Nodus because it was no longer responding.
Entry  Mon Nov 29 17:45:28 2010, Zach, Update, elog, restarted elog 
 The elog was down so I restarted it. The instructions on the wiki do not work as the process has some complicated name (i.e. it is not just 'elogd').
I used kill and the pid number.
I will get around to updating the restart script to work with 2.8.0.
Entry  Tue Nov 30 11:44:36 2010, Zach, Update, elog, elog restarted -- SCRIPT adapted for 2.8.0 
 I have created an updated version of the "start-elog-nodus" script and put it in .../elog/elog-2.8.0. It
seems to work fine.
Entry  Tue Nov 30 12:10:44 2010, josephb, Update, elog, Elog restarted again 
The elog seemed to be down at around 12:05pm.  I waited a few minutes to see if the browser would connect, but
it did not.
I used the existing script in /cvs/cds/caltech/elog/ (as opposed to Zach's new on in elog/elog-2.8.0/) which also
Entry  Tue Nov 30 14:21:21 2010, Zach, Update, elog, Script unnecessary 
I didn't realize that the script in .../elog was configured to start 2.8.0 already. I will revert the instructions on the wiki to point to that 
Entry  Tue Nov 30 19:35:09 2010, Zach, Update, elog, restarted again 
 Restarted the elog again, this time using .../elog/start-elog.csh, which Joe pointed out works just fine. I have amended the wiki
instructions to point to this script, instead.
Entry  Mon Dec 6 22:43:19 2010, Frank, Configuration, elog, elog restarted 
I restarted the elog because i changed the configuration for the cryo-elog.
Used the "start-elog.csh" script in /cvs/cds/caltech/elog/
Entry  Tue Dec 14 09:26:17 2010, Zach, Update, elog, restarted 
 Restarted the elog with the script
Entry  Sat Dec 18 06:24:49 2010, rana, Update, elog, restarted 
The process was taking up 100% of the CPU and not responding via web. The .log file showed the last action was somebody reading/editing one of Jenne's
entries from August regarding TT ECD. The restart script didn't work, so I had to do a 'kill -9' to get it to die.
    Reply  Sat Dec 18 23:33:06 2010, Koji, Update, elog, restarted 
Did the same.

    Reply  Sun Dec 19 11:19:42 2010, Koji, Update, elog, restarted 
Did it again. It seemed that Google bot came to the elog and tried to obtain  "http://nodus.ligo.caltech.edu:8080/robots.txt". That was the
last of the log.
Bot came from the AJW's homepage. Also Google FeedFecther came to the elog.
    Reply  Sun Dec 19 22:45:28 2010, rana, Update, elog, restarted 
I deleted the yellow box which showed up by default when making an elog entry. Would be nice if we could make it so that you have to click a button to
'opt-in' for the yellow box rather than get it by default.
I added a 'robots.txt' file to the /users/public_html/ area using Google's
Entry  Tue Dec 21 08:26:08 2010, rana, Update, elog, elogd is getting killed by Suresh 
Suresh killed the elogd again from India. This was the log file:
Accept-Charset: ISO-8859-1,utf-8;q=0.7,*;q=0.7
Keep-Alive: 115
    Reply  Wed Dec 22 06:50:19 2010, rana, Update, elog, elogd is getting killed by Suresh 
After another elog crash, I've blacklisted the domain that Suresh is using by editing the apache httpd.conf. Let's see what happens now.
    Reply  Thu Dec 23 03:15:11 2010, Koji, Update, elog, elogd is getting killed by Suresh 
ELOG has crashed and I restarted it.
Actually the filtering is not effective so far as elog is not using apache but has its own web server inside.
So this just block the access to port 30889 (=SVN, Dokuwiki, etc).
Entry  Thu Dec 23 08:54:32 2010, Suresh, Update, elog, the delhi univ syndrome 
Sorry folks!  I couldnt get to the elog and didnt know that the elog was crashing every time I tried to access it. 
But have found other means to access it and the elog is safe for now!
Entry  Wed Dec 29 18:53:11 2010, rana, Summary, elog, found hung - restarted 
This was the error today:
GET /40m/ HTTP/1.1
Host: nodus.ligo.caltech.edu:8080
    Reply  Mon Jan 3 10:32:27 2011, kiwamu, Summary, elog, found hung - restarted 
Found exactly the same error messages at the end of the log file.

            Quote: #4098
    Reply  Wed Jan 5 10:45:51 2011, Koji, Update, elog, restarted 
Google bot  crashed the elog again. Then, I found that Google bot (and I) can crash elogd by trying to show the threaded view.
There looks similar issue reported to the elog forum, the author did not think this is a true bag.
Note: This happens only for the 40m elog. The other elogs (ATF/PSL/TCS/SUS/Cryo) are OK for the threaded view.
Entry  Wed Jan 5 21:19:29 2011, Zach, Update, elog, restarted 
 Restarted the elog with the script
    Reply  Thu Jan 6 10:47:11 2011, Koji, Update, elog, ELOG fixed (re: restarted) 
Fixed the 40m elog crashing with the threaded display.
This morning I found that Google
bot crashed the elog again. I started the investigation and found the threaded mode is fine if we use the recent 10 entries.
I gradually copied the old entries to a temporary elog and found that a deleted elog entry on August 6 had a corrupted remnant in the elog file.
Entry  Wed Jan 19 10:31:24 2011, josephb, Update, elog, Elog restarted again 
Elog wasn't responding at around 10 am this morning.  I killed the elogd process, then used the restart script.
Entry  Mon Feb 21 11:05:51 2011, Zach, Update, elog, restarted 
 I restarted the elog using the script.
ELOG V3.1.3-