40m QIL Cryo_Lab CTN SUS_Lab TCS_Lab OMC_Lab CRIME_Lab FEA ENG_Labs OptContFac Mariner WBEEShop
  40m Log, Page 288 of 337  Not logged in ELOG logo
ID Date Author Type Category Subject
  2492   Sat Jan 9 11:07:30 2010 AlbertoUpdateLSCProblems trying to lock the arms

Quote:

This morning I've been having problems in trying to lock the X arm.

The X arm's filter FM6 in the LSC screen starts blinking as it was halfloaded. Then the transmitted power drops from 1 to ~0.5 and eventually the arm loses lock.
To me it looked like a computer related issue. So I decide to reboot C1ISCEX by powercycling it.

That doesn't seem to have solved the problem. The X arm can get locked but TRX slowly moves between 0.2 and 1.

The X arm is now locked with TRX stable at ~1.

I think earlier on today I was having problems with running the alignment scripts from op540. Now I'm controlling the IFO from Rosalba and I can easily and stably lock all degrees of freedom.

I needed the X arm to be locked to align the auxiliary beam of the AbsL experiment to the IFO. To further stabilize TRX I increased the loop gain from 1 to 1.5.

Now the auxiliary beam is well aligned to the IFO and the beat is going through the PRC. I'm finally ready to scan the recycling cavity.

I also changed the gain of the PRC loop from -0.1 to -0.5.

  2491   Sat Jan 9 09:47:03 2010 AlbertoUpdateLSCProblems trying to lock the arms

This morning I've been having problems in trying to lock the X arm.

The X arm's filter FM6 in the LSC screen starts blinking as it was halfloaded. Then the transmitted power drops from 1 to ~0.5 and eventually the arm loses lock.
To me it looked like a computer related issue. So I decide to reboot C1ISCEX by powercycling it.

That doesn't seem to have solved the problem. The X arm can get locked but TRX slowly moves between 0.2 and 1.

  2490   Fri Jan 8 20:13:49 2010 Alberto, JoBConfigurationComputersThe 40m Kaiser Permanent Reboot Marathon
This morning after Alex and Jo's tinkering with Megatron the RFM network crashed and it brought down also some computers. The effect was that it was not possible to lock the mode cleaner anymore.
A few computers crashed and things didn't come back to their origianl state.
After an endless day of rebooting and fixing problems with the single front ends (in particular with c1susvme1), eventually the mode cleaner got locked again.
Among my weapons I also used the Nuclear Option (TM).
Maybe I'll include more details in a future elog entry.
Anyway, in the end I burtrestored everything to Jan 8 2009 at 9:00.

pasadena_marathon.JPG

  2489   Fri Jan 8 18:20:12 2010 steveMetaphysicsTreasureRob now can concentrate on his thesis

We are celebrating Rob's promotion to thesis poetry.  These pictures were taken on December 9, 2009

Rob has finished all his measurements in the lab and is officially well prepared to graduate.

rob1.JPGrob2.JPG rob3.JPG

 

  2488   Fri Jan 8 15:40:14 2010 josephb, alexUpdateComputersRFM and RCG

Alex added a new module to the RCG, for generating RFMIO using floats.  This has been commited to CVS.

  2487   Fri Jan 8 11:43:22 2010 josephb, alexUpdateComputersRFM and Megatron

Alex came over with a short RFM cable this morning.  We used it to connect the rfm card in c1iscey to the rfm card megatron

Alex renamed startup.cmd in /cvs/cds/caltech/target/c1iscey/ to startup.cmd.sav, so it doesn't come up automatically.  At the end we moved it back.

Alex used the vxworks command d to look at memory locations on c1iscey.  Such as d 0xf0000000, which is the start of the rfm code location.  So to look at 0x11a1c8 (lscPos) in the rfm memory, he typed "d 0xf011a1c8".  After doing some poking around, we look at the raw tst front end code (in /home/controls/cds/advLigo/src/fe/tst), and realized it was trying to read doubles.  The old rts code uses floats, so the code was reading incorrectly.

As a quick fix, we changed the code to floats for that part.  They looked like:

etmy_lsc = filterModuleD(dsp_ptr,dspCoeff,ETMY_LSC,cdsPciModules.pci_rfm[0]? *(\
(double *)(((void *)cdsPciModules.pci_rfm[0]) + 0x11a1c8)) : 0.0,0);

And we simply changed the double to float in each case.  In addition we changed the RCG scripts locally as well (if we do a update at some point, it'll get overwritten).  The file we updated was /home/controls/cds/advLigo/src/epics/util/lib/RfmIO.pm

Line 57 and Line 84 were changed, with double replaced with float.

return "cdsPciModules.pci_rfm[0]? *((float *)(((void *)cdsPciModules.pci
_rfm[$card_num]) + $rfmAddressString)) : 0.0";

. "  *((float *)(((char *)cdsPciModules.pci_rfm[$card_nu
m]) + $rfmAddressString)) = $::fromExp[0];\n"

This fixed our ability to read the RFM card, which now can read the LSC POS channel, for example.

Unfortunately, when we were putting everything the way it was with RFM fibers and so forth, the c1iscey started to get garbage (all the RFM memory locations were reading ffff).  We eventually removed the VME board, removed the RFM card, looked at it, put the RFM card back in a different slot on the board, and returned c1iscey to the rack.  After this it started working properly.  Its possible in all the plugging and unplugging that the card somehow had become loose.

The next step is to add all the channels that need to be read into the .mdl file, as well as testing and adding the channel which need to be written.

 

  2486   Fri Jan 8 10:38:35 2010 josephb, kojiUpdateComputersRFM and Megatron

Last night, we installed the VMI 5565 RFM card into Megatron.  After turning off the watchdogs for the ETMY optic, we disconnected the RFM fiber, and connected it to megatron, then powered it up. 

We modified the RCG code to have 3 rfmio blocks, which were reading 0x11a1c0 (ascPit), 0x11a1c4 (ascYaw), and 0x11a1c8 (lscPos).  These were connected to the approriate filter module inputs, and we also added grounds to the front of the rfmio blocks (we looked at the ass code which was setup that way, so we just did the same thing).  When we started it however, it didn't read properly.  If we turned off the input and set and offset, it calculated the output of the filter module correctly, (i.e. just the offset value), but as soon as we turned on the input, it was set to 0, no matter the offset value, which indicated it was reading something correctly.

After this test, the RFM fibers were reconnected to c1iscey, we rebooted c1iscey, and we confirmed that the system was working properly again.  We turned the watch dogs back on for ETMY.

 

 

  2485   Fri Jan 8 10:03:04 2010 AlbertoOmnistructureLSCSPOB shutter was closed

This morning I found that there was no light on the SPOB PD. I went looking at the photodetector and I found that the shutter in front of it was closed.

I switched the shutter driver from n.c. to n.o. which had the effect of opening it.

I guess we inadvertently closed the shutter with Rana when last week we were tinkering with the ITMY  camera.

  2484   Thu Jan 7 14:55:36 2010 JenneUpdateComputersWe haven't had a bootfest yet this week.....so today's the day

Quote:

All the DAQ screens are bright red.  Thumbs down to that.

 All better now. 

  2483   Thu Jan 7 14:08:46 2010 JenneUpdateComputersWe haven't had a bootfest yet this week.....so today's the day

All the DAQ screens are bright red.  Thumbs down to that.

  2482   Wed Jan 6 16:48:52 2010 steveBureaucracySAFETYcopied NPRO key

We lost our key to the Lightwave 125/6-OPN-PS   The key shop just made one look a like that works.

Attachment 1: nprokey.JPG
nprokey.JPG
  2481   Wed Jan 6 03:44:41 2010 KojiConfigurationIOOElusive Mode Matching Solution found!

I am in the way to get a reasonable optical layout.
Please calculate the final results with the following conditions.

"Result" =
- mode overlapping with astigmatism
- alignment matrix (m/rad, rad/rad) for Pitch and Yaw
- alignment orthogonality
- sensitivity of the mode overlapping to the perturbations
  * histgram
  * individual scan of the optic positions

Optics chain: MC3 - SM1(flat) - MMT1(f=-5m) - MMT2(f=+8m) - SM2(flat) - PRM

Incident angles: SM1 24deg, MMT1 3deg, MMT2 1deg, SM2 44.5deg

Distances:
MC3 HR - SM1: 884mm
SM1 - MMT1: 1058.2mm
MMT1 - MMT2: 1890mm
MMT2 - SM2: 2007.9mm
SM2 - PRM HR: 495.6mm

It has ~200mm deviation from the solution. I can move only MMT1 for final optimization.
Give us the numbers if it can improve the performance.
Note that this move changes SM1-MMT1 and MMT1-MMT2 simultaneously.

Quote:

I think I have finally found a Mode Matching solution for our new Input Mode Matching Telescope!  And after looking at the layout diagram with Koji and Raffaele, it seems like all of the optics will fit into the chambers / onto the tables (not true as of last week). 

3. RoCMMT1 is -5m
   RoCMMT2 is 8m,
   with the MMTs 1.89m apart.
   This is a 1.6x telescope.
   MMT2 is 2.2641m from the PRM
   MMT1 is 2m from MC3.
   The Condition Number for this optical chain is 89219047.5781.

This layout is very similar to the one that Koji posted on the wiki yesterday:  Upgrade09/Optical Layout.  The difference is that I want to move MMT1 ~20cm closer to the MC13 table, so just on the other side of the main red beam that goes directly to PRM.  There is plenty of space there, so it should be all good.  The tricky bit is that the flat steering mirrors fit into things now while they are piezos, but they will be trickier to fit if we make them into Tip Tilts.  But I have full faith in Koji's amazing optical table layout skills, that he can make it happen. 

Unless there are major objections, I think this is the MMT that we're going to go with. (So speak now or forever hold your peace.)  The angle between tilt and translation isn't quite what we'd like it to be (at ~18deg), but it's not too terrible.  And we still have 99.5% overlap which is very important.

 

  2480   Tue Jan 5 17:32:59 2010 JenneUpdateWienerFilteringNew Wiener Filters installed in PEM IIR matrix on OAF screen

EDIT 6 Jan 2010:  Shouldn't have done this.  My bad.  The AA32 is on the other PEM matrix because the Adaptive code runs at 64Hz, so there's downsampling, calculating, and upsampling which goes on.  The Feed Forward path all runs at 2kHz, the regular rate of the ASS/OAF machine.  All of these filters are turned off (although I haven't deleted them from Foton).  Since we're focusing on low frequency stuff and trying to get that to do some subtraction, we're not worrying about the junk at higher frequencies just yet.

 

I have put AA32 filters into the PEMIIR matrix's input filter banks (ie, C1:ASS-TOP_PEMIIR_##), to match the ones that are in the same places in the regular PEM matrix on the OAF screen. 

I redid the uncorrected vs. corrected MC_L DTT printout, shown below. You can see that there's less junk at higher frequencies in the Blue (actuation channel) trace, which is good.

Attachment 1: OAF-FF_test_5Jan10.png
OAF-FF_test_5Jan10.png
  2479   Tue Jan 5 13:23:45 2010 AlbertoOmnistructureEnvironmentturning page

In the lab there are lots of old posters with outdated autocad drawings, or printouts with schematics of old electronics hanging on the walls.

Can we get rid of those and start giving the lab a fresh and modern look?

  2478   Tue Jan 5 11:00:04 2010 ranaOmnistructureEnvironmentAdded new wall cable-racks

Quote:

we hung two new WALL cable racks. One is on the pillar next to the Sp table, the other is next to the PSL computer rack.

 awesome - I have ordered 5 blue racks so that we can hang power cables. The fat BLUE ones are for fat cables and the orange ones for the coax cables.

  2477   Tue Jan 5 10:26:32 2010 Alberto, SteveOmnistructureEnvironmentAdded new wall cable-racks

we hung two new WALL cable racks. One is on the pillar next to the Sp table, the other is next to the PSL computer rack.

To do that we had to drill holes in the wall since the simple screws weren't strong enough to keep them up.

One of the racks, the yellow, is dedicated to 4-pin lemos and other thick cables.

DSC_1068-1.JPGDSC_1070-1.JPG

  2476   Tue Jan 5 09:18:38 2010 AlbertoOmnistructureElectronicsUniversal PDH Box Stored in the RF Cabinet

FYI: I stored the Universal PDH boxes in the RF cabiner in the Y arm.

  2475   Tue Jan 5 01:31:09 2010 JenneUpdateWienerFilteringNew Wiener Filters installed in PEM IIR matrix on OAF screen

Using the techniques employed at LLO, and then by Rana here at the 40m a few weeks ago, Wiener filters have been installed on the inputs of all of the PEM IIR channels which are hooked up to the 110B PEM ADCU.  Some slight modifications have taken place to the code, and it's all been checked in to the 40m svn. 

I have installed the filters into:  All 6 Wilcoxon accelerometers, the Ranger seismometer, and one of the Guralps (GUR1).  The other Guralp is currently connected through the ASS/OAF machine's ADC, so it's not used in this test. The filters are all labeled "Wiener", and are FM1 in the C1:ASS-TOP_PEMIIR_## filter banks.

The first figure below is the output of the Wiener Filter calculation program.  It shows the uncorrected MC_L (black) and the corrected MC_L (red), using the optimal wiener filter.  This is as good as we should be able to do with these sensors in these positions.

The second figure is a DTT shot of me trying out the nifty new filters.  They seem to maybe do a teensy bit on the microseism, but otherwise it's a bit unremarkable.  Hopefully I'll get better subtraction during the day, when the base level for MC_L is higher.  Here, Black is uncorrected MC_L, Red is the corrected MC_L, Blue is the actuation channel, and green is an example seismometer channel to illustrate the ground motion at the time.

 

For posterity, since it's not all in one elog that I can find, the order of operations to install a Wiener Feed Forward filter is as follows:

1.  (When you can borrow the IFO) Take a very careful TF of the plant, between your actuation point and your error signal readout.  At the 40m, this means between C1:ASS-TOP_SUS_MC1_EXC and C1:IOO-MC_L, since we actuate by pushing on the MC1 coils.  At the sites / future 40m, this would be between the HEPI (or STACIS) and the error signal.  The limit of how good your Feed Forward can do will depend heavily on how good this TF is.  Coherence should be above ~0.95 for all points.  Export this data from DTT as a .txt file, using units "Complex (abs/rad)". 

2. Run fitMC12MCL.m (or equivalent wrapper file) to fit the transfer function you just took with some Poles and Zeros.  Make sure to edit the wrapper file with your new .txt file's name so you're getting a fresh TF (if you've just taken one).

3. (Again, when you can borrow the IFO) Run getMCdata.m (or equivalent) to fetch witness channel data and error signal data.  At the 40m, this usually means C1:IOO-MC_L, and witness sensors which are around the MC chambers.  This data should be taken at a time when the cavity is locked, but pretty much on it's own. (i.e. probably shouldn't have Common Mode feedback on the MC - so the MC should be locked, but not the full IFO, for example.)

4.  Run c1winoiir.m (the main program here, which contains some of these notes). This will take in the TF data you've fit, and the witness channel data you have, and calculate the optimal combination of Wiener filters for your witness channels.  It pre-filters your witness data by your TF, then calculates the Wiener filter.  The resulting FIR filters are saved in a file.

5.  Run firfit.m  This will take the FIR Wiener filters you've just created, and convert them conveniently to IIR filters, in a format to be copied directly into Foton.  For each witness channel, you'll get the IIR filter in 2 formats:  the first is for copying into the Foton .txt file (ex ASS.txt), and the second is for copying into the Foton gui, in the "Command" box on the filter design screen.  The "o" at the end of the copy-able filter indicates to Foton that it is a Z-Plane Online filter.  Copy filters appropriately (there should be a line preceding each set of SOS filter formats to indicate which channel this Wiener filter is for...these channel names are extracted from your getMCdata.m)

6. Save your Foton file, and update your Coefficients in MEDM.  Enable your outputs to actuators, and watch magic happen!

 

On the To-Do list:

Check the transfer of signal btwn PEMIIR matrix and the 9x1 'matrix' that sends the signals to the SUS inputs.  In the SimuLink, the input to the 9x1 matrix is a bundle of 8 numbers (the 8 outputs of the PEMIIR matrix), but it looks like it only pays attention to the first one.  Need to figure out how to make it realize that it's a bundle, not a single number. 

Also, the OAF up / down scripts don't seem to be working on any of the control room computers.  This needs to be checked in to / fixed (but not tonight....)

Attachment 1: MCwino-FFtest_4Jan10_sameFiltersAsinEPICS.png
MCwino-FFtest_4Jan10_sameFiltersAsinEPICS.png
Attachment 2: OAF-FF_test_4Jan10.png
OAF-FF_test_4Jan10.png
  2474   Mon Jan 4 17:26:01 2010 MottUpdateGeneralT & R plots for Y1 and Y1S mirrors

The most up-to-date T and R plots for the Y1 and Y1S mirrors, as well as a T measurement for the ETM, can be found on:

http://lhocds.ligo-wa.caltech.edu:8000/40m/Upgrade_09/Optics/RTmeasurement

 

  2473   Mon Jan 4 17:21:30 2010 JenneConfigurationIOOElusive Mode Matching Solution found!

I think I have finally found a Mode Matching solution for our new Input Mode Matching Telescope!  And after looking at the layout diagram with Koji and Raffaele, it seems like all of the optics will fit into the chambers / onto the tables (not true as of last week). 

3. RoCMMT1 is -5m
   RoCMMT2 is 8m,
   with the MMTs 1.89m apart.
   This is a 1.6x telescope.
   MMT2 is 2.2641m from the PRM
   MMT1 is 2m from MC3.
   The Condition Number for this optical chain is 89219047.5781.

This layout is very similar to the one that Koji posted on the wiki yesterday:  Upgrade09/Optical Layout.  The difference is that I want to move MMT1 ~20cm closer to the MC13 table, so just on the other side of the main red beam that goes directly to PRM.  There is plenty of space there, so it should be all good.  The tricky bit is that the flat steering mirrors fit into things now while they are piezos, but they will be trickier to fit if we make them into Tip Tilts.  But I have full faith in Koji's amazing optical table layout skills, that he can make it happen. 

Unless there are major objections, I think this is the MMT that we're going to go with. (So speak now or forever hold your peace.)  The angle between tilt and translation isn't quite what we'd like it to be (at ~18deg), but it's not too terrible.  And we still have 99.5% overlap which is very important.

Attachment 1: Awesome_MM_Solution.png
Awesome_MM_Solution.png
  2472   Mon Jan 4 09:52:40 2010 ranaConfigurationCamerasITMX camera and PSL channels

I fixed up the ITMX camera like we did for ITMY recently (removed T's and added strain relief - the lens was already OK).

I also updated the .SCAN field for the RMTEMP and RCTEMP channels to 0.1 second. This had been done via probe but was wiped out after reboot previously, because I forgot to update the psl.db file.

  2471   Sun Jan 3 08:23:39 2010 ranaConfigurationCDSautoburt.pl 'fixed' for post 2009 years

Tobin & Keith pointed out in the LLO ilog that there was a code bug in the autoburt.pl script for autoburts.

I edited the autoburt.pl script so that it will work from now until 2099 (by which time we may no longer be using this version of perl):

nodus:autoburt>diff autoburt.pl~ autoburt.pl
234c234
<     $thisyear = "200".$timestamp[5];
---
>     $thisyear = "20".$timestamp[5];

The autoburt has not been working ever since 11PM on New Year's eve.

I ran it by hand and it seems to run fine. I noticed along the way that it was running on op340m (our old Sun Blade 150 machine). The autoburt.pl was pointing at /cvs/cds/bin/perl

which is Perl v5.0. I changed it to use '/usr/bin/env' and now points at '/usr/bin/perl' which is perl 5.8. It runs fine with the new perl:

op340m:scripts>time perl /cvs/cds/scripts/autoburt.pl >> /cvs/cds/caltech/logs/autoburtlog.log
5.37u 6.29s 2:13.41 8.7%

Also ran correctly, via cron, at 9AM.

  2470   Wed Dec 30 22:17:07 2009 kiwamuUpdateGeneralCamera input and monitor output

The input channels of the cameras and the output channels for the monitors are summarized on the wiki.

The channel table on the wiki is very helpful when you want to make a change in the video matrix.

thank you.

  2469   Wed Dec 30 20:33:36 2009 rana, albertoConfigurationCamerasITMY & MC2 Camera work

We restored the good state of the ITMY camera and neatened both the MC2 and ITMY camera.

The MC2 camera was driving a triple T jungle into some random cables and spoiling the image. We removed all T's and the MC2 camera now drives only The Matrix.

The ITMY camera was completely unmounted and T'd. So it was misaligned just by the force of gravity acting on its BNC cable. We swapped the lens for a reasonable sized one and remounted it in its can. We then used orange cable ties to secure the power and BNC cable for the MC2 and ITMY cameras so that tugging on the cables doesn't misalign the cameras. This is part of the camera's SOP.

No more driving 50 Ohm cables and T's with video cables, Steve! If you need a portable video, just use a spigot of the Matrix and then you can control it with a web browser.

DSC_1064.JPGDSC_1065.JPGDSC_1066.JPG

I also wiped out the D40's memory card after uploading all of the semi-useful files to the Picasa page.

  2468   Wed Dec 30 18:01:03 2009 Alberto, RanaUpdateGeneralAll watchdogs tripped this morning

WQuote:

This morning I found all the watchdogs had tripped during the night.

I restored them all.

I can't damp ITMX. I noticed that its driving matrix is all 1s and -1s as the the right values had been lost in some previous burtrestoring.

 

Rana fixed the problem. He found that the side damping was saturating. He lowered the gain a little for a while, waited for the the damping to slow down the optic and then he brought the gain back where it was.

He also upadted the MEDM screen snapshot.

  2467   Wed Dec 30 10:58:48 2009 AlbertoUpdateGeneralAll watchdogs tripped this morning

This morning I found all the watchdogs had tripped during the night.

I restored them all.

I can't damp ITMX. I noticed that its driving matrix is all 1s and -1s as the the right values had been lost in some previous burtrestoring.

  2466   Wed Dec 30 09:57:53 2009 steveUpdatePSLthirsty water chiller

I added 600 cc of Arrowhead Distilled Water to the chiller.

60 days plot shows that about every ~ 10 days I have to add some.

Please check the water level yourself.

Attachment 1: htemp60d.png
htemp60d.png
  2465   Tue Dec 29 13:57:20 2009 Rana, Kiwamu, and HaixingUpdatePhotosPhotos of video switch box

Before we installed the video switch box, we also took some photos of it. We uploaded them onto the 40m Picasa.

Video Matrix

The first photo is the an entire view of the switch box. The following four photos are the details of the switch matrix.

 The slideshow below is a dump of the last several months of photos from the Olympus. The originals have been deleted.

  2464   Tue Dec 29 04:28:27 2009 kiwamu, rana, haixingUpdateCamerasNew Video Switch Installed

We have installed the new Video Matrix.

Its still in an intermediate state, so don't try to "fix" anything before Kiwamu and I get back onto it in the afternoon.

The status so far is that we have removed the old switch (it was a 256 input x 128 output !! mux)  and installed the new one in the same rack. We have hooked it up to the CDS network and have set up its matrix by using the web interface (i.e. NOT EPICS).


Along the way, we discovered that there is lack of impedance matching in the video all over the 40m. Video signals are RF and need to be treated that way. The PSL signals are T'd around and sent on 50 Ohm cables to high impedance monitor inputs.

We should eliminate any switches besides the new one (called Luciana) and control the PSL's Video Monitor from the main MUX interface. No more Rogue Video Switches.

 


Another couple of things we have found is about RCR camera.

(1) The long cable which connects the RCR camera box and the video matrix doesn't work. Although the signal is alive and we can see it by the local tv monitor nearby PSL.

(1) The reflected beam going to the camera is too weak to see in the monitor.  We found a strange polarized cube splitter in front of the camera. We should modify it sooner or later.

  2462   Mon Dec 28 23:56:44 2009 kiwamu, ranaUpdateComputersadd the HILO drift channels to the burt

The HIGH and LOW channels are added into the burt request file "/target/c1losepics/autoBurt.req".

These values are used to colorize the alarm texts in the "C1DRIFT_MONITOR.adl" like a threshold. (the screenshot attached)

Hereafter these values will be automatically restored by the burt.  Happy !

Attachment 1: Screenshot_DRIFTMON.png
Screenshot_DRIFTMON.png
  2461   Mon Dec 28 18:35:27 2009 AlbertoUpdateABSLWorking on the AP table

Quote:

I opened the auxiliary laser's shutter.

I'm currently working on the AP table.

 I finished working on the table.

I closed the AUX NPRO's shutter.

  2460   Mon Dec 28 15:34:14 2009 AlbertoUpdateABSLWorking on the AP table

I opened the auxiliary laser's shutter.

I'm currently working on the AP table.

  2459   Mon Dec 28 15:19:19 2009 AlbertoUpdateComputersBurtrestored to Dec 26 at 20:00

Since it wasn't sure whether all the front-ends had been restored after the bootfest, I burtrestored everything to Dec 26 at 20:00.

Always keep in mind that to burtrestore c1dcuepics, the snapshot file has to be modified by hand by moving the last quote up to the line before the last.

  2458   Mon Dec 28 12:45:55 2009 KojiUpdateSUSMC2 is having a bad day

The MCL path of MC2 was in a strange state as the filters were activated as if it is in lock even though we had no lock. So I manually ran "mcdown". This reset the filters of the MCL path.

Quote:

MC2 is having a bad day, and I'm not yet sure why.  It's to do with the damping though.  When the damping is off, after a little while it will settle to ~30mV or so on the Watchdog screen.  When I enable all of the outputs and then turn on the damping, the optic gets kicked up.  It's like there's a minus sign error somewhere, maybe in a bad burtrestore?  This has been going on since I did my morning bootfest.

It's started to sit down and play nicely now.  Is someone doing magic remotely that is fixing things that I hadn't figured out yet?

 

  2457   Mon Dec 28 12:35:57 2009 JenneUpdateSUSMC2 is having a bad day

MC2 is having a bad day, and I'm not yet sure why.  It's to do with the damping though.  When the damping is off, after a little while it will settle to ~30mV or so on the Watchdog screen.  When I enable all of the outputs and then turn on the damping, the optic gets kicked up.  It's like there's a minus sign error somewhere, maybe in a bad burtrestore?  This has been going on since I did my morning bootfest.

It's started to sit down and play nicely now.  Is someone doing magic remotely that is fixing things that I hadn't figured out yet?

  2456   Mon Dec 28 10:29:31 2009 JenneUpdateComputersMonday Morning Bootfest

Nothing like a good ol' Bootfest to get back into the swing of things after vacation....

It was a regular bootfest, keying crates and running everyone's startup.cmd .  There wasn't any RFM funny business which we had been dealing with a lot earlier in December (maybe Kiwamu took care of that part of things last night).

After finishing the bootfest, I tried to re-enable the watchdogs.  I noticed that the optics weren't damping at all (not that any of them were swinging crazily, they just weren't damped like regular).  This was traced to the OSEM sensor inputs and outputs being disabled on all of the suspensions' screens.  I suspect that no burt-restoring happened after c1dcuepics was powercycled yesterday. 

All of the optics are now happy as clams.

  2455   Mon Dec 28 01:17:01 2009 KojiUpdateElectronicsMCT QPD investigation

Unfortunately, the signals for individual segments also suffer from the voltage drop as all of the low impedance amplifiers are hung from the same input.
In order to utilize the individual channels, we anyway have to remove the resistors for the VERT/HOR/SUM amps.
That is possible. But does it disable some fast channels for future ASC purposes?

 

Quote:

 This is indeed sad. But, we can perhaps bypass all of this by just using the individual segment outputs. According to the circuit diagram and the c1iool0 .db file, we should be able to just do the math on the segments and ignore the VERT/HOR/SUM signals completely. In that case, we can just use high impedance for the sum/diff buffers as Koji says and not suffer from the calibration errors at all I think.

 

  2454   Sun Dec 27 23:44:59 2009 ranaUpdateElectronicsMCT QPD investigation

Quote:

I found that MCT QPD has dependence of the total output on the position of the spot. Since the QPD needs the supply and bias voltages from the sum/diff amp, I could not separate the problems of the QPD iteself and the sum/diff amplifier by the investigation on Tuesday. On Wednesday, I investigated a generic quad photodiode interface module D990692.

 This is indeed sad. But, we can perhaps bypass all of this by just using the individual segment outputs. According to the circuit diagram and the c1iool0 .db file, we should be able to just do the math on the segments and ignore the VERT/HOR/SUM signals completely. In that case, we can just use high impedance for the sum/diff buffers as Koji says and not suffer from the calibration errors at all I think.

  2453   Sun Dec 27 20:05:28 2009 kiwamuUpdateComputerscan not communicate with front-ends

In this evening I found that fb40m has been down, then I restarted fm40m successfully.

However there still is a problem, the reflective memory can not communicate with some front-end CPUs ( such as c1iscey, c1susvme, ...etc.)

Right now I don't have any ideas about this, I am leaving them as they are now .... we can deal with them tomorrow. 


The followers are what I did.

(1) ssh to fb40m then "pkill tpman"

(2) telnet to fb40m then typed "shutdown". ( These procedure are on the 40m wiki)

(3) make sure fb40m gets recovered while watching the medm screen C0DAQ_DETAIL.adl

(4) run the backup script in fb40m

(5) in order to fix the communication problem, physically turn off c1dcuepics and c0daqctrl

(6) keying some front-end CPUs. ---> still some of front ends indicate RED on the medm screen C0DAQ_DETAIL.adl ( figure attached )

 

 

Attachment 1: C0DAQ_DETAIL.png
C0DAQ_DETAIL.png
  2452   Sat Dec 26 19:22:13 2009 KojiSummaryGeneralMode coupling of two astigmatic beams

In this note, amplitude and power couplings of two astigmatic (0,0)-th order gaussian modes are calculated.

Attachment 1: mode_coupling.pdf
mode_coupling.pdf mode_coupling.pdf
  2451   Thu Dec 24 19:13:29 2009 KojiUpdateIOOMCT QPD investigation

I found that MCT QPD has a dependence of the total output on the position of the spot. Since the QPD needs the supply and bias voltages from the sum/diff amp, I could not separate the problems of the QPD itself and the sum/diff amplifier by the investigation on Tuesday. On Wednesday, I investigated a generic quad photodiode interface module D990692.

...I was so disappointed. This circuit was left uninvestigated and used so long time with the following sorrowful conditions.
- This circuit has 4 unbuffered inputs with input impedance of 300~400 Ohm. It's way too low!
- Moreover, those channels have different input impedances. Ahhhh.
- Even worse, the QPD circuit D990272 has output impedance of 50 Ohm.
- The PCB of this circuit has four layers. It is quite difficult to make modifications of the signal route.
- It is a headache: this circuit is "generic" and used in many places.

D990692 has 4 channel inputs that are not buffered. Each channel has two high impedance buffers but they are used only for the monitors. The signal paths have no buffer.

The differential amplifier is formed by R=1k Ohm. The inverted side of the input has 1kOhm impedance. The non-inverted side has 1.5kOhm impedance.

CH1: 10K // 1.5k // 1.5k // 1k = 411 Ohm
CH2: 10K // 1.5k // 1k // 1k = 361 Ohm
CH3: 10K // 1k // 1k // 1k = 323 Ohm
CH4: 10K // 1k // 1.5k // 1k = 361 Ohm

Considering the output impedance of 50Ohm for the QPD, those too low input impedances result in the following effect:
- Because of the voltage division, we suffer absolute errors of 10.8~13.4%. This is huge.
- Because of the input impedance differences, we suffer a relative error of 1.5%~3%. This is also huge.

Unfortunately, the circuit has no room to modify; the signal paths are embedded in the internal layer.

I decided to replace the resistors of the sum/diff amps from 1k to 10k. Also the input impedance of the buffer was removed as the input is terminated by the sum/diff amps in any case.This changes the input inpedance to the followings:

CH1: 15k // 15k // 10k = 4286 Ohm
CH2: 15k // 10k // 10k = 3750 Ohm
CH3: 10k // 10k // 10k = 3333 Ohm
CH4: 10K // 15k // 10k = 3750 Ohm

These yield the absolute error of 1.2-1.5%. The relative error is now 0.3%. I can accept these numbers, but later I should put additional terminating resistors to compensate the differencies.

So far I have modified the resistors for the MCT as the modification for a QPD needs 17 10k resistors.
Next thing I have to check is the dependence of the QPD outputs on the spot positions.

-----------------------------------------------

Edit: Feb 11, 2010

I talked with Frank and he pointed out that the impedances are not the matter but the gains of the each channels are the matters (after considering the output impedance of the QPD channels).
If we assume the ideal voltage sources at the QPD and the symmetric output impedances of 50Ohm, the gain of the each circuit are affected but the change should be symmetric.

He found that several things:
- The analog switch (MAX333) used in the QPD unit adds more output impedance (somewhat randomly!).
- The resistance of the sum/diff circuits may vary each other unless we use 0.1% resistors.

 

Attachment 1: D990692.png
D990692.png
  2450   Thu Dec 24 01:25:29 2009 kiwamuUpdateElectronicsimpedance analyzing

The validation for high impedance measurement has been well done.

The impedance measurement is one of the keys for designing the EOM circuit.

So far I was very struggling to measure the high impedance ( above several 1000 Ohm) at RF because the EOM circuit has a high impedance at its resonance.

Finally I realized that the measured impedance was suppressed by a parasitic resistance, which especially reduces the impedance at the resonance.

Also I found that we can extract the TRUE impedance data by subtracting the effect of the parasitic resistance from resultant data.

In order to confirm whether this subtraction works correctly or not,  the impedance was directly re-measured with another analyzer for crosscheck.

                The followers are details about the re-measurement.
 

 

(measurement )

The measurement has been performed with help from Peter and Frank. ( Thank you !)

By using  network analyzer AG4395A with the impedance test kit AG43961A (these are at the PSL lab.), the impedance of resonant circuit with EOM was measured.

The picture of setup is attached. This impedance test kit allows to measure typically 0.1 [Ohm]-1M [Ohm] and frequency range of 100kHz-500MHz.

 

(result)
The resultant plot is attached. In the plot the blue curve represents the impedance measured by usual analyzer at 40m.

Note this curve is already subtracted the effect of the parasitic resistance.

( the parasitic resistance is in parallel to the circuit and it has ~7.8k Ohm, which is measured while the probe of the analyzer stays open. )

The red curve is the re-measured data using the impedance test kit.

The important point is that; these two peak values at the resonance around 40MHz show good agreement in 10%.

The resonant frequencies for two data differs a little bit, which might be the effect of a stray capacitance ( ~several [pF] )

The red curve has a structure around 80MHz, I think this comes from the non-coaxial cables, which connect the circuit and analyzing kit.

You can see these cables colored black and red in the picture.

 

( conclusion )

Our measurement with the subtraction of the  parasitic resistance effect is working reliably !

Attachment 1: DSCN0421.JPG
DSCN0421.JPG
Attachment 2: EOM.png
EOM.png
  2449   Wed Dec 23 17:33:14 2009 ranaUpdateASSOAF Feedaround ON and doing something good

The Rai box ran out of batteries a couple of days ago and so the data is no good. I've put the Ranger back on the SR560 for now (but with the damping resistor removed, so the gain is 2x more than before).

  2448   Wed Dec 23 16:34:25 2009 KojiUpdateIOOMCT QPD/MC REFL QPD disabled

For a certain investigation of the sum/diff module for MCT QPD/MC REFL QPD, I removed it from the system.

 

  2447   Tue Dec 22 18:42:40 2009 Sanjit, KojiConfigurationAdaptive FilteringReadded DAQ channels to active list

Sometimes back we modified /cvs/cds/caltech/chans/daq/C1ASS.ini to save some of the channels. The file was reverted to default after the recent changes in ASS.

We again uncommented and made acquire=1 to save the following three channels using daqconfig:

C1:ASS-TOP_ERR_MCL_IN1_2048

C1:ASS-TOP_PEM_15_IN1_2048

C1:ASS-TOP_PEM_18_IN1_2048

The script automatically created a back up in /cvs/cds/caltech/chans/daq/archive

 

  2446   Tue Dec 22 15:49:31 2009 kiwamuUpdateGenerale-log restarted

I found the e-log has been down around 3:40pm, then I restarted the e-log. Now it's working.

Thanks.

  2445   Tue Dec 22 13:14:37 2009 AlanOmnistructurePEMmiracle in the 40m

Quote:

We have been waiting for this for 20 some years. Arrowhead water with cooler. AWESOME

THANKS Alan

 Happy holidays, everyone!

 

  2444   Tue Dec 22 11:23:51 2009 kiwamu, SteveUpdateIOOMC relocked

In this morning I found MC unlocked.

Steve restored the watchdogs before I found that.

Then I relocked MC and now MC is locked and working well.

The reflected DC power is ~0.38, which is usual number.

 

  2443   Tue Dec 22 10:04:41 2009 steveOmnistructurePEMmiracle in the 40m

We have been waiting for this for 20 some years. Arrowhead water with cooler. AWESOME

THANKS Alan

Attachment 1: h2oo.JPG
h2oo.JPG
  2442   Tue Dec 22 02:50:09 2009 rana, kiwamu, jenneUpdateASSOAF Feedaround ON and doing something good

Kiwamu made the OAF screen functional today - screenshot attached.

After this, I used the measured TF of the MC1 to MCL to filter the signals from the Wilcoxon accelerometers and feed them into the MC.

The noise at 3 Hz went down by a factor of ~3. There's a little excess created at 100 Hz. Its good to see that our intuition about feed-forward is OK.

I did all of the filter calculations by adapting the scripts that Haixing, Valera, and I got going at LLO. They're all in the mDV/extra/C1 SVN.

 

The Wiener code predicts much better performance from using more than just 2 horizontal accelerometers, but I was too lazy to do more channels today.

I also added the Rai box to the Ranger readout today - the noise at 0.1 Hz went down by a factor of 10 and the noise at 1 Hz is close to 10^-11 m/rHz.

Attachment 1: oaf.png
oaf.png
Attachment 2: oaf.png
oaf.png
ELOG V3.1.3-