40m QIL Cryo_Lab CTN SUS_Lab TCS_Lab OMC_Lab CRIME_Lab FEA ENG_Labs OptContFac Mariner WBEEShop
  40m Log, Page 280 of 339  Not logged in ELOG logo
ID Date Authorup Type Category Subject
  2107   Fri Oct 16 18:46:36 2009 ranaConfigurationASCloop opened on PZT2 YAW at 3:40 pm

Quote:

I pushed the "closed loop" button on PZT2 YAW around 3:40 pm today, then roughly recentered it using the DC Offset knob on the PiezoJena controller and the IP ANG QPD readbacks.  There was a large DC shift.    We'll watch and see how much it drifts in this state.

 Here's the trend.

The transient at ~22:40 is Rob switching to 'Open Loop' on the Piezo Jena PZTs. I don't see any qualitative change in the drift after this event.

At 05:55 UTC, I removed an iris that was blocking the IP POS beam (the sum goes up from 2 to 6.5) without disturbing the mirrors who's oplev beam are on that table. Steve has conceded one sugar Napoleon after betting against my ninja-like iris skills.

We should recenter the beam on IP POS now that its unclipped - I'll let it sit this way overnight just to get more drift data.

Attachment 1: Untitled.png
Untitled.png
  2109   Sun Oct 18 16:09:34 2009 ranaConfigurationASCloop opened on PZT2 YAW at 3:40 pm

 

I wanted to see how long our IP POS beam has been badly clipped - turns out its since April 1, 2007.

Steve's April Fool's joke is chronicled then. The attached trend shows that the drop in IP POS is coincident with that event.

In trying to align IPPOS, I noticed that someone has placed a ND2.0 filter (factor of 100 attenuation) in front of it. This is kind of a waste - I have removed IPPOS to fix its resistors and avoid this bad optic. Also the beam coming onto the table is too big for the 1" diameter optics being used; we need to replace it with a 2" diamter optic (Y1-2037-45P).

 

IP ANG dropped by a factor of 2 back in early August of '08.

We need this guy on the investigation:

 

Attachment 1: a.png
a.png
  2110   Sun Oct 18 19:55:45 2009 ranaConfigurationElectronicsIP POS is back: ND filter gone, new resistors in

Its back in and re-centered. Our next move on IPPOS should be to replace its steering mirror with something bigger and more rigid.

Electronics changes:

20K -> 3.65 K  (R6, R20, R42, R31) (unused)

20K -> 3.65 K  (R7, R21, R32, R43, R11, R24, R35, R46)

If you look in the schematic (D990272), you see that its an AD797 transimpedance stage with a couple of LT1125 stages set to give some switchable gain. It looks like some of these

switches are on and some are not, but I am not sure where it would be controlled from. I've attached a snapshot of one quadrant of the schematic below.

The schematic shows the switches in the so-called 'normally closed' configuration. This is what the switches do with zero volts applied to the control inputs. As the schematic also shows,

just disconnecting the 'switch' inputs cause the switch's control inputs to go high (normally open configuration, i.e. pins 2-3 connected, pin4 open). For the record, the default positions of the IPPOS switches are:

switch1   high

switch2   low

switch3   low

switch4   high

 


** EDIT (Nov 2, 2009): I forgot to attach the before and after images; here they are:

IMG_0068.JPGIMG_0072.JPG

  2112   Sun Oct 18 22:06:15 2009 ranaConfigurationElectronicsIP POS is back: ND filter gone, new resistors in

I tried to compare the IP_POS time series with the IPANG and MC_TRANS but was foiled at first:

1) The IPANG scan rate was set to 0.5 second, so it doesn't resolve the pendulum motions well. Fixed in the .db file.

2) Someone had used a Windows/DOS editor to edit the .db file and it was filled with "^M" characters. I have removed them all using this command:   tr -d "\r" <ETMXaux.db > new.db

3) The MC_TRANS P/Y channels were on the MC Lock screen but had never been added to the DAQ. Remember, if there's a useful readback on an EPICS screen. its not necessarily in the frames unless you add it to the C0EDCU file. I have done that now and restarted the fb daqd. Channels now exist.

4) Changed the PREC of the IPPOS channels to 3 from 2.

5) changed the sign for the IBQPD (aka IPANG) so that bigger signal is positive on the EPICS screen.

Attachment 1: Untitled.png
Untitled.png
  2139   Sat Oct 24 04:57:33 2009 ranaUpdateloremarconi phase

Quote:

So, it appears that one doesn't even have to change the Marconi set frequency to alter the phase of the output signal.  It appears that other front panel actions (turning external modulations on/off, changing the modulation type) can do it as well.  At least that's what I conclude from earlier this morning, when after setting up the f2 Marconi (166MHz) for external AM, the double-demod handoff in the DRMI no longer worked.  Luckily this isn't a real problem now that we have the setDDphases and senseDRM scripts. 

 The real problem is that we are using frequency synthesizers to make the beat signals (133 and 199) instead of mixers. Luckily, the future 40m will not use beat signals (?) or synthesizers.

  2157   Wed Oct 28 17:20:21 2009 ranaSummaryCOCETM HR reflectivity plot

This is a plot of the R and T of the existing ETM's HR coating. I have only used 1/4 wave layers (in addition to the standard 1/2 wave SiO2 cap on the top) to get the required T.

The spec is a T = 15 ppm +/- 5 ppm. The calculation gives 8 ppm which is close enough. The calculated reflectivity for 532 nm is 3%. If the ITM reflectivity is similar, the signal for the 532 nm locking of the arm would look like a Michelson using the existing optics.

etm_40_1998.png

  2178   Thu Nov 5 05:07:22 2009 ranaUpdateLSCX Arm Cavity transfer Function

I would have guessed that you have to calibrate the detectors relative to each other before trying this. Its also going to be tricky if you use 2 different kinds of ADC for this (c.f. today's delay discussion in the group meeting).

I think Osamu used to look at fast transmission signals by making sure the PD at the end had a 50 Ohm output impedance and just drive the 40m long cable and terminate the receiving end with 50 Ohms. Then both PDs go into the SR785.

 

  2206   Mon Nov 9 01:52:56 2009 ranaUpdatePEMcoherence v. time for 2 accelerometers

I used the coh_carpet.m function from the mDV to calculate this plot:

coh_carpet('C1:PEM-ACC_MC1_X','C1:PEM-ACC_MC2_X',gps('now - 3 days'),3600*12,4,10,64)

It shows the coherence v. time of two of our X-direction accelerometers starting around 1AM on Friday and going for 12 hours.

I'm not sure what it means exactly, but it looks like the coherence is relatively steady as a function of time. I will need more RAM than Rosalba or a smarter code to calculate longer time stretches.

Attachment 1: coh.png
coh.png
  2231   Tue Nov 10 21:46:31 2009 ranaSummaryComputersTest Point Number Mapping

Quote:

I found this interesting entry by Rana in the old (deprecated) elog : here

I wonder if Rolf has ever written the mentioned GUI that explained the rationale behind the test point number mapping.

I'm just trying to add the StochMon calibrated channels to the frames. Now I remember why I kept forgetting of doing it...

 As far as I know, the EPICS channels have nothing to do with test points.

  2247   Thu Nov 12 02:02:18 2009 ranaSummaryLSCArm Locking with no feedback to the ETM or ITM

Steps:

1) Turn off feedback to ETMY (the ETMY button on the LSC screen).

2) Put a 1 into the YARM->MC2 output matrix element on the LSC screen.

3) Turn off FM6 (comb), FM7 (0.1:10) on the MC2_MCL filter bank. This is to make the IOO-MCL loop more stable and to reduce the IOO-MCL low frequency gain.

4) Set the MC2-LSC gain to 0.5, turn the output ON, turn ON FM4 & FM5 & FM6 of the MC2-LSC filter bank.

5) Turn on the input of MC2-LSC and the arm should now lock.

6) After locking, set the MC2-MCL gain to zero. Hopefully with a few second ramp time.

Voila!

(A comment by KA - c.f. this entry )

Attachment 1: nohands-2.pdf
nohands-2.pdf
  2283   Tue Nov 17 15:54:34 2009 ranaSummaryPEM40 days of weather

the inside temperature is alarming at the red level today - should check if the HIHI value is set correctly

Attachment 1: Untitled.pdf
Untitled.pdf
  2286   Tue Nov 17 21:10:35 2009 ranaSummaryElectronicsBusby Low Noise Box: Photos and Upgrades

IMG_0217.JPG

It looked like the Busby Low Noise Box had too much low frequency noise and so I upgraded it. Here is a photo of the inside - I have changed out the 0.8 uF AC coupling cap with a big, white, 20 uF one I found on Rob's desk.

The Busby Box is still working well. The 9V batteries have only run down to 7.8V. The original designer also put a spare AD743 (ultra low current FET amp) and a OP27 (best for ~kOhm source impedances) in there.

Here's the noise after the fix. There's no change in the DC noise, but the AC noise is much lower than before:

busby-noise.png

I think that the AC coupled noise is higher because we are seeing the current noise of the opamp. In the DC coupled case, the impedance to ground from the input pins of the opamp is very low and so the current noise is irrelevant.

The change I implemented, puts in a corner frequency of fc = 1/2/pi/R/C = 1/2/pi/10e3/20e-6 = 0.8 Hz.

Overall, the box is pretty good. Not great in terms of current noise and so it misses getting an A+. But its easily a solid A-.

  2288   Wed Nov 18 00:38:33 2009 ranaSummaryElectronicsVoltage Noise of the SR560's OUTPUTs (the back panel)

I've measured the voltage noise of the SR560's lead acid battery outputs; they're not so bad.

Steve ordered us some replacement lead-acid batteries for our battery powered pre-amps (SR560). In the unit he replaced, I measured the noise using the following setup:

SR560                              Busby Box

(+12V/GND) -------------AC Input      Out  ----------------   SR785

The SR785 was DC coupled and auto-ranged. The input noise of the SR785 was measured via 50 Ohm term to be at least 10x less than the SR560's noise at all frequencies.

sr560.png

Its clear that this measurement was spoiled by the low frequency noise of the Busby box below 10 Hz. Needs a better pre-amp.

  2289   Wed Nov 18 01:12:15 2009 ranaUpdatePEMseismometers were not saturating during Halloween weekend
Attachment 1: Untitled.png
Untitled.png
  2304   Fri Nov 20 00:18:45 2009 ranaSummaryCamerasVideo MUX Selection Wiki page

Steve is summarizing the Video Matrix choices into this Wiki page:

http://lhocds.ligo-wa.caltech.edu:8000/40m/Electronics/VideoMUX

Requirements:

Price: < 5k$

Control: RS-232 and Ethernet

Interface: BNC (Composite Video)

Please check into the page on Monday for a final list of choices and add comments to the wiki page.

  2319   Tue Nov 24 08:00:16 2009 ranaUpdateLSCMeasured MC length

I propose that from now on, we indicate in the elog what frequencies we're referring to. In this case, I guess its the front panel readback and not the frequency counter -- what is the frequency counter readback? And is everything still locked to the 10 MHz from the GPS locked Rubidium clock?

Plus, what FSS Box? The TTFSS servo box? Or the VCO driver? As far as I know, the RC trans PD doesn't go through the FSS boxes, and so its a real change. I guess that a bad contact in the FSS could have made a huge locking offset.

 

  2335   Wed Nov 25 16:13:27 2009 ranaUpdatePSLMeasured MC length--FSS trend

but the increase in both the RCtrans and the RCrefl is consistent with my theory that the power going to the RC has increased ; its not just an increase in the visibility.

We should scan the AOM/VCO to make sure the frequency is matched to the resonance to within 0.5 dB.

  2342   Fri Nov 27 02:25:26 2009 ranaUpdateABSLPLL Open Loop Gain Measured

Quote:

I measured the open loop gain of the PLL in the AbsL experiment.

 Plots don't really make sense. The second one is inherently unstable - and what's g?

  2398   Fri Dec 11 14:12:32 2009 ranaConfigurationLSC166 LO Disconnected

 

 Seems like very strange cable loss numbers. The Heliax is lossier than the RG-174? I wonder how these compare with the specs in the cable catalog?

  2403   Sat Dec 12 07:36:56 2009 ranaHowToElectronicsHow to Measure the Length of a Cable: Interferometry

Need to measure the length of the cable, but too lazy to use a measuring tape?

Then you too can become an expert cable length measurer by just using an RF signal generator and a scope:

  1. Disconnect or short (not 50 Ohm term) the far side of the cable.
  2. Put a T on the near side of the cable.
  3. Drive the input of the T with your signal source.
  4. Look at the output of the T with the scope while sweeping the signal source's frequency knob.

The T is kind of acting like a beamsplitter in an asymmetric length Michelson in this case. Just as we can use the RF phase shift between the arms to measure the Schnupp asymmetry, we can also use a T to measure the cable length. The speed of light in the cable is documented in the cable catalog, but in most cases its just 66% of the speed of light in the vacuum.

  2406   Sun Dec 13 20:50:45 2009 ranaSummaryIOOMach Zender Calibration

I ramped the MZ PZT (with the loop disabled on the input switch) to calibrate it. Since the transmission has been blocked, I used the so-called "REFL" port of the MZ to do this.

The dark-to-dark distance for the MZ corresponds to 2 consecutive destructive interferences. Therefore, that's 2 pi in phase or 1 full wavelength of length change in the arm with the moving mirror.

Eyeballing it on the DTT plot (after lowpassing at 0.1 Hz) and using its cursors, I find that the dark-to-dark distance corresponds to 47.4 +/- 5 seconds.

So the calibration of the MZ PZT is 88 +/- 8 Volts/micron.

Inversely, that's a mean of 12 nm / V.

why am I calibrating the MZ? Maybe because Rob may want it later, but mainly because Koji won't let me lock the IFO.

Apparently, we haven't had a fast channel for any of the MZ board. So I have temporarily hooked it up to MC_DRUM at 21:13 and also turned down the HEPA. Now, let's see how stable the MZ and PMC really are overnight.

EDIT: it railed the +/- 2V ADCwe have so I put in a 1:4 attenuator via Pomona box. The calibration of MC_DRUM in terms of MZ_PZT volts is 31.8 cts/V.

So the calibration of MC_DRUM1 in meters is: 0.38 nm / count


Attachment 1: Untitled.png
Untitled.png
  2407   Sun Dec 13 23:18:09 2009 ranaSummaryIOODisplacement noise on the PSL table

For the Laser Gyro, I wondered how much mechanical noise we might get with a non-suspended cavity. My guess is that the PMC is better than we could do with a large ring and that the MZ is much worse than we could do.

Below 5 Hz, I think the MZ is "wind noise" limited. Above 10 Hz, its just ADC noise in the readout of the PZT voltage.

Attachment 1: mz.pdf
mz.pdf
  2417   Tue Dec 15 00:02:10 2009 ranaUpdatePEMNoise of the Ranger SS-1 Seismometer

I wanted to see what the noise of the Ranger seismometer should be. I used LISO and file ranger.fil (in our LISO SVN) to calculate the voltage noise referred to the input. In this model, we represent the EMF from the moving magnet in the coil as a voltage source at 'nin' which drives the coil impedance. This is the same approach that Brian Lantz uses in his noise modeling of the GS-13 (PDF is on our Ranger wiki page).

In the simulation, I used the OP27 as a placeholder for the SR560 that we use (I don't know the current noise of the SR560). To do this, I use the new 'inputnoise' feature in LISO (its in the README, but not in the manual).

You can see that we would be limited by the input current noise of the OP27. So we would do a lot better if we used an FET based readout amp like the AD743 (or equivalent) or even better using the new multi-FET readout circuit that Rich Abbott has developed. Clearly, its also silly to have a load resistance in there - I put it in because the manual says to do it, but all it does is damp the mass and reduce the size of the signal.

#  Noise sim for the Ranger SS-1 seismometer
#
#                            \
#                           | \            
#           n2- - - ----  - |  \          
#            |    |         | op1>-- n4 - r4 -- no
#           Rg   RL     n3- |  /     |           
#       n1 - |    |     |   | /      |                
#           Lg    |     |    /       |                        
#            |    |     | - - - R2 - -                    
#           nin  gnd   R1 
#                       |
#                      gnd

We previously measured the Ranger's self noise by locking it down.

The 1/f^3 noise that we see below 1 Hz is roughly consistent with the noise model: to get from my plot into meters you have to multiply by:

(1 + f)^2

----------

340 * f^2

P.S. Secret PDF handshake: You can make your non-compliant applications like LISO or DTT produce a thumbnailing PDF by using Acrobat to open the file and export it as PDF/A.

In the second attachment, I have used an OPA827 (new low-noise FET input amp from TI) as the readout amplifier. This seems like a good choice - main drawback is that Digikey backordered my OPA827s by 19 weeks!

Attachment 1: rangerx.pdf
rangerx.pdf
Attachment 2: ranger827.pdf
ranger827.pdf
  2423   Wed Dec 16 11:55:47 2009 ranaUpdateABSLUniversal PDH Box Servo Filters

 

 To me, they both look stable. I guess that the phase has to go to -180 deg to be unstable.

Why does the magnitude go flat at high frequencies? That doesn't seem like 1/f.

How about a diagram of what inputs and outputs are being measured and what the gain knob and boost switch settings are?

  2424   Wed Dec 16 20:29:08 2009 ranaUpdateCOCETM Coating study

This plot shows the Transmission for 532 and 1064 nm as a function of the thickness of the SiO2 layer.

i.e. the thickness is constrained so that the optical thickness of the SiO2 and Ta2O5 pair is always 1/2 of a wavelength.

The top layer of the mirror is also fixed in this plot to be 1/2 wave.

This plot shows the result for 17 pairs. For 16 pairs, we are unable to get as low as 15 ppm for the 1064 nm transmission.

Attachment 1: layerfrac.png
layerfrac.png
  2430   Thu Dec 17 23:27:23 2009 ranaUpdatePEMRanger Noise: sim w. Rai FET box as readout

I have started measuring the low frequency noise of the FET front end + LT1128 low noise preamp from Rai Weiss. It has a very low input current noise because its FET based, which is not surprising. It is also a fairly low voltage noise box - the best measured ones have an input referred noise of ~0.35 nV/rHz.

Today I measured the noise of the one we have down to 0.1 Hz. It looks like a good candidate for a Geophone readout (e.g. Ranger or GS-13 or perhaps the L-4C). Because I didn't thermally shield any of this stuff, the broadband noise is ~0.8 nV/rHz. The low frequency corner is ~15 Hz.

I attach the LISO simulation of the voltage noise referred to the input. The circuit is described in this entry.

We can probably do better than this if we package it a little better or give it time to warm up or use metal film resistors inside. Even as it is, however, it would allow us to reach the thermal noise of the Ranger (or GS-13) down to 0.1 Hz.

This should be ~1.5 or 2x better than the LT1012 based readout at 1 Hz and 10x better down at 0.1 Hz (c.f. T0900457).

Attachment 1: ranger.pdf
ranger.pdf
  2436   Mon Dec 21 01:14:08 2009 ranaSummaryElectronicsNoise measurement of the Rai Weiss FET preamp box

 I shorted the input to the box and then put its output into the SR560 (low noise, G = 100, AC). I put the output of the SR560 into the SR785.

*** BTW, the 2nd channel of the SR785 is kind of broken. Its too noisy by a factor of 100. Needs to go back for repair once we get started in the vac.

The attached PNG shows its input-referred noise with the short.

The picture shows the inside of the box before I did anything. The TO-5 package metal can is the meaty super dual-FET that gives this thing all of its low noise power.

Picture_2.pngRWnoise.png

In the spectra on the right are two traces. The BLUE one is the noise of the box as I found it. The BLACK one is the noise after I replaced R1, R6, R7, & R10 with metal film resistors.

The offset at the output of the box with either an open or shorted input is +265 mV.

I think we probably should also replace R2, R3, & R1, but we don't have any metal film resistors lower than 100 Ohms in the kit...but hopefully Steve will read this elog and do the right thing.

Attachment 1: IMG_0242.JPG
IMG_0242.JPG
  2441   Mon Dec 21 19:24:29 2009 ranaUpdateASSOAF Model update and build instructions

I fit the MC1 -> MCL TF using vectfit4.m (from mDV). The wrapper file is mDV/extra/C1/ fitMC12MCL.m.

Plotted here are the data (RED), the fit (BLUE), and the residual x10 (GREEN).

For the magnitude plot, residual is defined as ------   res = 1 - fit / data

For the phase plot the residual is defined as -------    res =  phase(data)-phase(fit)

You can see that the agreement is very good. The phase match is better than 5 deg everywhere below 10 Hz.

This TF is so smooth that we could have probably done without using this, but its good to excercise the method anyway.

Attachment 1: mc12mcl.png
mc12mcl.png
  2449   Wed Dec 23 17:33:14 2009 ranaUpdateASSOAF Feedaround ON and doing something good

The Rai box ran out of batteries a couple of days ago and so the data is no good. I've put the Ranger back on the SR560 for now (but with the damping resistor removed, so the gain is 2x more than before).

  2454   Sun Dec 27 23:44:59 2009 ranaUpdateElectronicsMCT QPD investigation

Quote:

I found that MCT QPD has dependence of the total output on the position of the spot. Since the QPD needs the supply and bias voltages from the sum/diff amp, I could not separate the problems of the QPD iteself and the sum/diff amplifier by the investigation on Tuesday. On Wednesday, I investigated a generic quad photodiode interface module D990692.

 This is indeed sad. But, we can perhaps bypass all of this by just using the individual segment outputs. According to the circuit diagram and the c1iool0 .db file, we should be able to just do the math on the segments and ignore the VERT/HOR/SUM signals completely. In that case, we can just use high impedance for the sum/diff buffers as Koji says and not suffer from the calibration errors at all I think.

  2471   Sun Jan 3 08:23:39 2010 ranaConfigurationCDSautoburt.pl 'fixed' for post 2009 years

Tobin & Keith pointed out in the LLO ilog that there was a code bug in the autoburt.pl script for autoburts.

I edited the autoburt.pl script so that it will work from now until 2099 (by which time we may no longer be using this version of perl):

nodus:autoburt>diff autoburt.pl~ autoburt.pl
234c234
<     $thisyear = "200".$timestamp[5];
---
>     $thisyear = "20".$timestamp[5];

The autoburt has not been working ever since 11PM on New Year's eve.

I ran it by hand and it seems to run fine. I noticed along the way that it was running on op340m (our old Sun Blade 150 machine). The autoburt.pl was pointing at /cvs/cds/bin/perl

which is Perl v5.0. I changed it to use '/usr/bin/env' and now points at '/usr/bin/perl' which is perl 5.8. It runs fine with the new perl:

op340m:scripts>time perl /cvs/cds/scripts/autoburt.pl >> /cvs/cds/caltech/logs/autoburtlog.log
5.37u 6.29s 2:13.41 8.7%

Also ran correctly, via cron, at 9AM.

  2472   Mon Jan 4 09:52:40 2010 ranaConfigurationCamerasITMX camera and PSL channels

I fixed up the ITMX camera like we did for ITMY recently (removed T's and added strain relief - the lens was already OK).

I also updated the .SCAN field for the RMTEMP and RCTEMP channels to 0.1 second. This had been done via probe but was wiped out after reboot previously, because I forgot to update the psl.db file.

  2478   Tue Jan 5 11:00:04 2010 ranaOmnistructureEnvironmentAdded new wall cable-racks

Quote:

we hung two new WALL cable racks. One is on the pillar next to the Sp table, the other is next to the PSL computer rack.

 awesome - I have ordered 5 blue racks so that we can hang power cables. The fat BLUE ones are for fat cables and the orange ones for the coax cables.

  2518   Sun Jan 17 05:22:42 2010 ranaConfigurationComputersELOG script change

With Dave Barker's help, I changed the elog startup script. Instead of running as a Daemon with the -D option,

it now runs in the background with the unix "&". I think that the stdout and stderr are now redirected to a log file called elog.log.

We can 'tail -f' this file to see what its up to and debug any future crashing.

  2524   Tue Jan 19 00:10:44 2010 ranaUpdateElectronicstriple resonant circuit for EOM

Very cool.         

  2547   Tue Jan 26 03:28:56 2010 ranaUpdateABSL166 MHz sideband turned off

 

 You can turn the 166 off if you want. MZ is unhappy after its turned off, but that's just the thermal transient from removing the RF heat. After a several minutes, the heat goes away and the MZ can be relocked.

One of these days we should evaluate the beam distortion we get in EOMs because of the RF heat induced dn/dT. Beam steering, beam size, etc.

  2549   Tue Jan 26 20:18:32 2010 ranaConfigurationALARMop540m: alarms and BLRMS and StripTool restored

I turned the StripTool and ALARMS and BLRMS back on on op540m. Looks like it has been rebooted 5 days ago and no one turned these back on. Also, there was a bunch of junk strewn around its keyboard which I restrained myself from throwing in the trash.

The BLRMS trends should be active now.

  2569   Thu Feb 4 00:59:52 2010 ranaUpdateelogelog restarted

 I restarted the ELOG on NODUS just now. Our attempt to set up error logging worked - it turns out ELOG was choking on the .ps file attachment.

So for the near future: NO MORE .PS files! Use PDF - move into the 20th century at least.

matlab can directly make either PNG or PDF files for you, you can also use various other conversion tools on the web.

Of course, it would be nice if nodus could handle .ps, but its a Solaris machine and I don't feel like debugging this. Eventually, we'll give him away and make the new nodus a Linux box, but that day is not today.

  2593   Thu Feb 11 19:20:44 2010 ranaUpdateComputersStatus of the IP change over

After Joe left:

  1. Turned on op440m and returned him his keyboard and mouse.
  2. Damped MC2.
  3. Opened PSL shutter - locked PMC, FSS,
  4. Started StripTool displays on op540m.
  5. op340m doesn't respond to ping from anyone.
  6. started FSS  SLOW and RCPID scripts on op540 - need to kill and restart on op430m.
  7. ASS wouldn't come up - it doesn't know who linux1 is.
  8. MC autolocker wouldn't run on op540m because of a perl module issue, started it on op440m - it needs to be killed and restarted on op430m.
  9. probably mafalda, linux2, and op430m need some attention - they are all in the same rack.

As of 7:18 PM, the MC is locked and the PSL seems normal + all suspensions are damped and the ELOG is back up as well as the SVN.

  2620   Sun Feb 21 17:44:35 2010 ranaUpdateGeneralPrep for Power Supply Stop
  • Turned on the RAID attached to linux1 (its our /cvs/cds disk)
  • Turned on linux1 (it needed a keyboard and monitor in order to be happy - no fsck required)
  • Turned on nodus (and started ELOG) + all the control room machines
  • Turned on B/W monitors
  • Untaped fridge


  • Found several things OFF which were not listed in the Wiki...
  • Turned ON the 2 big isolation transformers (next to Steve's desk and under the printer). These supply all of the CDS racks inside.
  • ~75% of the power strips were OFF in the CDS racks ?? I turned on as many as I could find (except the OMC).
  • Switched on and keyed on all of the FE and SLOW crates in no particular order. Some of the fans sound bad, but otherwise OK.
  • Turned on all of the Sorensens that are labeled.
  • Turned ON the linear supplies close to the LSC rack.
  • ON the Marconis - set them according to the labels on them (probably out-dated).
  • After restoring power to the PSL enclosure (via the Isolation Transformer under the printer) turned the Variac ON and HEPA on full speed.
  • Plugged in the PSs for the video quads. Restored the Video MUX settings - looks like we forgot to save the correct settings for this guy...


PSL


1) Turned on the chiller, then the MOPA, then the RC's Heater power supply.
2) Shutter is open, laser is lasing, PMC is locked.
3) RC temperature is slowly rising. Will probably be thermalized by tomorrow.

Sun Feb 21 20:04:17 2010
Framebuilder is not mounting its RAID frames - in fact, it doesn't mount anything because the mountall command is failing on the RAID with the frames. The Jetstor RAID is also not responding to ping. Looks like the JetStor RAID which has all of our frames is still on the old 131 network, Joe.
  2621   Mon Feb 22 07:25:58 2010 ranaUpdateGeneralPrep for Power Supply Stop

Autoburts have not been working since the network changeover last Thursday.

Last snapshot was around noon on Feb 11...  


It turns out this happened when the IP address got switched from 131.... to 192.... Here's the horrible little piece of perl code which was failing:

$command = "/usr/sbin/ifconfig -a > $temp";
   system($command);

   open(TEMP,$temp) || die "Cannot open file $temp\n";
   $site = "undefined";
   #                                                                                                     
   # this is a horrible way to determine site location                                                   
   while ($line = <TEMP>) {
     if ($line =~ /10\.1\./) {
       $site = "lho";
     } elsif ($line =~ /10\.100\./) {
       $site = "llo";
     } elsif ($line =~ /192\.168\./) {
       $site = "40m";
     }
   }
   if ($site eq "undefined") {
     die "Cannot Determine Which LIGO Observatory this is\n";

I've now put in the correct numbers for the 40m...and its now working as before. I also re-remembered how the autoburt works:

1) op340m has a line in its crontab to run /cvs/cds/caltech/burt/autoburt/burt.cron (I've changed this to now run at 7 minutes after the hour instead of at the start of the hour).

2) burt.cron runs /cvs/cds/scripts/autoburt.pl (it was using a perl from 1999 to run this - I've now changed it to use the perl 5.8 from 2002 which was already in the path).

3) autoburt.pl looks through every directory in 'target' and tries to do a burt of its .req file.

Oh, and it looks like Joe has fixed the bug where only op440m could ssh into op340m by editing the host.allow or host.deny file (+1 point for Joe).

But he forgot to elog it (-1 point for Joe).®

  2634   Tue Feb 23 16:42:02 2010 ranaConfigurationComputer Scripts / ProgramsSVN restarted on NODUS

I ran the start Apache script as described by Yoichi in the WIki. SVN back up.

  2645   Sun Feb 28 16:45:05 2010 ranaSummaryGeneralPower ON Recovery
  1. Turned ON the RAID above linux1.
  2. Hooked up a monitor and keyboard and then turned ON linux1.
  3. After linux1 booted, turned ON nodus - then restarted apache and elog on it using the wiki instructions.
  4. Turned on all of the control room workstatiions, tuned Pandora to Johnny Cash, started the auto package updater on Rosalba (517 packages).
  5. Started the startStrip script on op540m.
  6. turned on RAID for frames - wait for it to say 'SATA', then turn on daqctrl and then fb40m and then daqawg and then dcuepics
  7. turned on all the crates for FEs, Sorensens, Kepcos for LSC, op340m, mafalda was already on
  8. fb40m again doesn't mount the RAID again!
  9. I turned on fb40m2 and that fixes the problem. The fb40m /etc/vfstab points to 198.168.1.2, not the JetStor IP address.
  10. I plugged in the Video Switch - its power cord was disconnected.
  11. FEs still timing out saying 'no response from EPICS', but Alberto is now here.

Sun Feb 28 18:23:09 2010

Hi. This is Alberto. Its Sun Feb 28 19:23:09 2010

  1. Turned on c1dcuepics, c0daqctrl and c0daqawg. c0daqawg had a "bad"status on the daqdetail medm screen. The FEs still don't come up.
  2. Rebooted c1dcuepics and power cycled c0daqctrl and c0daqawg. The problem is still there.
  3. Turned on c1omc. Problem solved.
  4. Rebooted c1dcuepics and power cycled c0daqctrl and c0daqawg. c0daqawg now good. The FE are coming up.
  5. Plugged in the laser for ETMY's oplev
  6. Turned on the laser of ETMX's oplev from its key.

 Monday, March 1, 9:00 2010 Steve turns on PSL-REF cavity ion pump HV at 1Y1

  2646   Sun Feb 28 23:47:52 2010 ranaUpdateComputersrosalba

Since Rosalba wanted to update ~500 packages, I let it do it. This, of course, stopped the X server from running. I downloaded and installed the newest Nvidia driver and its mostly OK.

The main problem with the auto-update on our workstations is that we've updated some packages by hand; i.e. not using the standard CentOS yum. So that means that the auto-update doesn't work right. From now on, if you want to install a fancier package than what CentOS distributes, you should commit to handle the system maintenance for these workstations for the future. Its not that we can't have new programs, we just have to pay the price.

 

At 23:45 PST, I also started a slow triangle wave on the AOM drive amplitude. This is to see if there's a response in the FSS-FAST which might imply a coupling from intensity noise to frequency noise via absorbed power and the dn/dT effect in the coatings.

Its a 93 second period triangle modulating the RC power from 100% down to 50%.

  2649   Mon Mar 1 22:38:12 2010 ranaUpdateComputersRC sensitivity to RIN

The overnight triangle wave I ran on the AOM drive turns out to have produced no signal in the FAST feedback to the PZT.

The input power to the cavity was ~10 mW (I'm totally guessing). The peak-peak amplitude of the triangle wave was 50% of the total power.

The spectral density of the fast signal at the fundamental frequency (~7.9 mHz) is ~0.08 V/rHz. The FAST calibration is ~5 MHz/V. So, since we

see no signal, we can place an upper limit on the amount of frequency shift = (5 MHz/V) * (0.08 V/rHz) * sqrt(0.0001 Hz) = 4 kHz.

Roughly this means that the RIN -> Hz coefficient must be less than 4 kHz / 5 mW or ~ 1 Hz/uW.

For comparison, the paper on reference cavities by the Hansch group lists a coefficient of ~50 Hz/uW. However, they have a finesse of 400000

while we only have a finesse of 8000-10000. So our null result means that our RC mirrors' absorption is perhaps less than theirs. Another possibility

is that their coating design has a higher thermo-optic coefficient. This is possible, since they probably have much lower transmission mirrors. It would be

interesting to know how the DC thermo-optic coefficient scales with transmission for the standard HR coating designs.

Attachment 1: Untitled.png
Untitled.png
  2657   Thu Mar 4 22:07:21 2010 ranaUpdate40m Upgrading11MHz PD not yet designed

Use 10 Ohms for the resistance - I have never seen a diode with 25 Ohms.

p.s. PDFs can be joined together using the joinPDF command or a few command line options of 'gs'.

  2659   Fri Mar 5 18:04:56 2010 ranaUpdateSUSused OSEMs are magnetic

The OSEM LEDs and PDs from Honeywell have always had some ferromagnetic material in them. These are the same OSEMs we had since 2000.

You must be thinking of the really old 20th century plastic OSEMs.

  2660   Sun Mar 7 07:01:21 2010 ranaUpdateWienerFilteringGuralp Huddle Test software

We need to do a new huddle test of the Guralps for the Wiener filtering paper. The last test had miserable results.

I tried to use recent data to do this, but it looks like we forgot to turn the Guralp box back on after the power outage or that they're far off center.

So instead I got data from after the previous power outage recovery.

I tried to use our usual Wiener filter method to subtract Guralp1-Z from Guralp2-Z, but that didn't work so well. It was very sensitive to the pre-weighting.

Instead I used the new .m file that Dmass wrote for subtracting the phase noise from his doubling noise MZ. That worked very well. It does all of the subtraction in the frequency domain and so doesn't have to worry about making a stable or causal filter. As you can see, it beats our weighted Wiener filter at all frequencies.

huddlez.png

The attached plot shows the Guralp spectra (red & green), the residual using time-domain Wiener filtering (black) and the Dmass f-domain code (yellow).

As soon as Jenne brings in her beer cooler, we're ready to redo the Huddle Test.

 

  2661   Sun Mar 7 23:05:39 2010 ranaUpdatePEMSeismic witnesses near MC1 tank moved

Quote:

Since we're going to open the MC1 tank tomorrow, I've moved the MC1 accelerometers and the Guralp over to underneath MC2 for the vent.  I'll reconnect them later.

 I've put both Guralps next to the Ranger and connected them to the breakout box. The data is now good.

I found that the Ranger was not centered and so it was stuck (someone kicked it in the last 2 weeks apparently). I recentered the mass according to the procedure in the manual. Its now moving freely.

In order to do a better huddle test, I increased the gain of the Ranger's SR560 preamp to 100 from 10 and put it on the low noise setting. I also enabled a 2x lowpass at 3 kHz for no good reason.

I couldn't find what the actual value of the gain of the Guralp breakout box is, but I assume its 10. With this assumption the calibrations are this:

Guralp: 800 V/(m/s)  *  10  (V/V)   *  16384  cts/V   =>    7.63e-9  (m/s)/count           (0.03 - 40 Hz)

Ranger:  345 V/(m/s)  * 100 (V/V)  *  16384 cts/V   =>     1.77e-9  (m/s)/count          (above 1Hz)

To account for the fact that I am not damping the Ranger with an external damping resistor, I have changed the calibration poles and zeros: in DTT we now use 2 poles @ 0 Hz and a complex pair at 1 Hz:

G = 1.77e-9

Poles = 0, 0

Zeros = 0.15 0.9887

I think that the Guralp gain is too high by a factor of 2. To really do this right, we should attach a known voltage to the input pins of the Guralp breakout and then read off the amount of counts.

Attachment 1: seis.png
seis.png
  2662   Mon Mar 8 18:15:27 2010 ranaUpdatePEMStyrofoam Cooler on the Seismos

I put Jenne's cooler over the seismometers. Kiwamu put the copper foil wrapped lead brick on top of the cooler to hold it down. I also put another (unwrapped) lead brick on top of the Guralp cables outside of the cooler. Frank gave me a knife with which I cut a little escape hole in the bottom of the cooler lip for the Guralp cables to sneak out of.

Attachment 1: SeismometersHuddled.jpg
SeismometersHuddled.jpg
ELOG V3.1.3-