40m QIL Cryo_Lab CTN SUS_Lab TCS_Lab OMC_Lab CRIME_Lab FEA ENG_Labs OptContFac Mariner WBEEShop
  40m Log, Page 283 of 344  Not logged in ELOG logo
ID Date Authorup Type Category Subject
  1639   Mon Jun 1 15:01:31 2009 ranaUpdatePSLLaser Power after fixing the laser chiller: more traces
If you look at the correlation between RMTEMP and HTEMP, you see what we knew: namely that there
was a 1:1 correlation before. After the chiller fix, I can see no correlation between the room and
amplifier temperature at the resolution of 10:1. So the chiller loop has a gain > 10 at 24 hour time
scales.

I don't understand why the PMC looks more stable.
Attachment 1: Picture_7.png
Picture_7.png
  1640   Mon Jun 1 19:19:26 2009 ranaUpdatePSL1000 days of hour-trend
Attachment 1: u.png
u.png
  1646   Wed Jun 3 03:30:52 2009 ranaUpdateMOPANPRO current adjust
I increased the NPRO's current to the max allowed via EPICS before the chiller shutdown. Yesterday, I did this
again just to see the effect. It is minimal.

If we trust the LMON as a proportional readout of the NPRO power, the current increase from 2.3 to 2.47 A gave us
a power boost from 525 to 585 mW (a factor of 1.11). The corresponding change in MOPA output is 2.4 to 2.5 W
( a factor of 1.04).

Therefore, I conclude that the amplifier's pump has degraded so much that it is partially saturating on the NPRO
side. So the intensity noise from NPRO should also be suppressed by a similar factor.

We should plan to replace this old MOPA with a 2 W Innolight NPRO and give the NPRO from this MOPA back to the
bridge labs. We can probably get Eric G to buy half of our new NPRO as a trade in credit.
Attachment 1: Untitled.png
Untitled.png
  1649   Wed Jun 3 18:55:27 2009 ranaUpdateCOCsnapshot of upgrade layout
Attachment 1: layout.png
layout.png
  1689   Sun Jun 21 00:08:26 2009 ranaConfigurationComputerselog rebooted

 

nodus:log>dmesg

Sun Jun 21 00:06:43 PDT 2009
Mar  6 15:46:32 nodus sshd[26490]: [ID 800047 auth.crit] fatal: Timeout before authentication for 131.215.114.93
Mar 10 11:11:32 nodus sshd[22775]: [ID 800047 auth.crit] fatal: Timeout before authentication for 131.215.114.93
Mar 11 13:27:37 nodus sshd[7768]: [ID 800047 auth.error] error: connect_to 131.215.115.52 port 7000: Connection refused
Mar 11 13:27:37 nodus sshd[7768]: [ID 800047 auth.error] error: connect_to nodus port 7000: failed.
Mar 11 13:31:40 nodus sshd[7768]: [ID 800047 auth.error] error: connect_to 131.215.115.52 port 7000: Connection refused
Mar 11 13:31:40 nodus sshd[7768]: [ID 800047 auth.error] error: connect_to nodus port 7000: failed.
Mar 11 13:31:45 nodus sshd[7768]: [ID 800047 auth.error] error: connect_to 131.215.115.52 port 7000: Connection refused
Mar 11 13:31:45 nodus sshd[7768]: [ID 800047 auth.error] error: connect_to nodus port 7000: failed.
Mar 11 13:34:58 nodus sshd[7768]: [ID 800047 auth.error] error: connect_to 131.215.115.52 port 7000: Connection refused
Mar 11 13:34:58 nodus sshd[7768]: [ID 800047 auth.error] error: connect_to nodus port 7000: failed.
Mar 12 16:09:23 nodus sshd[22785]: [ID 800047 auth.crit] fatal: Timeout before authentication for 131.215.114.93
Mar 14 20:14:42 nodus sshd[13563]: [ID 800047 auth.crit] fatal: Timeout before authentication for 131.215.114.93
Mar 25 19:47:19 nodus sudo: [ID 702911 local2.alert] controls : 3 incorrect password attempts ; TTY=pts/2 ; PWD=/cvs/cds ; USER=root ; COMMAND=/usr/bin/rm -rf kamioka/
Mar 25 19:48:46 nodus su: [ID 810491 auth.crit] 'su root' failed for controls on /dev/pts/2
Mar 25 19:49:17 nodus last message repeated 2 times
Mar 25 19:51:14 nodus sudo: [ID 702911 local2.alert] controls : 1 incorrect password attempt ; TTY=pts/2 ; PWD=/cvs/cds ; USER=root ; COMMAND=/usr/bin/rm -rf kamioka/
Mar 25 19:51:22 nodus su: [ID 810491 auth.crit] 'su root' failed for controls on /dev/pts/2
Jun  8 16:12:17 nodus su: [ID 810491 auth.crit] 'su root' failed for controls on /dev/pts/4

nodus:log>uptime
 12:06am  up 150 day(s), 11:52,  1 user,  load average: 0.05, 0.07, 0.07

  1702   Thu Jun 25 17:27:42 2009 ranaUpdateComputerstdsresp on linux
I downloaded the tdsresp.pl from LLO and put it into the various TDS/bin paths. Also updated the LLO specific path stuff. It runs.
  1706   Fri Jun 26 19:14:04 2009 ranaUpdateEnvironmentseisBLRMS for the past 3 weeks
Restarted the seisBLRMS.m on mafalda (running a term on op540m). Don't know why it stopped - the
terminal had a 'disabled by EPICS' message even though the EPICS enable button was enabled.

I also changed the delay from 4 to 2 minutes. So now it is calculating a 64 s PSD starting from 2 minutes ago. We had
put it back to 4 minutes long ago since the framebuilder was acting slow, but maybe it will work now since its using
the NDS1 protocol instead of direct frame reading. If it starts not finding data, please kill the seisBLRMS and restart
it with a 3 minute delay.
  1727   Thu Jul 9 02:18:09 2009 ranaUpdatePEMBonnie moved to PSL, getting some coherence with the PMC_ERR channel
My guess is that we need a different acoustic strategy. The microphones are mainly for high frequencies,
so you should not expect any coherence with MC_L (or even better, MC_F) below 100 Hz. I expect that the
main coherence for MC_F will come from the PSL in that band.

After subtracting that one out, we should look at the signal from the lock of the X or Y arm, and see
if we can nail that by putting a mic right above the AS table (leaving enough room to take the lid off).
If that works OK, we can find a spot under the lid and se if it gets better.
  1729   Thu Jul 9 19:24:50 2009 ranaUpdatePEMmore mic position changes; mics not picking up high frequencies
Might be the insidious 850 Hz AA filters in the black AA box which precedes the ADC.

Dan Busby fixed up the PSL/IOO chassis. WE might need to do the same for the PEM stuff.
  1730   Fri Jul 10 17:32:08 2009 ranaUpdateEnvironmentseisBLRMS & mafalda restarted
Rana, Alberto

Mafalda's ethernet cable had fallen out of the connector on the hub-side. We reconnected it and rebooted mafalda and restarted seisBLRMS.

Mafalda didn't mount /cvs/cds on start up for some reason. I mounted it using 'sudo mount linux1:/home/cds /cvs/cds' and it took at least
30 seconds, so maybe there's a timeout issue. Seems OK now.
  1732   Sun Jul 12 20:05:06 2009 ranaOmnistructureEnvironmentChanged office temp
This is a 7-day minute trend. There's no obvious effect in any of the channels looking back 2 days.

Seems like the laser chiller fix has made the laser much more immune to the office area temperature.
Attachment 1: Picture_3.png
Picture_3.png
  1738   Mon Jul 13 15:48:05 2009 ranaOmnistructureEnvironmentRemoval of the cold air deflection device for the MOPA chiller
Around 2 PM today, I removed the blue flap which has been deflecting the cold air from the AC down into the laser chiller.
Let's watch the laser trends for a few days to see if there's any effect.
  1761   Sat Jul 18 19:49:48 2009 ranaUpdatePEMGuralp Box Fail
That's terrible: R5 & R8 should definitely be 100 Ohm and not 100kOhm. 100k would make it a noise disaster. They should also be metal film (from the expensive box, not from the standard box). This is the same for all channels so might as well stuff them.

The circuit diagram between TP3 and TP4 appears to be designed to make the whitening not work. That's why R6 & R7 should be 100k. And R2 should be metal film too.

Basically, every time we want good low frequency performance we have to use the metal film or metal foil or wirewound resistors. Everything else produces a lot of crackling noise under the influence of DC current.

I'm also attaching the voltage and current noise spectra for the AD620 from the datasheet. These should allow us to compare our measurements to a reasonable baseline.
Attachment 1: Picture_1.png
Picture_1.png
Attachment 2: Picture_2.png
Picture_2.png
Attachment 3: AD620.pdf
AD620.pdf AD620.pdf AD620.pdf AD620.pdf AD620.pdf AD620.pdf AD620.pdf AD620.pdf
  1793   Sun Jul 26 13:19:54 2009 ranaUpdatePSLAligning the mode cleaner

I set the MC back to its good alignment (June 21st) using this procedure. The trend of the OSEM values over the last 40 days and 40 nights is attached.

Then I aligned the periscope to that beam. This took some serious periscope knob action. Without WFS, the transmission went to 2.7 V and the reflection down to 0.6V.

Then I re-aligned the MC_REFL path as usual. The beam was far enough off that I had to also re-align onto the MC LSC PD as well as the MC REFL camera (~2 beam radii).

Beams are now close to their historical positions on Faraday and MC2. I then restored the PZT sliders to their April snapshot and the X-arm locked.

Steve - please recenter the iris which is on the periscope. It has been way off for a long time.

So it looks OK now. The main point here is that we can trust the MC OSEMs.

Afterwards I rebooted c1susvme1 and c1susvme2 because they were skewed.

 

Attachment 1: Untitled.png
Untitled.png
  1796   Mon Jul 27 14:12:14 2009 ranaSummarySUSTM Coil Noise Spectra
Rob noticed that the ITMY DAC channels were saturating occassionally. Looking at the spectrum we can see why.
With an RMS of 10000 cts, the peak excursions sometimes cause saturations.

There's a lot of mechanical noise which is showing up on the ITM oplevs and then going to the mirror via
the oplev servo. We need to reduce the mechanical noise and/or modify the filters to compensate. The ITM
COIL_OUT RMS needs to be less than ~3000.
Attachment 1: Coils.pdf
Coils.pdf
  1809   Wed Jul 29 19:31:17 2009 ranaConfigurationComputerselog restarted

Just now found it dead. Restarted it. Is our elog backed up in the daily backups?

  1814   Thu Jul 30 21:26:16 2009 ranaUpdateIOOMC Drumhead mode
I used COMSOL 3.5a to do a FEA of one of the MC flat mirrors. Should be close to the same for all the mirrors.

The model is very simple- it includes just the cylindrical shape (no magnets, curvature, or coating or bevels).
This is good enough, since we don't really know all of the material properties at the 1% level.

The attached plot shows the MC drumhead mode. The color scale shows the displacement along the optic axis.
The model predicts 28.855 kHz and the measured value was 28.2 kHz.

I used COMSOL in the multiphysics mode which includes the Structural Mechanics and Heat Transfer modules at the
same time. For the material I used the built in properties of Corning 7940 (fused silica). In reality we have
7980 (I don't know all of the material differences). In any case, this model includes the temperature dependence
of the Young's modulus, so it should be possible to use this to predict the absorption numbers.

The model file (mc2.mph) has been added to our COMSOL SVN directory.
Attachment 1: mc2drum.png
mc2drum.png
  1851   Fri Aug 7 00:10:14 2009 ranaUpdatePSLRef cav reflection PD is funky

we have a tester cable, but you don't want it. Instead the problem is probably at the cross-connect. The D-cable goes to a cross-connect and you can probe there with a voltmeter. If the signal is good there, trace it to the ADC. Also trend for several years to see when this happened - Yoichi may know the history better.

Also, we still need to complete the FSS RFPD task list from last year.

 

  1867   Sat Aug 8 15:08:14 2009 ranaConfigurationPSLSMOO settings updated in psl.db and SVN updated

I have added/modified SMOO settings to all of the records in psl.db appropriately. Changes checked in to SVN.

As a reminder, you should check in to the SVN all changes you make to any of the .db files or any of the .ini files in chans.

  1868   Sat Aug 8 17:19:07 2009 ranaUpdatePEMTwo Guralps plugged in, prepped for huddle test

 I found that several of the cables are unlabeled so I'm not sure what's plugged in. In the end, I found that the TEMP_2, _3, & _44 channels were working and so I plugged in anything that looked seismic into there.

TEMP_2 is now apparently the X channel of the 2nd Guralp. If someone can figure out which cable belongs to the Y channel, please plug it into TEMP_3 and then we can fix the channel names.

I also removed (gently) all of the accelerometers from MC2's chamber. This didn't break the lock, but I intentionally broke it to make sure it reacquired fine. It did and the MC TRANS QPD showed no significant shift afterwards.

Attachment 1: Untitled.png
Untitled.png
  1869   Sat Aug 8 17:23:29 2009 ranaUpdatePEMoffensive 2 Hz sine wave removed

Friday, we were seeing a 2 Hz harmonic series in all of the PEM channels. Today I found that some bad person had put in a 4V (!) signal into one of the channels with a signal generator. The generator was also sneakily stuck way back inside the DCU rack. NO SECRET SIGNAL INJECTIONS!

Since the ADC has a 2Vpk range, this was saturating and putting in harmonics in all the adjacent channels. I disconnected it and turned off the function generator.

  1870   Sun Aug 9 16:32:18 2009 ranaUpdateComputersRCG work. MDC MDP open loop transfer function

This is very nice. We have, for the first time, a real time plant with which we can test our changes of the control system. From my understanding, we have a control system with the usual POS/PIT/YAW matrices and filter banks. The outputs go to a separate real-time system which is running something similar and where we have loaded the pendulum TF as a filter. Cross-couplings, AA & AI filters, and saturations to come later.

The attached plot is just the same as what Peter posted earlier, but with more resolution. I drove at the input to the SUSPOS filter bank and measured the open loop with the loop closed. The loop wants an overall gain of -0.003 or so to be stable.

Attachment 1: a.png
a.png
  1887   Tue Aug 11 23:17:21 2009 ranaSummaryComputersNodus rebooted / SVN down

Looks like someone rebooted nodus at ~3 PM today but did not elog it. Also the SVN is not running. Why?

  1897   Thu Aug 13 09:22:06 2009 ranaUpdatePEMranger

Rana, Jan, Jenne

We noticed that the Ranger data was all bogus at low frequencies. So we checked it and found that the proper procedure had not been used when changing it from horizontal to vertical last week. So the huddle test data from the weekend is not valid for the ranger; we will have to repeat it sometime.

So we used the manual, and extended the hanger rod on top of the Ranger to free the mass. It now has good response and coherence with the Guralps down to 0.1 Hz. See attached plot soon.

 

  1912   Sat Aug 15 18:57:48 2009 ranaUpdateVACUPS failed

As Rob noted last Friday, the UPS which powers the Vacuum rack failed. When we were trying to move the plugs around to debug it, it made a sizzling sound and a pop. Bad smells came out of it.

Ben came over this week and measured the quiescent power consumption. The low power draw level was 11.9 A and during the reboot its 12.2 A. He measured this by ??? (Rob inserts method here).

So what we want is a 120 V * 12.2 A  ~ 1.4 kVA UPS with ~30-50% margin. We look for this on the APC-UPS site:

On Monday, we will order the SUA2200 from APC. It should last for ~25 minutes during an outage. Its $1300. The next step down is $200 cheaper and gives 10 minutes less uptime.

  1920   Mon Aug 17 17:43:11 2009 ranaSummaryGeneralconlogger restarted

Added the conlog directory to the SVN, minus the enormous data directory. We are now free to make changes to the conlog code.

  1927   Wed Aug 19 02:17:52 2009 ranaOmnistructureEnvironmentControl Room Workstation desks lowered to human height

There were no injuries...Now we need to get some new chairs.

  1938   Tue Aug 25 00:35:04 2009 ranaUpdateGeneralTransfer function of Mode Cleaner Stacks

Looks like all of the accelerometers and seismometers have been disconnected since early AM last Monday when Clara disconnected them for her sensor noise measurement.

Attachment 1: Untitled.png
Untitled.png
  1939   Tue Aug 25 01:27:09 2009 ranaConfigurationComputersRaid update to Framebuilder (not quite)

Quote:

The RAID array servicing the Frame builder was finally switched over to JetStor Sata 16 Bay raid array. Each bay contains a 1 TB drive.  The raid is configured such that 13 TB is available, and the rest is used for fault protection.

The old Fibrenetix FX-606-U4, a 5 bay raid array which only had 1.5 TB space, has been moved over to linux1 and will be used to store /cvs/cds/.

This upgrade provides an increase in look up times from 3-4 days for all channels out to about 30 days.  Final copying of old data occured on August 5th, 2009, and was switched over on that date.

 Sadly, this was only true in theory and we didn't actually check to make sure anything happened.

We are not able to get lookback of more than ~3 days using our new huge disk. Doing a 'du -h' it seems that this is because we have not yet set the framebuilder to keep more than its old amount of frames. Whoever sees Joe or Alex next should ask them to fix us up.

  1940   Tue Aug 25 02:37:53 2009 ranaConfigurationComputer Scripts / ProgramsFirefox 3.5 installed for 64 bit linux in apps/
Attachment 1: DSC_0620.JPG
DSC_0620.JPG
  1942   Tue Aug 25 11:02:39 2009 ranaSummaryPSLTemperature Box

The PSL Temperature Box (D980400-B-C, what kind of numbering scheme is that?) modified at LHO/LLO ~8 years ago to have better resolution on the in-loop temperature sensors.

I haven't been able to find a DCN / ECN on this, but there's an elog entry from Hugh Radkins here.  I'm also attaching the PDF of the latest drawing (circa 2000) from the DCC.

The schematic doesn't show it, but I am guessing that the T_SENSE inputs are connected to the AD590 chips, and that 4 of these are attached somehow to the RefCav can. IF this is true, I don't understand why there are input resistors on the LT1125 of U1; the AD590 is supposed to be a current source ?

Peter King is supposed to be coming over to work on this today so whoever spots him should force/cajole/entice him to elog what he's done. Film him if necessary.

 

I also think R1-8 should be swapped into metal film resistors for stability. The datasheet says that it puts out 1 uA/K, so the opamps put out 10 mV/K.

J8 and JP1 should be shorted to disable both the tidal and VME control input. Both are unused and a potential source of drift.

Attachment 1: D980400-B.pdf
D980400-B.pdf
  1946   Tue Aug 25 21:55:11 2009 ranaUpdatePSLreference cavity temp box temporarly out of order

There's no elog entry about what work has gone on today, but it looks like Peter took apart the reference cavity temperature control around 2PM.

I touched the reference cavity by putting my finger up underneath its sweater and it was nearly too hot to keep my finger in there. I looked at the heater power supply front panel and it seems that it was railed at 30 V and 3 A. The nominal value according to the sticker on the front is 11.5 V and 1 A.

So I turned down the current on the front panel and then switched it off. Otherwise, it would take it a couple of days to cool down once we get the temperature box back in. So for tonight there will definitely be no locking. The original settings are in the attached photo. We should turn this back on with its 1A setting in the morning before Peter starts so that the RC is at a stable temp by the evening. Its important NOT to turn it back on and let it just rail. Use the current limit to set it to 1 A. After the temperature box is back in the current limit can be turned back up to 2A or so. We never need the range for 3A, don't know why anyone set it so high.

Attachment 1: Untitled.png
Untitled.png
Attachment 2: rc-heater.jpg
rc-heater.jpg
  1956   Thu Aug 27 13:42:08 2009 ranaSummaryPSLReference Cavity Temperature Control: psl.db changes

I made the changes to the psl.db to handle the new Temperature box hardware. The calibrations (EGUF/EGUL) are just copied directly from the LHO .db file (I have rsync'd their entire target area to here).

allegra:c1psl>diff psl.db~ psl.db
341,353d340
< grecord(ai,"C1:PSL-FSS_TIDALOUT")
< {
<       field(DESC,"TIDALOUT- drive to the reference cavity heater")
<       field(DISV,"1")
<         field(SCAN,".5 second")
<       field(DTYP,"VMIVME-3113")
<       field(INP,"#C0 S28 @")
<       field(EGUF,"10")
<       field(EGUL,"-10")
<       field(EGU,"volts")
<       field(LOPR,"-10")
<       field(AOFF,"0")
< }
493,494c480,481
<         field(EGUF,"285.675")
<         field(EGUL,"-214.325")
---
>         field(EGUF,"67.02")
>         field(EGUL,"7.96")
508,509c495,496
<         field(EGUF,"726.85")
<         field(EGUL,"-1273.15")
---
>         field(EGUF,"75.57")
>         field(EGUL,"12.31")
531,532c518,519
<         field(EGUF,"726.85")
<         field(EGUL,"-1273.15")
---
>         field(EGUF,"75.57")
>         field(EGUL,"12.31")
605,617d591
< grecord(ai,"C1:PSL-FSS_TIDALINPUT")
< {
<       field(DESC,"TIDALINPUT- tidal actuator input")
<       field(DISV,"1")
<         field(SCAN,".5 second")
<       field(DTYP,"VMIVME-3123")
<       field(INP,"#C0 S3 @")
<       field(EGUF,"10")
<       field(EGUL,"-10")
<       field(EGU,"volts")
<       field(LOPR,"-10")
<       field(AOFF,"0")
< }
1130a1105,1130
> grecord(ai,"C1:PSL-FSS_TIDALINPUT")
> {
>       field(DESC,"TIDALINPUT- tidal actuator input")
>       field(DISV,"1")
>         field(SCAN,".5 second")
>       field(DTYP,"VMIVME-3123")
>       field(INP,"#C0 S3 @")
>       field(EGUF,"10")
>       field(EGUL,"-10")
>       field(EGU,"volts")
>       field(LOPR,"-10")
>       field(AOFF,"0")
> }
> grecord(ai,"C1:PSL-FSS_TIDALOUT")
> {
>       field(DESC,"TIDALOUT- drive to the reference cavity heater")
>       field(DISV,"1")
>         field(SCAN,".5 second")
>       field(DTYP,"VMIVME-3113")
>       field(INP,"#C0 S28 @")
>       field(EGUF,"10")
>       field(EGUL,"-10")
>       field(EGU,"volts")
>       field(LOPR,"-10")
>       field(AOFF,"0")
> }
1143,1144c1143,1144
<         field(HOPR,"0.010")
<         field(LOPR,"-0.010")
---
>         field(HOPR,"2")
>         field(LOPR,"0")

  1957   Thu Aug 27 14:00:33 2009 ranaUpdatePSLRC thermal servo impulse response

I stepped the TIDALSET and looked at what happened. Loop was closed with the very low gain.

The RED guy tells us the step/impulse response of the RC can to a step in the heater voltage.

The GREY SLOWDC tells us how much the actual glass spacer of the reference cavity lags the outside can temperature.

Since MINCOMEAS is our error signal, I have upped his SCAN period from 0.5 to 0.1 seconds in the database and reduced its SMOO from 0.9 to 0.0. I've also copied over the Fricke SLOW code and started making a perl PID loop for the reference cavity.

Attachment 1: Untitled.png
Untitled.png
  1968   Mon Sep 7 20:05:18 2009 ranaUpdatePSLRCTEMP v. RMTEMP

Since ~Aug. 27, the reference cavity has been running with no thermal control. This is not really a problem at the 40m; a 1 deg change of the glass cavity

will produce a 5 x 10-7 strain in the arm cavity. That's around 20 microns of length change.

This open loop time gave us the opportunity to see how good our cavity's vacuum can insulation is.

 

rct.pngrct2.png

The first plot below shows the RCTEMP sensors and the RMTEMP sensor. RMTEMP is screwed down to the table close to the can and RCTEMP is on the can, underneath the insulation. I have added a 15 deg offset to RMTEMP so that it would line up with RCTEMP and allow us to see, by eye, what's happening.

There's not enough data here to get a good TF estimate, but if we treat the room temperature as a single frequency (1 / 24 hours) sine wave source, then we can measure the delay and treat it as a phase shift. There's a ~3 hour delay between the RMTEMP and RCTEMP. If the foam acts like a single pole low pass filter, then the phase delay of (3/24)*360 = 45 deg implies a pole at a ~3 hour period. I am not so sure that this is a good foam model, however.

The colorful plot is a scatter plot of RCTEMP v. RMTEMP. The color denotes the time axis - it starts out blue and then becomes red after ten days.

  1970   Mon Sep 7 23:35:03 2009 ranaUpdatePSLRC thermal servo: PID script modified, database + screen added

I have added the records for the RC thermal PID servo into the psl/slowpid.db file which also holds the records for the SLOW servo that uses the NPRO-SLOW to minimize the NPRO-FAST. This new database will take effect upon the next PSL boot.

The perl script which runs the servo is scripts/PSL/FSS/RCthermalPID.pl. Right now it is using hard-coded PID parameters - I will modify it to use the on-screen values after we reboot c1psl.

The new screen C1PSL_FSS_RCPID.adl, the script, and the .db have been added to the SVN.

I have got some preliminary PID parameters which seem to be pretty good: The RCTEMP recovers in ~10 minutes from a 1 deg temperature step and the closed loop system is underdamped with a Q of ~1-2.

I'm leaving it running on op340m for now - if it goes crazy feel free to do a 'pkill RCthermalPID.pl'.

Attachment 1: Untitled.png
Untitled.png
  1971   Mon Sep 7 23:51:48 2009 ranaConfigurationComputersmatlab installed: 64-bit linux

I have wiped out the 2008a install of 64-bit linux matlab and installed 2009a in its place. Enjoy.

  1976   Tue Sep 8 19:30:33 2009 ranaUpdatePSLc1psl rebooted for new RCPID database settings

The RC thermal PID is now controllable from its own MEDM screen which is reachable from the FSS screen. The slowpid.db and psl.db have been modified to add these records and all seems to be working fine.

Also, I've attached the c1psl startup output that we got on the terminal. This is just for posterity.

I'm also done tuning the PID for now. Using Kp = -1.0, Ki = -0.01, and Kd = 0, the can servo now has a time constant of ~10 minutes and good damping as can be seen in the StripTool snap below. These values are also now in the saverestore.req so hopefully its fully commissioned.

I bet that its much better now than the MINCO at holding against the 24 hour cycle and can nicely handle impulses (like when Steve scans the table). Lets revisit this in a week to see if it requires more tuning.

Attachment 1: c1psl-term-dump.txt.gz
Attachment 2: C1PSL_FSS_RCPID.png
C1PSL_FSS_RCPID.png
Attachment 3: Picture_1.png
Picture_1.png
  1983   Thu Sep 10 18:25:15 2009 ranaUpdatePSLc1psl rebooted for new RCPID database settings

I added a new database record (C1:PSL-FSS_RCPID_SETPOINT) to allow for changing of the RC setpoint while the loop is on. This will enable us to step the can's temperature and see the result in the NRPO's SLOWDC.

 

  1986   Sat Sep 12 15:40:15 2009 ranaUpdatePSLRC response v. can temperature

I stepped the RC can temperature to see the response in the laser frequency. This gives a true measure of the thermal time constant of the RC. Its ~4 hours.

Since the RCPID screen now has a setpoint field, I can remotely type in 1 deg steps. The NPRO SLOW actuator locks the NPRO to the RC at long time scales and so we can use C1:PSL-FSS_SLOWDC to measure the RC length. By knowing what the step response time constant is, we can estimate the transfer function from can temperature to frequency noise and thereby make a better heater circuit.

 Does the observed temperature shift make any sense? Well, John Miller and I measured the SLOW calibration to be 1054 +/- 30 MHz / V.

We know that the thermal expansion coefficient of fused silica, alpha = 5.5 x 10-7 (dL/L)/deg. So the frequency shift ought to be alpha * c / lambda = 155 MHz / deg.

Instead we see something like 110 MHz / deg. We have to take more data to see if the frequency shift will actually asymptote to the right value or not. If it doesn't, one possibility is that we are seeing the effect of temperature on the reflection phase of the mirror coatings through the dn/dT and the thermal expansion of the dielectric layers. I don't know what these parameters are for the Ta2O5 layers.

A more useful measure of the frequency noise can be gotten by just looking at the derivative in the first 30 minutes of the step, since that short time scale is much more relevant for us. Its 0.04 V / hour / (2 deg) =>  860 (Hz/s)/deg.

In the frequency domain this comes out to be dnu/dT = 860 Hz/deg @ 0.16 Hz or dnu/dT = 137 *(1/f) Hz / deg.

Our goal for the reference cavity frequency noise is 0.01 * (1/f) Hz/rHz. So the temperature noise of the can needs to be < 0.1 mdeg / rHz.

Attachment 1: Picture_2.png
Picture_2.png
Attachment 2: Untitled.pdf
Untitled.pdf
  1995   Wed Sep 23 19:36:41 2009 ranaUpdatePSLRC temperature performance

This first plot shows the RC temperature channels' performance from 40 days ago, before we disabled the MINCO PID controller. Although RCTEMP is supposed to be the out of loop sensor, what we really care about is the cavity length and so I've plotted the SLOW. To get the SLOW on the same scale, I've multiplied the channel by 10 and then adjusted the offset to get it on the same scale.

 The second plot shows a period after that where there is no temperature control of the can at all. Same gain scaling has been applied to SLOW as above, so that instead of the usual 1 GHz/V this plot shows it in 0.1 GHz/V.

The third plot shows it after the new PID was setup.

Summary: Even though the PID loop has more gain, the true limit to the daily fluctuations in the cavity temperature and the laser frequency are due to the in-loop sensors measuring the wrong thing. i.e. the out-of-loop temperature is too different from the in-loop sensor. This can possibly be cured with better foam and better placement of the temperature sensors. Its possible that we're now just limited by the temperature gradients on the can.

Attachment 1: Untitled.png
Untitled.png
Attachment 2: Untitled.png
Untitled.png
Attachment 3: e.png
e.png
  1998   Thu Sep 24 19:35:20 2009 ranaHowToPhotos40m Google account

I've created a 40m Google account. Please post all the 40m related photos to this site. If you don't already have it, download Picasa to make this easier.

40m Installation Photos">

the password is in the usual password place.

  1999   Thu Sep 24 20:17:05 2009 ranaSummaryLSCComparison of Material Properties for the new RFPD Mounts
  Steel Brass Aluminum Delrin
Density (kg/m^3) 7850 8500 2700 1420
CTE (ppm/C) 12 19 23 100

Young's

Modulus

(GPa)

200 110 69 2
Hardness        
Color grey gold light silver any

 

  2005   Fri Sep 25 19:56:08 2009 ranaConfigurationComputersNTPD restarted on c1dcuepics (to fix the MEDM screen times)
restarted ntp on op440m using this syntax
>su
>/etc/init.d/xntpd start -c /etc/inet/ntp.conf

gettting the time on scipe25 (for the MEDM screen time) working was tougher. The /etc/ntp.conf file was pointing
to the wrong server. Our NAT / Firewall settings require some of our internal machines to go through the gateway
to get NTPD to work. Curiously, some of the linux workstations don't have this issue.
The internal network machines should all have the same file as scipe25's /etc/ntp.conf:

server nodus

and here's how to check that its working:

[root@c1dcuepics sbin]# ./ntpq -p
     remote           refid      st t when poll reach   delay   offset  jitter
==============================================================================
 nodus.ligo.calt 0.0.0.0         16 u    -   64    0    0.000    0.000 4000.00
*nodus.ligo.calt usno.pa-x.dec.c  2 u   29   64  377    1.688  -65.616   6.647
-lime7.adamantsy clock.trit.net   3 u   32   64  377   37.448  -72.104   4.641
-montpelier.ilan .USNO.           1 u   19   64  377   18.122  -74.984   8.305
+spamd-0.gac.edu nss.nts.umn.edu  3 u   28   64  377   72.086  -66.787   0.540
-mighty.poclabs. time.nist.gov    2 u   30   64  377   71.202  -61.127   4.067
+monitor.xenscal clock.sjc.he.ne  2 u   16   64  377   11.855  -67.105   6.368
  2007   Sun Sep 27 12:52:56 2009 ranaUpdateMOPAIncreasing the power from the MOPA

This is a trend of the last 20 days. After our work with the NPRO, we have recovered only 5% in PMC trans power, although there's an apparent 15% increase in AMPMON.

The AMPMON increase is partly fake; the AMPMON PD has too much of an ND filter in front of it and it has a strong angle dependence. In the future, we should not use this filter in a permanent setup. This is not a humidity dependence.

The recovery of the refcav power mainly came from tweaking the two steering mirrors just before and just after the 21.5 MHz PC. I used those knobs because that is the part of the refcav path closest to the initial disturbance (NPRO).

BTW, the cost of a 1W Innolight NPRO is $35k and a 2W Innolight NPRO is $53k. Since Jenne is on fellowship this year, we can afford the 2W laser, but she has to be given priority in naming the laser.

Attachment 1: Picture_3.png
Picture_3.png
  2010   Sun Sep 27 23:21:14 2009 ranaUpdatePSLSLOWscan result

Quote:

What I like to try:
a) Change the NPRO temp to more cold side.
b) Change the MOPA head temp to a bit hot side.
c) Tweak the MOPA current (is it difficult?)

 I think that the AMPMON ND problem was just that the responsivity changes with angle. So when I aligned it a little we got some few% improvement in the signal which is not a real power increase.

I don't think we can adjust any of the MOPA parameters because the controller is broken, but we can try the NPRO crystal temperature.

  2011   Mon Sep 28 02:24:05 2009 ranaUpdateLockingMC1/3 Dewhitening found OFF: Turned back ON

While trying to make the OAF work, I found that the XYCOM switches for MC1/3 have been set in the bad way for awhile. This means that the hardware filters were bypassed and that MC1 & MC3 were moving around too much at high frequency and possibly causing trouble with the locking. I have put them back into the default position.

On Friday, Jenne and I were playing around with turning the dewhitening off/on to see if it efffected the OAF stability. At the time, I didn't pay too much attention to what the state was. Looks like it was in the wrong state (hardware bypassed) when we found it. For the OAF work, we generally want it in that bypassed state, but its bad because it makes noise in the interferometer. The bits in question are bits 16-23 on the XYCOM screen.

I have updated the snapshot and set the screen in the appropriate settings. I used a swept sine measurement to verify the filter state. In the attached plot, green corresponds to XYCOM green and red corresponds to red.

Attachment 1: C1SUS_SRM_XYCOM1.png
C1SUS_SRM_XYCOM1.png
Attachment 2: Untitled.png
Untitled.png
  2021   Tue Sep 29 21:37:09 2009 ranaUpdateMZMZ work done : some noise checking

Since we used to run with a gain slider setting of +15 dB on the MZ, I wanted to check that the new setting of +30dB was OK. It is.

To check it I turned it up and looked for some excess noise in the ISS or in the MC. There was none. I also set the input offset slider by unlocking the PMC and zeroing the mixer monitor readback. The new slider setting is -6.5V.

I don't know why we would need more gain on the MZ loop, but we can have some if we want it by turning up the gain before the servo (optical or RF). The attached plot shows the MC_F and ISS signals with the ISS loop on and off. There was no change in either of these spectra with the MZ gain high or low.

Attachment 1: fsm.pdf
fsm.pdf
  2025   Tue Sep 29 23:43:49 2009 ranaAoGall down cond.Cosmic

Actel1.jpg

cosmic rays in cars

  2041   Fri Oct 2 14:52:55 2009 ranaUpdateComputersc1susvme2 timing problems update

The attached shows the 200 day '10-minute' trend of the CPU meters and also the room temperature.

To my eye there is no correlation between the signals. Its clear that c1susvme2 (SRM LOAD) is going up and no evidence that its temperature.

 

Attachment 1: Untitled.png
Untitled.png
ELOG V3.1.3-