40m QIL Cryo_Lab CTN SUS_Lab TCS_Lab OMC_Lab CRIME_Lab FEA ENG_Labs OptContFac Mariner WBEEShop
  40m Log  Not logged in ELOG logo
Entry  Wed Oct 10 20:27:40 2012, Den, Update, IOO, MCL, WFS triggers MC2_POS.pngmcl.pdf
    Reply  Thu Oct 18 03:45:56 2012, Jenne, Update, IOO, MCL, WFS triggers 
       Reply  Thu Oct 18 12:02:32 2012, Den, Update, IOO, MCL, WFS triggers 
          Reply  Fri Oct 19 01:11:18 2012, Jenne, Update, IOO, MCL, WFS triggers 
Message ID: 7572     Entry time: Thu Oct 18 03:45:56 2012     In reply to: 7522     Reply to this: 7575
Author: Jenne 
Type: Update 
Category: IOO 
Subject: MCL, WFS triggers 

Quote:

I've added MCL and WFS stop triggers into C1MCS/SUS model. Threshold value of MC_TRANS can be changed in the text entry located in MC2_POSITION medm screen. I tried 2 cases: trigger either blocks signal before MCL filter bank input or after output. Due to filter history in the 1 case MC2 was still slightly disturbed (C1:SUS-MC2_ULPD_VAR ~= 15) right after unlock. In the second case there was no disturbance as we zero output signal, but then I had to add "clear history" command to the mcup script.

WFS triggers block the signal before ASCPIT/YAW filter bank.

 I've redone the WFS triggers.  I left the MCL trigger alone (for now....I'll come back to it). 

The trigger was setup such that (a) it was totally unclear what was going on, by looking at the WFS screen.  Koji and I spent some time confused before I remembered that Den did this work recently.  Also, for some reason, the triggers were just plain thresholding, not a schmidt trigger, so any time the cavity flashed, the WFS came on.  Since the cavity can flash before the mcdown script has a chance to turn off the WFS servos, the outputs of the WFS filters are trying to output thousands of counts, and the signal goes through any time the cavity flashes.  Not so good.

I have removed the triggering for the angular DoFs from the mcs model (leaving the MCL triggering for now).  I have put new triggering into the ioo model, at the error point of the WFS loops.  The idea is that if the cavity unlocks, we don't want to lose the current pointing of the mirrors.  If the WFS servos were doing a lot of DC work, the bias sliders won't have the full information about where we want the mirrors to point.  Since we have the integrators in FM1, removing the input signal should freeze the output signal.  I need to modify the WFS on / off script so that this doesn't get turned off every lockloss.

Also, I have implemented (for the first time in a useful model, although I've done some testing in the tst model) the "wait" delay between a cavity locking and the trigger going through.  The idea is that we don't necessarily want the WFS to come on simultaneously with the cavity lock.  Since the wait delay resets any time it is un-triggered, this also prevents any signals from going through during cavity flashes.  The wait block has 3 inputs:  (1) a trigger, the output of some kind of trigger block, (2) a number of seconds to wait and (3) the model rate in Hz.  The model rate should be set with a constant in the model, the trigger passed from the trigger block, and the wait time in seconds should be available as an epics input. 

So far it looks like it's working as I expect, although I'm honestly too tired to do enough testing that I'm satisfied with, so I'm leaving the WFS off for the night.

ELOG V3.1.3-