40m QIL Cryo_Lab CTN SUS_Lab TCS_Lab OMC_Lab CRIME_Lab FEA ENG_Labs OptContFac Mariner WBEEShop
  40m Log  Not logged in ELOG logo
Entry  Mon Aug 23 11:51:26 2021, Koji, Update, General, Campus Wide Power Glitch Reported: Monday, 8/23/21 at 9:30am  
    Reply  Mon Aug 23 19:00:05 2021, Koji, Update, General, Campus Wide Power Glitch Reported: Monday, 8/23/21 at 9:30am  
       Reply  Mon Aug 23 22:51:44 2021, Anchal, Update, General, Time synchronization efforts 
          Reply  Tue Aug 24 09:22:48 2021, Anchal, Update, General, Time synchronization working now 
             Reply  Tue Aug 24 18:11:27 2021, Paco, Update, General, Time synchronization not really working 
                Reply  Tue Aug 24 22:37:40 2021, Anchal, Update, General, Time synchronization not really working 
    Reply  Wed Nov 17 17:37:53 2021, Anchal, Update, General, Placed Nodus and fb1 on UPS power 
       Reply  Thu Nov 18 15:16:10 2021, Anchal, Update, General, Moved Chiara to 1X7 above nodus powered with same UPS 
          Reply  Mon Nov 22 17:42:19 2021, Anchal, Update, General, Connected Megatron to battery backed ports of another UPS 
             Reply  Tue Nov 30 17:11:06 2021, Paco, Update, General, Moved white rack to 1X3.5 IMG_8749.JPGIMG_8750.JPG
Message ID: 16479     Entry time: Mon Nov 22 17:42:19 2021     In reply to: 16476     Reply to this: 16488
Author: Anchal 
Type: Update 
Category: General 
Subject: Connected Megatron to battery backed ports of another UPS 

[Anchal, Paco]

I used the UPS that was providing battery backup for chiara earlier (a APS Back-UPS Pro 1000), to provide battery backup to Megatron. This completes UPS backup to all important computers in the lab. Note that this UPS nominally consumes 36% of UPS capacity in power delivery but at start-up, Megatron was many fans that use up to 90% of the capacity. So we should not use this UPS for any other computer or equipment.

While doing so, we found that PS3 on Megatron was malfunctioning. It's green LED was not lighting up on connecting to power, so we replaced it from the PS3 of old FB computer from the same rack. This solved this issue.

Another thing we found was that Megatron on restart does not get configured to correct nameserver resolution settings and loses the ability to resolve names chiara and fb1. This results in the nfs mounts to fail which in turn results in the script services to fail. We fixed this by identifying that the NetworkManager of ubuntu was not disabled and would mess up the nameserver settings which we want to be run by systemd-resolved instead. We corrected the symbolic link: /etc/resolv.conf -> /run/systemd/resolve/resolv.conf. the we stopped and diabled the NetworkManager service to keep this persistent on reboot. Following are the steps that did this:

> sudo rm /etc/resolv.conf
> ln -s /etc/resolv.conf /run/systemd/resolve/resolv.conf
> sudo systemctl stop NetworkManager.service
> sudo systemctl disable NetworkManager.service

 

ELOG V3.1.3-