40m QIL Cryo_Lab CTN SUS_Lab TCS_Lab OMC_Lab CRIME_Lab FEA ENG_Labs OptContFac Mariner WBEEShop
  40m Log  Not logged in ELOG logo
Entry  Tue Jul 16 16:00:01 2019, gautam, Update, CDS, c1iscaux Supermicro setup IMG_7769.JPG
    Reply  Wed Jul 17 21:22:41 2019, gautam, Update, CDS, CM board Latch Enable subtlety 
       Reply  Sun Jul 21 12:55:38 2019, gautam, Update, CDS, CM board Latch Enable test script LatchLogic.pdfLatchLogicTest.png
          Reply  Fri Aug 9 08:59:04 2019, gautam, Update, CDS, Prep for install of c1iscaux 
             Reply  Sun Aug 11 11:47:42 2019, gautam, Update, CDS, Bench test of c1iscaux 
                Reply  Mon Aug 12 17:36:04 2019, gautam, Update, CDS, More bench test of c1iscaux iscauxCheclist.pdf
                   Reply  Mon Aug 12 21:25:19 2019, Koji, Update, CDS, More bench test of c1iscaux 
                   Reply  Tue Aug 13 08:07:09 2019, gautam, Update, CDS, P1--->P2 
                      Reply  Tue Aug 13 14:36:17 2019, gautam, Update, CDS, P1--->P2 
                   Reply  Fri Aug 16 16:40:04 2019, gautam, Update, CDS, 1Y3 work newLook1Y3.JPGIMG_7803.JPGc1lsc_crashed.png
                      Reply  Sat Aug 17 16:49:23 2019, gautam, Update, CDS, More 1Y3 work Screen_Shot_2019-08-17_at_3.00.57_PM.pngScreen_Shot_2019-08-17_at_3.12.23_PM.pngIMG_7804.JPGScreenshot_from_2019-08-17_17-04-47.png
                         Reply  Mon Aug 19 14:36:21 2019, gautam, Update, CDS, c1iscaux remaining work caseForSmallerFootprint.pdf
                            Reply  Tue Aug 20 19:05:24 2019, Koji, Update, CDS, MC1 (and MC3) troubleshoot Screenshot_from_2019-08-20_17-26-01.pngScreenshot_from_2019-08-20_17-43-03.png
                               Reply  Thu Aug 22 12:54:06 2019, Koji, Update, CDS, MC1 glitch removed (for now) and IMC locking recovered 7x
                                  Reply  Thu Aug 22 20:56:51 2019, Koji, Update, CDS, MC1 glitch removed (for now) and IMC locking recovered 
                            Reply  Fri Aug 23 18:46:17 2019, Jon, Update, CDS, c1iscaux remaining work 
                               Reply  Sun Aug 25 14:18:08 2019, gautam, Update, CDS, c1iscaux remaining work Screen_Shot_2019-08-25_at_10.38.37_PM.png
    Reply  Thu Jul 18 10:46:04 2019, gautam, Update, CDS, Database files made 
       Reply  Thu Jul 18 19:58:56 2019, gautam, Update, CDS, Work on Acromag chassis IMG_7771.JPGIMG_7770.JPGIMG_7772.JPG
          Reply  Fri Jul 19 19:44:03 2019, gautam, Update, CDS, Database file test Whitening.png
Message ID: 14773     Entry time: Thu Jul 18 19:58:56 2019     In reply to: 14771     Reply to this: 14781
Author: gautam 
Type: Update 
Category: CDS 
Subject: Work on Acromag chassis 

Now that the .db files were prepared, I wanted to test for errors. So I did the following:

  1. Acromags were mounted on the DIN rails. Attachment #1 shows the grouping of ADC, DAC and BIO units. They are labelled with their IP addresses.
  2. Wiring of power:
    • Chub had already prepared the backplane with the power connectors, switches and indicator LEDs.
    • So I just had to daisy chain the +24 V (RED) and GND (BLACK) terminals for all the acromags together, which I did using 24 AWG wire (we may want to use heavier gauge given the current draw).
  3. Ethernet cables were used to daisy chain the network connectivity between the various units.  Attachment #1 shows the current state of the chassis box.
  4. Front panel pieces were attached and labelled, see Attachment #2
    • I found it was sufficient to use the front - we may use the rear panel slots when we want to add connections for controlling the c1aux machine channels.
    • The D15 P2 connector panel for the CM board will arrive tomorrow and will be installed then.
  5. Entire setup was connected to power and ethernet, see Attachment #3
    • As usual, the current draw is significant for the collection of Acromags, I got around this problem by using the bench supply to "Parallel" mode to enhance the current driving capacity.
    • For the ethernet connection, I used the office space port #6, which I connected at the network rack end to the eth1 port of the Supermicro.

All the Acromags are seen on the 192.168.114 subnet on c1iscaux3 yes- however, when I run the modbusIOC process, I see various errors in the logfile no, so more debugging is required. Nevertheless, progress.

Update 2245: Turns out the errors were indeed due to a copy/paste error - I had changed the IP addresses for the ADCs from the .115 subnet c1susaux was using, but forgot to do so for the DACs and BIOs. Now, if I turn off the existing c1iscaux so that there aren't any EPICS clashes, the EPICS server initializes correctly. There are still some errors in the log file - these pertain to (i) the mbbo notation, which I have to figure out, and (ii) the fact that this version of EPICS, 7.0.1, does not support channel descriptions longer than 28 characters (we have several that exceed this threshold). I think the latter isn't a serious problem.

Getting closer... Note that I turned off the c1iscaux VME crate to prevent any EPICS server clashes. I will turn it back on tomorrow.

Attachment 1: IMG_7771.JPG  2.304 MB  Uploaded Thu Jul 18 21:02:19 2019  | Hide | Hide all
IMG_7771.JPG
Attachment 2: IMG_7770.JPG  1.803 MB  Uploaded Thu Jul 18 21:06:35 2019  | Hide | Hide all
IMG_7770.JPG
Attachment 3: IMG_7772.JPG  2.046 MB  Uploaded Thu Jul 18 21:10:37 2019  | Hide | Hide all
IMG_7772.JPG
ELOG V3.1.3-