40m QIL Cryo_Lab CTN SUS_Lab TCS_Lab OMC_Lab CRIME_Lab FEA ENG_Labs OptContFac Mariner WBEEShop
  40m Log  Not logged in ELOG logo
Entry  Thu Aug 17 22:54:49 2017, ericq, Update, Computers, Trying to access JetStor RAID files 
    Reply  Tue Aug 22 15:17:19 2017, ericq, Update, Computers, Old frames accessible again 
       Reply  Tue Aug 22 15:40:06 2017, gautam, Update, Computers, Old frames accessible again  
          Reply  Tue Aug 22 17:11:15 2017, gautam, Update, Computers, c1iscex model restarts 
             Reply  Tue Aug 22 18:36:46 2017, gautam, Update, Computers, All FE models compiled against RCG3.4 CDS_Aug22.png
                Reply  Fri Sep 1 16:55:27 2017, gautam, Update, Computers, Testpoints now accessible again 
Message ID: 13242     Entry time: Tue Aug 22 17:11:15 2017     In reply to: 13240     Reply to this: 13243
Author: gautam 
Type: Update 
Category: Computers 
Subject: c1iscex model restarts 

[jamie, gautam]

We tried to implement the fix that Rolf suggested in order to solve (perhaps among other things) the inability of some utilities like dataviewer to open testpoints. The problem isn't wholly solved yet - we can access actual testpoint data (not just zeros, as was the case) using DTT, and if DTT is used to open a testpoint first, then dataviewer, but DV itself can't seem to open testpoints.

Here is what was done (Jamie will correct me if I am mistaken).

  1. Jamie checked out branch 3.4 of the RCG from the SVN.
  2. Jamie recompiled all the models on c1iscex against this version of RCG.
  3. I shutdown ETMX watchdog, then ran rtcds stop all on c1iscex to stop all the models, and then restarted them using rtcds start <model> in the order c1x01, c1scx and c1asx. 
  4. Models came back up cleanly. I then restarted the daqd_dc process on FB1. At this point all indicators on the CDS overview screen were green.
  5. Tried getting testpoint data with DTT and DV for ETMX Oplev Pitch and Yaw IN1 testpoints. Conclusion as above.

So while we are in a better state now, the problem isn't fully solved. 

Comment: seems like there is an in-built timeout for testpoints opened with DTT - if the measurement is inactive for some time (unsure how much exactly but something like 5mins), the testpoint is automatically closed.

ELOG V3.1.3-