40m QIL Cryo_Lab CTN SUS_Lab TCS_Lab OMC_Lab CRIME_Lab FEA ENG_Labs OptContFac Mariner WBEEShop
  40m Log  Not logged in ELOG logo
Entry  Mon Jun 16 21:56:53 2014, Jenne, Update, Computer Scripts / Programs, fstab updates, MC autolocker running, FSS slow loop alive 
    Reply  Tue Jun 17 12:04:40 2014, manasa, Update, Computer Scripts / Programs, MC autolocker NOT running, FB needs some attention FE_red.png
       Reply  Tue Jun 17 16:52:40 2014, ericq, Update, Computer Scripts / Programs, autolocker confusion 
          Reply  Tue Jun 17 19:39:29 2014, rana, Update, Computer Scripts / Programs, autolocker confusion 
             Reply  Wed Jun 18 11:28:19 2014, Manasa, Update, Computer Scripts / Programs, autolocker confusion 
                Reply  Wed Jun 18 13:29:48 2014, rana, Update, Computer Scripts / Programs, autolocker confusion 
                   Reply  Wed Jun 18 17:38:14 2014, Jenne, Update, Computer Scripts / Programs, autolocker running again 
                      Reply  Thu Jun 19 16:49:15 2014, rana, Update, Computer Scripts / Programs, autolocker running again 
                         Reply  Thu Jun 19 22:04:23 2014, ericq, Update, Computer Scripts / Programs, caget/caput now return in reasonable time 
                            Reply  Fri Jun 20 09:46:49 2014, manasa, Update, IOO, MC WFS servo turned ON 
                            Reply  Fri Jun 20 19:07:44 2014, rana, Update, Computer Scripts / Programs, op340m DNS 
                               Reply  Tue Jun 24 22:46:15 2014, ericq, Update, Computer Scripts / Programs, op340m crons 
       Reply  Tue Jun 17 17:04:26 2014, ericq, Update, Computer Scripts / Programs, FB troubles 
Message ID: 10054     Entry time: Wed Jun 18 11:28:19 2014     In reply to: 10052     Reply to this: 10056
Author: Manasa 
Type: Update 
Category: Computer Scripts / Programs 
Subject: autolocker confusion 

Quote:

I renamed the Autolocker and described it in the elog from this weekend. To run it, you have to run it from the scripts/MC/ directory (as always). I restarted the autolocker on Ottavia with nohup.

> nohup ./AutoLockMC.csh &

To figure out how to get cron to run it, we will have to debug the difference between linux and solaris pgrep, so that's in progress.

I am NOT convinced that the autolocker script is running or doing anything. The MC was unlocked as of this morning and the autolocker wasn't doing anything to any of the MC servo buttons and sliders. The autolocker control shows that it is 'alive' but it still blinks 'MC down' even after I locked the MC manually. I am suspecting that this might have to do something with the caget and caput in autolock script itself rather than the CRON. I will look into this problem later today.

Moral of the story: The autolocker is not doing its job.

ELOG V3.1.3-