40m QIL Cryo_Lab CTN SUS_Lab TCS_Lab OMC_Lab CRIME_Lab FEA ENG_Labs OptContFac Mariner WBEEShop
  40m Log, Page 89 of 344  Not logged in ELOG logo
ID Date Author Type Categoryup Subject
  3486   Mon Aug 30 11:41:34 2010 kiwamuUpdateComputersdisable sendmail and isdn

 {Rana and Kiwamu}

Yesterday we disabled the sendmail daemon and the isdn daemon on allegra because we don't need these daemons always running.

 

-   How to disable/enable daemons:

sudo ntsysv

  3517   Thu Sep 2 21:22:31 2010 Sanjit, KojiConfigurationComputersrossa nvidia driver and dual monitor configuration

 

Simple steps (but don't try these on a working computer without getting some experience on a spare one, you may find it difficult to restore the system if something goes wrong):

  1. download the appropriate driver from NVIDIA website for this computer
    • we did: NVIDIA GeForce 310 64bit Linux, version: 256.53, release date 2010.08.31
  2. keep/move the driver in /root (use "sudo" or "su")
  3. reboot the computer in "single user" mode
    • in the GRUB screen edit the boot command by pressing the appropriate key listed in the screen
    • in the boot command-line put " single" in the end (no other change is normally needed), don't save
    • press ENTER and the system will reboot to a root shell (# prompt)
  4. cd /root
  5. run the NVIDIA driver script
  6. exit the shell (ctrl-d), let the system reboot
    • it should flash (mostly green) "nvidia" screen before starting X
    • in case of problems run system-config-display and revert to vesa driver
  7. login as "root" and run "nvidia-settings" from command line or GUI menu to add/configure display

 

  3518   Thu Sep 2 23:35:33 2010 ranaConfigurationComputersrossa nvidia driver and dual monitor configuration

Why are we running CentOS 4.8 instead of 5.5 ?    What runs at LLO?     What runs in Downs?

  3521   Fri Sep 3 11:23:16 2010 josephbConfigurationComputersrossa nvidia driver and dual monitor configuration
At LLO the machines are running Centos 5.5. A quick login confirms this. Specifically the release is 2.6.18-194.3.1.el5.

Quote:

Why are we running CentOS 4.8 instead of 5.5 ?    What runs at LLO?     What runs in Downs?

 

  3524   Sun Sep 5 21:35:41 2010 ranaConfigurationComputersrossa notes

**** Deleted
apps/emacs
apps/linux64/firefoxold
apps/linux64/comsol      (old v. 3.5)

* running up2date on rossa

* rossa needs to be able move windows between monitors: Xinerama?

* there are permissions problems: controls on rossa can't
make and delete directories made by 'controls' elsewhere.
Some sort of user# or group issue?

  3526   Mon Sep 6 10:08:10 2010 AlbertoConfigurationComputersNetgear Network Switch fan broken.

The Netgear Network Switch in the top shelf of Nodus' rack has a broken fan. It is the one interfaced to the Martian network.

The fan must have broken and it is has now started to produce a loud noise. It's like a truck was parked in the room with the engine running.

Also the other network switch, just below the Netgear, has one of its two fans broken. It is the one interfaced with the General Computer Side.

I tried to knock them to make the noise stop, but nothing happened.

We should consider trying to fix them. Although that would mean disconnecting all the computers.

  3531   Tue Sep 7 10:50:53 2010 josephbConfigurationComputersrossa notes

The controls group is user id 500 by default on most new machines. Unfortunately, the user ID used across the already existing machines is 1001. One method of doing this switch is in this elog.  You can also do the change of the controls ID by becoming root and using the graphical command system-config-users.  This will  let you change the user ID and group ID for controls to 1001.  This graphical interface also lets you change the login shell.

Unfortunately, I had some minor difficulty and I ended up removing the old controls and creating a new controls account with the correct values and using tcsh.  The .cshrc file has been recreated to source cshrc.40m.  The controls account now has correct permissions, although some of the preferences such as background will need to be reset.

 

 

Quote:

**** Deleted
apps/emacs
apps/linux64/firefoxold
apps/linux64/comsol      (old v. 3.5)

* running up2date on rossa

* rossa needs to be able move windows between monitors: Xinerama?

* there are permissions problems: controls on rossa can't
make and delete directories made by 'controls' elsewhere.
Some sort of user# or group issue?

 

  3535   Tue Sep 7 15:57:07 2010 AlbertoConfigurationComputersNodus connection not working. Fixed

[Joe, Alberto]

The Nodus connection to the Martian network stopped working after someone switched cables on the Netgear router. Apparently that router doesn't like to have the 23 and 24 ports connected at the same time.

Joe fixed the connection just freeing either the 23 or the 24 port.

  3537   Tue Sep 7 22:21:17 2010 AlbertoConfigurationComputerselog restarted
  3539   Tue Sep 7 23:17:45 2010 sanjitConfigurationComputersrossa notes

Quote:

* rossa needs to be able move windows between monitors: Xinerama?

 Xinerama support has been enabled on rossa using nvidia-settings.

  3540   Tue Sep 7 23:34:15 2010 Kiwamu, SanjitConfigurationComputerse-log

e-log was repeatedly hanging and several attempts to start the daemon failed.

problem was solved after clearing the (firefox) browser cache, cookie, everything!!

 

  3541   Tue Sep 7 23:49:08 2010 sanjitConfigurationComputersaldabella network configuration

 

added name server 192.169.113.20 as the first entry in /etc/resolv.conf

changed the host IPs in /etc/hosts to 192.168.xxx.yyy

made:

127.0.0.1 localhost.localdomain localhost

::1 localhost6.localdomain6 localhos6

as the first two lines of /etc/hosts

 

/cvs/cds mounts

on ethernet, DNS look-up works without the explicit host definitions in /etc/hosts,

but those entries are needed for wifi only connection.

 

  3557   Sat Sep 11 03:16:51 2010 ranaConfigurationComputersrossa notes

I wiped out the old CentOS install on rossa and installed CentOS 5.5 on there. The DVDs are on a spindle in the control room; there were 2 iso's, but I only needed the first to install most things.

It still needs to get all of the usual stuff (java, flash, nvidia) installed as well as setting up the .cshrc and the NFS mount of /cvs/cds. The userID and groupID are set to 1001 as before. Whoever

sees Sanjit first should steer him towards this elog entry.

 

  3559   Sun Sep 12 22:36:03 2010 ranaConfigurationComputersrossa notes

I found Sanjit's instructions for doing the Nvidia settings too complicated and so I followed these instructions from Facebook:

http://www.facebook.com/notes/centos-howtos/installing-nvidia-display-drivers-on-centos-55/399295987425

After installations, the monitors were autodetected and the Xinerama effect is working.

  3588   Mon Sep 20 10:33:21 2010 josephbBureaucracyComputersLarry stopped by - GC machine had conflicting IP

Larry stopped by today and had to disconnect the m25 machine (this is the 1st GC machine on the left as you walk into the control room) because its IP was conflicting with a machine over in Downs.  Do not use 131.215.115.125 as the IP on this machine as this is already assigned to someone else.  They couldn't figure out the root password to change it which is why it is not currently plugged into the network, and is not to be until an appropriate IP is assigned.

They've asked that whoever set the machine up to please contact them (extension 2974).

  3595   Wed Sep 22 22:22:12 2010 KojiConfigurationComputersNetgear Network Switch fan broken.

Net switch mumbo-jumbo:

Although Rana is going to buy a replacement for the Netgear Switch for martian, I opened the lid of the Netgear as the fan already have stopped working.
Also the lid of the other network switch for GC (Black one) was opened as it has a broken fan and a noisy half-broken fan.

I have asked Steve to buy replacement fans. These would also be the replacement of the replacement.

During the work, it seemed that I accidentally toggled the power supply of linux1. It lead lengthy fsck of the storage.
This is why all of the machines which rely on linux1 got freezed. linux1 is back and the machines looked happy now.

If you find any machine disconnected from the network, please consult with me.

Quote:

The Netgear Network Switch in the top shelf of Nodus' rack has a broken fan. It is the one interfaced to the Martian network.

The fan must have broken and it is has now started to produce a loud noise. It's like a truck was parked in the room with the engine running.

Also the other network switch, just below the Netgear, has one of its two fans broken. It is the one interfaced with the General Computer Side.

I tried to knock them to make the noise stop, but nothing happened.

We should consider trying to fix them. Although that would mean disconnecting all the computers.

 

  3597   Thu Sep 23 02:45:30 2010 KojiSummaryComputersnodus gracefully rebooted

Zach> Nodus seemed to be working fine again, and I was browsing the elog with no
Zach> problem. I tried making an entry, but when I started uploading a file it
Zach> became unresponsive. Tried SSHing, but I get no prompt after the welcome
Zach> blurb. ^C gives me some kind of tcsh prompt (">"), which only really
Zach> responds to ^D (logout). Don't know what else to do, but I assume someone
Zach> knows what's going on.

By gracefully rebooting nodus, the problem was solved.


It (">") actually was the tcsh prompt, but any commands with the shared or dynamic link libraries looked unfunctional.

I could use
    cd /.../...
and
    echo *
to browse the directory tree. The main mounted file systems like /, /usr, /var, /cvs/cds/caltech looked fine.
I was afraid that the important library files were damaged.

I tried
    umountall
and
    mountall
in order to flush the file systems.
These should run even without the libraries as mount must properly work even before /usr is mounted.

They indeed did something to the system. Once I re-launch a new login shell, the prompt was still ">"
but now I could use most of the commands.

I have rebooted by usual sudo-ing and now the services on nodus are back to the functional state again.

# nodus was working in the evening at around 9pm. I even made an e-log entry about that.
# So I like to assume this is not directly related to the linux1 incident. Something else could have happened.

  3598   Thu Sep 23 10:34:20 2010 ranaFrogsComputersnodus gracefully rebooted

SVN down

mafalda down

I am guessing that the NFS file system hangup may have caused some machines to get into an awkward state. We may be best off doing a controlled power cycle of everything...

  3599   Thu Sep 23 11:15:20 2010 KojiFrogsComputersnodus gracefully rebooted

svn is back after starting apache on nodus.

http://lhocds.ligo-wa.caltech.edu:8000/40m/ApacheOnNodus

Quote:

SVN down

mafalda down

I am guessing that the NFS file system hangup may have caused some machines to get into an awkward state. We may be best off doing a controlled power cycle of everything...

 

  3601   Thu Sep 23 13:16:57 2010 KojiFrogsComputersnodus gracefully rebooted

mafalda is up now.

I found that the cable for mafalda (the sole red cable) had a broken latch.
The cable was about falling off from the switch. As a first-aid, I used this technique to put a new latch, and put it into the switch.

Now I can logged in it. I did not rebooted it.

Quote:

SVN down

mafalda down

I am guessing that the NFS file system hangup may have caused some machines to get into an awkward state. We may be best off doing a controlled power cycle of everything...

 

  3623   Wed Sep 29 18:28:32 2010 yutaUpdateComputersaldabella connects to the wireless network

Background:
 We need laptops that connect to the wireless network to use them in the lab.

aldabella:
 Dell Inspiron E1505 laptop
 Broadcom Corporation BCM4311 802.11b/g WLAN (rev 01) (PCIID: 14e4:4311 (rev 01))

What I did:
1. I followed this method(Japanese!): http://www.linuxmania.jp/wireless_lan.html
 Except I installed ndiswrapper-1.56 and cabextracted sp32156.exe.
  http://sourceforge.net/apps/mediawiki/ndiswrapper/index.php?title=Broadcom_BCM4311
 Also, I didn't run
  # ndiswrapper -m

2. Then I did step #6 in here: http://nodus.ligo.caltech.edu:8080/40m/1275
 Note that the hardware is eth1 instead of wlan0.

3. Added the following line to /etc/rc.d/rc.local to make ndiswrapper load on every boot:
 /sbin/modprobe ndiswrapper

Result:
 aldabella now connects to the wireless martian network on every boot!!

Note:
 Somehow, the method that uses Broadcom official driver doesn't work.
  http://wiki.centos.org/HowTos/Laptops/Wireless/Broadcom
 It returns the following error when activating eth1:
  Error for wireless request "Set Encode" (8B2A) :
    SET failed on device eth1 ; Invalid argument.
  Error for wireless request "Set Encode" (8B2A) :
    SET failed on device eth1; Invalid argument.

  3627   Thu Sep 30 14:09:33 2010 yutaUpdateComputersmariabella connects to the wireless network

Background:
 We need laptops that connect to the wireless network to use them in the lab.

mariabella:
 Dell Inspiron 1210 laptop
 Broadcom Corporation BCM4312 802.11b/g (rev 01) (PCIID: 14e4:4315 (rev 01))

What I did:
1. I followed the same steps I did for aldabella: http://nodus.ligo.caltech.edu:8080/40m/3623
 Except I unzipped R151517-pruned.zip.
   http://myspamb8.googlepages.com/R151517-pruned.zip

2. Note that the PCIID is important for driver selection. Not the model No.
 To check whether your driver selection is correct, run:
  # ndiswrapper -l
 after installing the driver.
 If the driver selection is wrong, it will return only:
  bcmwl5 : driver installed
 If correct, it will return:
  bcmwl5 : driver installed
         device (14E4:4315) present (alternate driver: hoge)

 This page has some information for the driver selection:
   https://help.ubuntu.com/community/WifiDocs/Driver/bcm43xx/Feisty_No-Fluff#Step%202:%20Download%20and%20Extract%20Drivers

Result:
 aldabella now connects to the wireless martian network.

Note:

 Broadcom official driver didn't work for mariabella, too.

  3630   Thu Sep 30 18:51:50 2010 yutaUpdateComputerssetting up aldabella and mariabella

(Kiwamu, Yuta)

Background:
 We wanted to make aldabella and mariabella know how to work.

What we did:

1. Added 2 lines to /etc/rc.local
 /sbin/modprobe ndiswrapper
 sleep 10
 mount linux1:/home/cds/ /cvs/cds


2. Edited ~/.cshrc
 source /cvs/cds/caltech/cshrc.40m

Result:
 Working environment is set to aldabella and mariabella. They have their access to the main system, linux1, now.

Note:
 fstab doesn't work for aldabella and mariabella because the mount should be done after ndiswrapper loads.

  3643   Mon Oct 4 13:48:41 2010 Leo SingerConfigurationComputersUninstalled gstreamer-devel and gstreamer-plugins-base-devel on rosalba

 I uninstalled gstreamer-devel and gst-plugins-base-devel on Rosalba.  Here is the command I ran:

$ sudo yum remove gstreamer-devel gstreamer-plugins-base-devel

 

Actually, I had installed these myself a few days earlier, before I knew that I should be recording such changes in the elog.  I'm sorry!

  3650   Tue Oct 5 13:59:17 2010 Leo SingerConfigurationComputersInstalled x264-devel on Allegra

 I installed the package x264-devel on allegra.martian.  This package provides headers and libraries for the popular h264 video codec.  I am going to use this in the GStreamer streaming media server on Allegra.

  3674   Thu Oct 7 17:53:07 2010 yutaUpdateComputersFarfalla with Firefox, fixed

(Kiwamu, Yuta)

Symptom:
 Farfalla(Acer Aspire one KAV60 netbook) couldn't run Firefox and returned the following error:
  Error: platform version '1.9.2.8' is not compatible with
  minVersion >= 1.9.2.9
  maxVersion <= 1.9.2.9

What we did:
1. Added the following line to ~/.cshrc.
  alias firefox "/usr/lib/firefox-3.6/firefox"
2. Made a cool launcher for firefox.

Result:
 Farfalla can fly into the web with Firefox now.

Notes:

 Even if it was then before, bash could run firefox. tsch couldn't.
 The command firefox was /cvs/cds/caltech/apps/linux/bin/firefox for tsch, because of the source /cvs/cds/caltech/cshrc.40m.
 I did this to zita which had the same symptom, too.

Next work:

 Farfalla wakes up on the wrong side of the bed. This has to be fixed.

  3679   Fri Oct 8 12:29:21 2010 KevinUpdateComputersNew Netgear Switch

I removed some old equipment from the rack outside the control room and stacked them next to the filing cabinets in the control room. I also mounted the new Netgear switch in the rack.

  3693   Mon Oct 11 22:45:16 2010 kiwamuUpdateComputerssolid works 2010 installed

solidworks.PNG

Solid works 2010 was installed to m3, an windows machine in the control room.

Have fun !

  3700   Tue Oct 12 22:06:08 2010 yutaUpdateComputerscelan-installed CentOS 5.5 on mafalda

I clean-installed CentOS 5.5(32bit) on mafalda.
No firewalls, no SELinix.

  3701   Tue Oct 12 23:35:12 2010 mafaldaUpdateComputerscelan-installed CentOS 5.5 on mafalda

Quote:

I clean-installed CentOS 5.5(32bit) on mafalda.
No firewalls, no SELinix.

 Yuta has removed my ethernet connection. Help me!!!

rossa:mDV>ping mafalda
PING mafalda.martian (192.168.113.23) 56(84) bytes of data.
From rossa.martian (192.168.113.215) icmp_seq=2 Destination Host Unreachable
From rossa.martian (192.168.113.215) icmp_seq=3 Destination Host Unreachable
From rossa.martian (192.168.113.215) icmp_seq=4 Destination Host Unreachable

--- mafalda.martian ping statistics ---
5 packets transmitted, 0 received, +3 errors, 100% packet loss, time 3999ms
, pipe 3

  3705   Wed Oct 13 11:09:28 2010 yutaUpdateComputersclean-installed CentOS 5.5 on mafalda

Dear mafalda,

Sorry for leaving you alone.
We put ethernet cable in you. You can talk to everyone now!
We created a user "controls" correctly. (UID: 1001)
We mounted linux1:/home/cds/ to your directory /cvs/cds.

Truly yours,
Joseph Betzwieser
Yuta Michimura

Quote:

Quote:

I clean-installed CentOS 5.5(32bit) on mafalda.
No firewalls, no SELinix.

 Yuta has removed my ethernet connection. Help me!!!

rossa:mDV>ping mafalda
PING mafalda.martian (192.168.113.23) 56(84) bytes of data.
From rossa.martian (192.168.113.215) icmp_seq=2 Destination Host Unreachable
From rossa.martian (192.168.113.215) icmp_seq=3 Destination Host Unreachable
From rossa.martian (192.168.113.215) icmp_seq=4 Destination Host Unreachable

--- mafalda.martian ping statistics ---
5 packets transmitted, 0 received, +3 errors, 100% packet loss, time 3999ms
, pipe 3

 

  3714   Thu Oct 14 10:29:33 2010 josephbUpdateComputersMafalda ready for NDS2, updated Rosalba, Rossa repos

At John Zweizig's request, I installed a couple of packages from the lscsoft repository, along with libtools, automake, autoconf, and several kerberos packages, including cyrus-sasl, cyrus-sasl-lib, cyrus-sasl-devel, cyrus-sasl-gssapi, and krb5-libs.  All it needs now is John to come down and install the NDS2 server.

I copied the lscsoft.repo file from /etc/yum.conf.d/ on allegra to mafalda, as well as rosalba and rossa, just for completeness.  I also added the epel repository to rossa and installed the yum-priorities package and set the priorities on rossa's repositories. 

  3715   Thu Oct 14 10:59:10 2010 josephbUpdateComputersUpdated cshrc.40m and Computer Restart Procedures

I started modifying the cshrc.40m file in /cvs/cds/caltech/ so that it starts pointing at the new directories.

# misc aliases
alias target 'cd /opt/rtcds/caltech/c1/target'
alias scripts 'cd /opt/rtcds/caltech/c1/scripts'
alias chans 'cd /opt/rtcds/caltech/c1/chans'
alias c 'cd /opt/rtcds/caltech/c1'
alias s 'cd /opt/rtcds/caltech/c1/scripts'
alias u 'cd /cvs/cds/caltech/users'

I also added "alias screens 'cd /opt/rtcds/caltech/c1/medm'" as a quick way to get to the medm directory.

Once we get multiple compiled versions (i.e. i386, x86_64, Solaris) of the new gds tools from Alex, we'll have to some more serious surgery on this file.

I removed the "New Computer Restart Procedures" and simply moved the changes into the "Computer Restart procedures", found here.  I've removed everything I don't think applies anymore (all the VME FE reboot procedures for example).

  3716   Thu Oct 14 12:45:47 2010 josephbUpdateComputersNDS 2 server installation on mafalda

[Joe, John Zweizig]

John stopped by around noon today to install the NDS 2 server.  He installed it /cvs/cds/caltech/users/jzweizig/nds2-server/.

Once John is done, I will be moving this to a more sensible install location that is not his user directory, but its there for the moment.

We had to install a couple more packages including bzip2, bzip2-devel, gcc-c++, openssl, and openssl-devel. 

We mounted the /frames directory from the fb machine to mafalda by modifying the /etc/fstab file with the line:

fb:/frames              /frames                 nfs     bg,ro           0 0

 

If we change channels recorded by the frame builder, we need to update a channel list file for the NDS 2 server.  There's an excutable located at:

/cvs/cds/caltech/users/jzweizig/nds2-server/bin/buildChannelList

This builds the file list if given a .gwf file.  These are written by the frame builder, and can be found in /frames/full/####, where #### are the first 4 gps digits of the gravity files contained in that directory.

Upon questing about when we get to GPS time 1000000000, he said there's some updates he needs to do so it rather throws away the last 5 digits, rather than keeping the first 4.

An example command run on the fb or mafalda machine is:

/cvs/cds/caltech/users/jzweizig/nds2-server/bin/buildChannelList  /frames/full/9711/C-R-971119728-16.gwf > nds2-mafalda/C-R-ChanList.txt

For a seconds trends file (located in /frames/trends/second/ instead of /frames/full)

/cvs/cds/caltech/users/jzweizig/nds2-server/bin/buildChannelList  /frames/trends/second/9711/ C-T-971106780-60.gwf > nds2-mafalda/C-T-ChanList.txt

For a minute trends file (located in /frames/trends/minute)

/cvs/cds/caltech/users/jzweizig/nds2-server/bin/buildChannelList  /frames/trends/minute/9711/C-T-971106780-60.gwf  > nds2-mafalda/C-M-ChanList.txt

In these cases, John was putting the lists in the /cvs/cds/caltech/users/jzweizig/nds2-mafalda/ directory.

 

Both the  C-raw-cache.txt file and the nds2.conf files need to be configured to point at the correct files in the nds2-mafalda directory.

 

  3718   Thu Oct 14 13:09:01 2010 Leo SingerConfigurationComputersnds2-client-devel installed on rossa

I installed nds2-client-devel on rossa using the following command:

$ sudo yum install nds2-client-devel

  3719   Thu Oct 14 13:15:14 2010 Leo SingerConfigurationComputersgit installed on rossa

I installed git on rossa using:

$ sudo yum install git

  3721   Thu Oct 14 14:52:52 2010 Leo SingerConfigurationComputersnumpy, ipython, matplotlib, python-matplotlib installed on rossa

I installed the following packages on rossa:

numpy, ipython, matplotlib, python-matplotlib

  3722   Thu Oct 14 20:31:15 2010 yutaUpdateComputerspyNDS installation

EDIT by kiwamu Dec.7th ;

The Pynds package has been moved to the appropriate place:

/cvs/cds/caltech/apps/linux64/python/lib64/python2.4/site-packages

Background:
 We need the python module pyNDS to get the data directly from the server using python.
 Leo helped us install pyNDS today.

Installation:
1. Get pyNDS source tarball from here.
  https://www.lsc-group.phys.uwm.edu/daswg/download/software/source/pynds-0.3.tar.gz

2. All you need is Boost.Python and nds2-client. See README in the pynds-0.3 directory.

3. I installed pyNDS to /cvs/cds/caltech/users/yuta/pynds

4. You have to set environment variable to import the module. For example, run;
  setenv PYTHONPATH /users/yuta/pynds/lib64/python2.4/site-packages:${PYTHONPATH}

Notes:
 RPM will be available soon from Leo.

  3723   Thu Oct 14 20:49:50 2010 yutaUpdateComputersautomated Q-value adjuster

Background:
 Now we can use pyNDS(see elog #3722), so I wrote a python script that adjusts Q-value automatically.

What I did:
1. Wrote a python script. /cvs/cds/caltech/users/yuta/scripts/QAdjuster.py

2. Ran this script for every DOF, every MC suspension.

Result:
 Following lines and attached are example output when I ran QAdjuster.py for MC3 POS.

Currently, C1:SUS-MC3_SUSPOS_GAIN is 5

Connecting.... authenticate failed: Unspecified error
Connecting.... done
Current GPS time is 971149410

I kicked C1:SUS-MC3_SUSPOS_OFFSET

Waiting for the ringdown...... 0\

Current GPS time is 971149431

omega_0= 6.326764,
Q= 11.254252,
A= -53.491850,
delta= 5.007821,
ofset= 4349.808434

Q-value was 11.3
Set C1:SUS-MC3_SUSPOS_GAIN = 10.2311380794


 Current Q-values automatically set are as follows.

  MC1 MC2 MC3
POS 4.9 4.8 5.9
PIT 6.8 5.5 4.5
YAW 6.4 5.6 5.3
SIDE 5.8 5.2 5.0


Next work:
 - Modify the script so that it adjusts all the channels automatically. Now, it is one by one, trial by trial.
 - Modify the script so that it automatically turns the offset switch on. Now, it must be turned on beforehand.
 - Write a how-to

Attachment 1: MC3_SUSPOS.png
MC3_SUSPOS.png
  3724   Thu Oct 14 22:26:38 2010 KojiUpdateComputersNew Netgear Switch

The network cables for the Martian network were moved to the new Netgear switch from the old one which had the broken fan.
The martian machines look happy so far.

Above the new switch we have the GC network switch. The two fans of it were also broken. The fans were replaced.

They are now quiet and I am quite satisfied.

Quote:

I removed some old equipment from the rack outside the control room and stacked them next to the filing cabinets in the control room. I also mounted the new Netgear switch in the rack.

 

  3734   Mon Oct 18 11:22:13 2010 JenneUpdateComputersShame on people not elogging! FrameFiles backups not working.

On the one hand, SHAME ON ALL PEOPLE WHO DON'T ELOG THINGS, such as the moving of scripts directories (it was a pain to figure out that that's part of why the backup scripts are broken).  On the other hand, the moving of the scripts directories brought to light a critical problem in the backup scheme. None of the frame files have been backed up since Joe replaced fb40m with fb, on ~23 Sept (I think).

What went down:

The frame builder was replaced, and no backup script was started up on the new machine.  Sadface.  Crontab doesn't work yet on the new machine, and also the 'ssh-add' commands give an error:

controls@fb /cvs/cds/rtcds/caltech/c1/scripts/backup $ ssh-add ~/.ssh/id_rsa
No such file or directory
controls@fb /cvs/cds/rtcds/caltech/c1/scripts/backup $ ssh-add ~/.ssh/backup2PB 
No such file or directory

Thus, I know that the backup was never running on the new fb.  However, the check-er script runs on nodus, and looks at the logfile, and since there was no script running, it wasn't adding to the log file, so the last log was an "Okay, everything worked" entry.  So, the check-er script kept sending me daily emails saying that everything was okie-dokey. 

Since all of the scripts were moved (Joe said this happened on Friday, although there's no elog about it), the check-er script, and all of the rest of the backup scripts point to the wrong places (the old scripts/backup directory), so I didn't receive any emails about the backup either way (usually it at least sends a "Hey, I'm broken" email).  This clued me in that we need to check things out, and I discovered that it's all gone to hell.

Since I can't add the ssh clients to the new fb, I can't actually log in to the backup computers over in Powell-Booth to check when the last legitimately successful backup was. But I suspect it was just before the fb was replaced.

So, we need to get Crontab up and running on the new Frame Builder machine so that we can run cron jobs, and we also need to figure out this backup hullabaloo.  I think I'll email / call Dan Kozak over in downs, who was talking about upgrading our backup scheme anyway.

 

  3749   Thu Oct 21 01:11:48 2010 ranaSummaryComputerselog change and rossa tex

I deleted a bunch of categories from the elogd.cfg file. Not every kind of locking and activity gets its own activity. All of the things related to length sensing and control should be LSC. If there's a high pollen count its under PEM. etc., etc., etc.

I decided that the 'tetex' distribution which comes with CentOS is total BS and I removed it from rossa using 'yum erase tetex'. I installed TexLive using the instructions on the web; its much better, actually works, and also has RevTex 4.1 which allows Jenne and I to write our paper.

Eventually, we'll standardize our workstation setups.

Yuta has also successfully set up zita to run the projector, so we should clear our some of the boxes and bookshelves in that area so that the projection can be larger.

  3753   Thu Oct 21 13:05:19 2010 KojiSummaryComputerselog change and rossa tex

This is cool though the projector is flashing the blue screen alternately.

I gave the dual head video card (ATI RADEON something) to Yuta a month ago.
It is on the top of Zita. This would make the things more fun.

Quote:

Yuta has also successfully set up zita to run the projector, so we should clear our some of the boxes and bookshelves in that area so that the projection can be larger.

 

  3790   Tue Oct 26 22:57:37 2010 JenneConfigurationComputersWhy doesn't DTT work?!?

DTT has only SUS and "X02" channels under C1 in the drop down channel selection menu.  Basically, we can't measure any fast channels with DTT.  I keep getting the error: "Unable to select testpoints."  Sadface.

Similar things are true for DataViewer.  The same limited number of fast channels, and no data found:

Server error 13: no data found
datasrv: DataWriteRealtime failed: daq_send: Illegal seek

Is this a framebuilder problem?  Is this something that the CDS team has on the to-do list?

  3793   Wed Oct 27 10:53:03 2010 josephbConfigurationComputersWhy doesn't DTT work?!?

Test points for the SUS channels should be there.  They have been working previously this week.  Possibly break down points include awgtpman, mx_streams, and the fb itself.  I'll look into that.

As far as other fast channels, there are no other fast front ends running than the suspensions ones we have.  Until additional channels get connected to the front ends and the models updated, those are the channels we have available.  However I am working on getting c1ioo up and running, and we can try connecting in some PEM channels today to the c1sus front end's 4th ADC.

 

Edit:

I tried starting a fresh instance of the frame builder, but when I brought the old copy down, it left a pair of zombie or dead mx_stream processes running on c1sus . Basically c1mcs and c1rms were still running, while c1x02 and c1sus came down.  I tried to kill the processes but this caused the c1sus machine to crash.  In the past I've killed left over mx_stream processes running after the frame builder has gone down, but I've never seen them crash the computer.  I'm unsure why this happened since we haven't done any updates of the code, just updated models and daq configuration files.

Quote:

DTT has only SUS and "X02" channels under C1 in the drop down channel selection menu.  Basically, we can't measure any fast channels with DTT.  I keep getting the error: "Unable to select testpoints."  Sadface.

Similar things are true for DataViewer.  The same limited number of fast channels, and no data found:

Server error 13: no data found
datasrv: DataWriteRealtime failed: daq_send: Illegal seek

Is this a framebuilder problem?  Is this something that the CDS team has on the to-do list?

 

  3835   Mon Nov 1 12:38:56 2010 Leo SingerConfigurationComputerspython-sqlite installed on Allegra

I installed the Python bindings for sqlite on Allegra using

$ sudo yum install python-sqlite python-sqlite2

  3875   Sat Nov 6 01:54:15 2010 FrankSummaryComputersvirus definition file update on laptop for dinocam

i took some pictures with the dinocam this afternoon. I used the laptop computer next to it using wireless lan connection to the caltech network to send the pictures to me.

The installed anti virus software was bitching about the old database and wanted to update that. As the installed virus definition database was from mid last year i agreed and started downloading the update. As the file was huge (~100MB) it wasn't finished when i left. computer is still running and probably waiting for instructions.

Will come back on the weekend to finalize the new virus definition file database installation.

  3907   Fri Nov 12 11:36:06 2010 AidanConfigurationComputersFixed the PERL PATH errors from the scripts directory change

 I've been trying to get a PID loop running for the green locking and I've discovered that some of the directories in the path for the Perl Modules are now obselete. Specifically, since the scripts directory has been moved from /cvs/cds/caltech/scripts to /cvs/cds/rtcds/caltech/c1/scripts the following locations in the Perl @INC path list need to be changed:

  • /cvs/cds/caltech/scripts/general
  • /cvs/cds/caltech/scripts/general/perlmodules

I've added the above directories to the PERL5LIB path in /cvs/cds/caltech/cshrc.40m.

 

 

setenv PERL5LIB /cvs/cds/caltech/scripts/general:

/cvs/cds/caltech/scripts/general/perlmodules:

/cvs/cds/caltech/libs/solaris9/usr_local_lib/perl5/5.8.0/:

/cvs/cds/rtcds/caltech/c1/scripts/general:

/cvs/cds/rtcds/caltech/c1/scripts/general/perlmodules

 This seems to fix the problem .. at least, you no longer get an error if you try nodus:~>perl -e 'user EpicsTools'

 

  3969   Mon Nov 22 20:01:56 2010 kiwamuConfigurationComputersGPIB box : took it out from HP3563A and connect it to AG4395A

 I disconnected the yellow GPIB box from the backside of HP3563A (classic analyzer),

and connected it to AG4395A (network analyzer), which is the official place for it.

  3981   Tue Nov 23 22:45:59 2010 kiwamuUpdateComputersAltium

I installed and activated Altium, a PCB design software, on the Windows machine M2.

With Altium I am going to design the triple resonant circuit for the broadband EOM.

ELOG V3.1.3-