40m QIL Cryo_Lab CTN SUS_Lab TCS_Lab OMC_Lab CRIME_Lab FEA ENG_Labs OptContFac Mariner WBEEShop
  40m Log, Page 339 of 344  Not logged in ELOG logo
New entries since:Wed Dec 31 16:00:00 1969
Entry  Tue Dec 14 09:26:17 2010, Zach, Update, elog, restarted 
 Restarted the elog with the script
Entry  Sat Dec 18 06:24:49 2010, rana, Update, elog, restarted 
The process was taking up 100% of the CPU and not responding via web. The .log file showed the last action was somebody reading/editing one of Jenne's
entries from August regarding TT ECD. The restart script didn't work, so I had to do a 'kill -9' to get it to die.
    Reply  Sat Dec 18 23:33:06 2010, Koji, Update, elog, restarted 
Did the same.


    
        
            Quote:
        
        
            
    Reply  Sun Dec 19 11:19:42 2010, Koji, Update, elog, restarted 
Did it again. It seemed that Google bot came to the elog and tried to obtain  "http://nodus.ligo.caltech.edu:8080/robots.txt". That was the
last of the log.
Bot came from the AJW's homepage. Also Google FeedFecther came to the elog.
    Reply  Sun Dec 19 22:45:28 2010, rana, Update, elog, restarted 
I deleted the yellow box which showed up by default when making an elog entry. Would be nice if we could make it so that you have to click a button to
'opt-in' for the yellow box rather than get it by default.
I added a 'robots.txt' file to the /users/public_html/ area using Google's
Entry  Tue Dec 21 08:26:08 2010, rana, Update, elog, elogd is getting killed by Suresh 
Suresh killed the elogd again from India. This was the log file:
Accept-Charset: ISO-8859-1,utf-8;q=0.7,*;q=0.7
Keep-Alive: 115
    Reply  Wed Dec 22 06:50:19 2010, rana, Update, elog, elogd is getting killed by Suresh 
After another elog crash, I've blacklisted the domain that Suresh is using by editing the apache httpd.conf. Let's see what happens now.
    Reply  Thu Dec 23 03:15:11 2010, Koji, Update, elog, elogd is getting killed by Suresh 
ELOG has crashed and I restarted it.
Actually the filtering is not effective so far as elog is not using apache but has its own web server inside.
So this just block the access to port 30889 (=SVN, Dokuwiki, etc).
Entry  Thu Dec 23 08:54:32 2010, Suresh, Update, elog, the delhi univ syndrome 
Sorry folks!  I couldnt get to the elog and didnt know that the elog was crashing every time I tried to access it. 
But have found other means to access it and the elog is safe for now!
Entry  Wed Dec 29 18:53:11 2010, rana, Summary, elog, found hung - restarted 
This was the error today:
GET /40m/ HTTP/1.1
Host: nodus.ligo.caltech.edu:8080
    Reply  Mon Jan 3 10:32:27 2011, kiwamu, Summary, elog, found hung - restarted 
Found exactly the same error messages at the end of the log file.


    
        
            Quote: #4098
        
        
            
    Reply  Wed Jan 5 10:45:51 2011, Koji, Update, elog, restarted 
Google bot  crashed the elog again. Then, I found that Google bot (and I) can crash elogd by trying to show the threaded view.
There looks similar issue reported to the elog forum, the author did not think this is a true bag.
Note: This happens only for the 40m elog. The other elogs (ATF/PSL/TCS/SUS/Cryo) are OK for the threaded view.
Entry  Wed Jan 5 21:19:29 2011, Zach, Update, elog, restarted 
 Restarted the elog with the script
    Reply  Thu Jan 6 10:47:11 2011, Koji, Update, elog, ELOG fixed (re: restarted) 
Fixed the 40m elog crashing with the threaded display.
This morning I found that Google
bot crashed the elog again. I started the investigation and found the threaded mode is fine if we use the recent 10 entries.
I gradually copied the old entries to a temporary elog and found that a deleted elog entry on August 6 had a corrupted remnant in the elog file.
Entry  Wed Jan 19 10:31:24 2011, josephb, Update, elog, Elog restarted again 
Elog wasn't responding at around 10 am this morning.  I killed the elogd process, then used the restart script.
Entry  Mon Feb 21 11:05:51 2011, Zach, Update, elog, restarted 
 I restarted the elog using the script.
Entry  Mon Feb 21 23:00:06 2011, Zach, Summary, elog, restarted 
 again
Entry  Tue Mar 1 08:42:18 2011, Aidan, Update, elog, Restarted the elog this morning Zombie.gif
 The elog was dead this morning. I reanimated it. It is now undead.
Entry  Fri Mar 4 13:25:04 2011, Zach, Update, elog, restarted 
with script
Entry  Thu Mar 24 13:56:05 2011, josephb, Update, elog, elog restarted at 1:55pm 
Restarted elog.
Entry  Fri Apr 22 02:10:53 2011, Zach, Update, elog, restarted 
Restarted the elog with the script.
Entry  Tue Apr 26 22:56:35 2011, Zach, Update, elog, restarted 
 with script
Entry  Wed Apr 27 20:14:16 2011, Aidan, Summary, elog, Restarted with script ... 
 
Entry  Wed May 18 18:33:46 2011, Aidan, Update, elog, restarted elog with script 
 
Entry  Thu May 19 00:15:20 2011, Jenne, Update, elog, Restarted, Italian-style 
Aka, from a hotel in Pisa.
    Reply  Thu May 19 00:22:21 2011, rana, Update, elog, Restarted, Italian-style 


    
        
            Quote:
        
        
            
            Aka, from a hotel in Pisa.
Entry  Fri Jul 15 19:00:18 2011, dmass, Metaphysics, elog, Crashes 
Elog crashed a couple times, restarted it a couple times.
Entry  Wed Jul 20 11:13:59 2011, Larisa Thorne, Update, elog, I restarted the ELOG as it seemed to have crashed 
 
Entry  Sun Aug 14 19:06:50 2011, Jenne, Update, elog, elog dead. Brought back to life 
like the subject says...
Entry  Tue Sep 6 21:00:48 2011, Zach, Update, elog, elog restarted 
I restarted the elog with the script as it was not up when I tried to make a post. It was again unresponsive when I went to submit, but this time the
script couldn't restart it. The log said it couldn't bind to 8080, which usually happens if the daemon is still running. I pkilled it, then reran the script,
and it appears to be working.
Entry  Wed Sep 7 20:44:11 2011, Suresh, Update, elog, restarted 
Elog crashed / dormant for long time.  A look at the log file indicated that it was busy generating png thumbnails for pdf files.
Restarted at Wed Sep  7 20:41:13 PDT 2011
 
Entry  Tue Sep 27 11:43:59 2011, Jenne, Update, elog, Elog has been dying a lot lately... 
WTF?
Entry  Tue Oct 25 21:23:17 2011, Dmass, Bureaucracy, elog, Elog Restarted 
Elog went nonreponsive. SSH'ed into nodus to run restart script. Elog came back ~15 minutes later.
Entry  Fri Oct 28 02:41:18 2011, Suresh, Metaphysics, elog, elog unresponsive: restarted 
Elog did not respond despite running the /cvs/cds/caltech/elog/start-elog.csh  script two times.  
It worked the after the third restart.  
 
Entry  Wed Nov 2 14:07:25 2011, Zach, Update, elog, restarted 
Elog was hanging, restarted with the script.
Entry  Mon Nov 7 11:50:42 2011, Jenne, Update, elog, Restarted elog 
Elog restart script killed the elog, but didn't restart it.  Restarted by hand.
    Reply  Mon Nov 7 12:51:44 2011, Zach, Update, elog, Restarted elog 
I've noticed that it always takes running the script twice for it to actually work. I think there's something wrong with how it's doing it. I'll mess
with it sometime the elog isn't getting much use.


    
        
            
Entry  Wed Nov 9 19:08:18 2011, Suresh, Update, elog, restarted elog 
Elog was not responding and was restarted.
Entry  Fri Nov 11 00:58:19 2011, Den, Update, elog, restarted elog 
Elog suspended 2 times for 1 hour. Too high frequency.
Restarted.
Entry  Wed Nov 16 01:45:37 2011, Zach, Update, elog, restarted 
Elog was hanging. Restarted it with script.
    Reply  Wed Nov 16 02:36:35 2011, Koji, Update, elog, restarted 
Basically, elog hangs up by the visit of googlebot.
Googlebot repeatedly tries to obtain all (!) of entries by specifying  "page0" and "mode=full".
Elogd seems not to have the way to block an access from the specified IP.
    Reply  Wed Nov 16 10:13:13 2011, jamie, Update, elog, restarted 


    
        
            Quote:
        
        
            

           Basically, elog hangs up by the visit of googlebot.
    Reply  Wed Nov 16 12:21:33 2011, Koji, Update, elog, googlebot (Re: restarted) 
- elogd itself is a sort of web server which has no freedom to put our own file, we can not put robots.txt
- If we include elog using proxy in the usual web tree of Apache, we can put robots.txt at the root.
- So far, if we prevent "page0" browse by google, we will be saved for a while.
Entry  Fri Nov 18 00:25:10 2011, Zach, Update, elog, restarted 
 with script.
Entry  Tue Nov 22 14:39:50 2011, Jenne, Update, elog, Afternoon elog restart 
Gave the elog its afternoon / tea-time reboot, since it was hanging yet again.
Entry  Wed Nov 23 00:30:55 2011, Zach, Update, elog, sucks 
Tried the script 3 times and it didn't come back. Pkill'd and then scripted. That worked.
Entry  Thu Nov 24 14:42:57 2011, Koji, Update, elog, elogd gained an immunity to googlebot 
I modified elogd.c as shown below in order not to allow to display all of the entries at once by specifying page number "0".
After this modification, elog seems to have survived 66 times of attacks by googlebots.
==============================
    Reply  Thu Nov 24 15:48:27 2011, Illustrator, Update, elog, elogd gained an immunity to googlebot elog_mario.pnggolden-monkey.jpeg

Entry  Mon Mar 26 12:50:24 2012, Zach, Update, elog, restarted with script 
On the plus side, it was the first time I've had to do it in a while..
Entry  Thu Aug 9 12:55:15 2012, Zach, Update, elog, elog was being a pain in the ass; I restarted it 
The elog was not responding. I attempted to restart it by running .../start-elog.csh, but this didn't work (even after the usual ~2 times it needs).
Somehow pkill did not kill the daemon, so I kill -9'd it and that did the trick. I ran the start script once more and it came back online.
ELOG V3.1.3-