40m QIL Cryo_Lab CTN SUS_Lab TCS_Lab OMC_Lab CRIME_Lab FEA ENG_Labs OptContFac Mariner WBEEShop
  40m Log, Page 334 of 341  Not logged in ELOG logo
New entries since:Wed Dec 31 16:00:00 1969
    Reply  Mon Jul 30 14:24:25 2012, Den, Update, digital noise, biquad key is working lnf.png


           What is "DQF"?  Is that the biquad?  And what is the difference between DF1 and DF2?  Why don't you just write out
Entry  Mon Jul 30 16:05:36 2012, Den, Update, digital noise, filter checker iir_psd_notch.pngiir_psd_lp.pngiir_time_lp.png
 We decided to write a script that will check online filters for digital noise. One method can be implemented using the following algorithm:

    calculate filter output using single precision
    calculate filter output using double precision and assume that it is precise

   find digital noise at the output of the filter when single precision is used
    extrapolate the result to the double precision filter
Entry  Sat Aug 4 17:32:31 2012, Den, Update, digital noise, filter checker gur1x.pngC1SUS_BS_SUSPOS.png
The script estimates digital noise produces by online filters. First version of Matlab files and complied c files are in scripts/digital_noise directory.
Algorithm for 1 filter bank (max number of filters = 10):

           extract sos - representation from Foton file for each filter (Matlab)
Entry  Tue Nov 6 18:39:16 2012, Den, Update, digital noise, ifo checking system 
Matlab version of ifo digital noise estimation code is almost ready. It estimates digital noise introduced by each filter bank in each model. I'm waiting
for NDS group to complete function to download online data to Matlab. Now code downloads data from the past that is not great because not all _IN1 channels
are recorded and some of them are recorded at lower frequencies.
Entry  Wed Oct 21 17:12:30 2009, Alberto, Update, elog, Browser context menu enabled on the Elog under HTM editing mode 
On behalf of Steve and of the rest of the not-native-English community at the 40m willing to have their browser's spell checker working while editing
the Elog, I fixed the Elog's feature that prevented Firefox' context menu (that one which pops up with a mouse right click) to work when using the HTML
editing interface (FCKeditor).
Entry  Fri Nov 6 19:29:24 2009, Jenne, Update, elog, elog acting up 
elog was acting up again (not running), so I restarted it. 
    Reply  Fri Nov 6 20:10:15 2009, Jenne, Update, elog, elog acting up 

            elog was acting up again (not running), so I restarted it. 
Entry  Thu Nov 19 16:04:48 2009, Alberto, Configuration, elog, Elog debugging output - Down time programmed today to make changes 
We want the elog process to run in verbose mode so that we can see what's going. The idea is to track the events that trigger the elog crashes.
Following an entry on the Elog Help Forum, I added this line to the elog starting script start-elog-nodus:
./elogd -p 8080 -c /cvs/cds/caltech/elog/elog-2.7.5/elogd.cfg -D -v > elogd.log 2>&1
    Reply  Thu Nov 19 18:49:55 2009, Alberto, Configuration, elog, Elog debugging output - Down time programmed today to make changes 

            We want the elog process to run in verbose mode so that we can see what's going. The idea is to track the events that
Entry  Tue Feb 2 18:15:47 2010, Alberto, Update, elog, Elog restarted it 
 Zach made me notice that the elog had crashed earlier on this afternoon. 
I just restarted it with the restarting script.
Instructions on how to run the last one are now in the wiki page. Look on the "How To" section, under "How to restart the elog".
Entry  Wed Feb 3 10:46:12 2010, Alberto, Update, elog, elog restarted 
 Again, this morning Zach told me that the elog had crashed while he was trying to post an entry.
I just restarted it.
    Reply  Thu Feb 4 00:59:52 2010, rana, Update, elog, elog restarted 
 I restarted the ELOG on NODUS just now. Our attempt to set up error logging worked - it turns out ELOG was choking on the .ps file attachment.
So for the near future: NO MORE .PS
files! Use PDF - move into the 20th century at least.
Entry  Fri Mar 12 13:52:18 2010, Zach, Update, elog, elog restarted 
 The elog was down and I ran the restart script.
Entry  Tue Mar 23 15:38:26 2010, Alberto, Update, elog, elog just restarted  
I found the elog down and I restarted it.
Then, after few seconds it was down again. Maybe someone else was messing with it. I restarted an other 5 times and eventually it came back up.
Entry  Wed Mar 31 10:34:02 2010, josephb, Update, elog, Elog not responding this morning 
When I went to use the elog this morning, it wasn't responding.  I killed the process on nodus, and then restarted, per the 40m wiki instructions.
Entry  Fri Apr 2 08:52:21 2010, Alberto, Update, elog, elog restarted 
i just restarted the elog for the third time in the past 12 hours.
I checked the elog.log file to debug the problem. It doesn't contain eveidence of any particular cause, except for png/jpg file uploads happened
last night.
Entry  Tue Apr 20 13:00:52 2010, Zach, Update, elog, elog restarted 
 I restarted the elog with the restart script as it was down.
Entry  Wed Apr 28 08:55:19 2010, Zach, Update, elog, elog restarted 
 Restarted the elog with the script as it was down.
    Reply  Wed Apr 28 09:21:16 2010, Zach, Update, elog, elog restarted 
And again.

Entry  Tue May 25 07:58:23 2010, kiwamu, Update, elog, elog down 
I found the elog got down around 7:30 am in this morning.
So I restarted it by running the script: "start-elog-nodus" as instructed on the wiki.
Entry  Sat Jun 12 18:03:00 2010, sharmila, Update, elog, Temperature Controller 
Kiwamu and I setup a serial port terminal for receiving data from TC200 via a RS-232 USB interface. It was done using a Python code. Some command definitions
need to be done to get the output from TC-200.
Entry  Thu Jul 8 17:29:20 2010, Katharine, Sharmila, Update, elog,  6x

Last night, we successfully connected and powered our circuit, which
Entry  Mon Jul 12 21:26:02 2010, Katharine, Sharmila, Update, elog, maglev coils P7120276.JPG
The connection between our coil wires and BNC terminals was pretty awful (soldered wires broke off ) so we removed the old heat shrink and re-soldered the wires.  We then chose more appropriately sized heat shrinks (small one around each of the
two soldered wires, a medium-sized shrink around the wires together, a large one covering the BNC terminal and the wire) and used the solder iron and heat
Entry  Wed Jul 14 01:05:27 2010, Sharmila,Katharine, Summary, elog, Maglev P7120284.JPGP7120278.JPGP7120281.JPGP7140292.JPG
Yesterday we hooked up the Quadrant Maglev control to the power supply to test the components in the Input/Output part of the circuit.
The output from the buffer was an unexpected high noise signal which was caused by some circuit components.
Entry  Fri Jul 16 12:36:00 2010, Katharine, Sharmila, Update, elog, levitation CIMG0649.AVI
After last night's challenge (or inspiration), we levitated our magnet this morning.  Since the nice Olympus camera is not currently in the 40m,
we had to use my less stellar camera, but despite the poor video quality you can still see the magnet returning to its stable equilibrium position. 
Once we recover the better camera, we will post new videos.  Also, we haven't yet figured out how to put videos in line in the elog entry, so here
Entry  Tue Jul 20 11:55:15 2010, Sharmila,Katharine, Update, elog, Maglev tf.pngP7140292.JPG
We plotted the transfer functions for the maglev control circuit and compared them with the plots from the spectrum 
analyzer. We were stuck for sometime because
Entry  Sat Aug 7 10:47:38 2010, Koji, Summary, elog, elog restarted / source of the trouble eliminated 
Nancy notified me that the elog crashed. It was fixed.

I restarted elog, but it kept crashing. Some of the entries on Aug 6th caused the trouble.
I tried to refresh the pictures in entries 3376, 3377, 3378. Still it kept crashing.
Entry  Tue Aug 10 01:05:17 2010, Zach, Update, elog, elog restarted 
 Elog was down. Restarted with the script.
Entry  Wed Aug 11 02:44:37 2010, Zach, Update, elog, elog restarted 
You'll never guess what happened: the elog crashed!
I restarted it with the script. Yay.
Entry  Wed Aug 11 16:13:59 2010, Jenna, Update, elog, elog restarted 
The elog crashed, so we restarted it again.
Entry  Thu Aug 12 11:39:27 2010, Zach, Update, elog, elog restarted 
with script
Entry  Thu Aug 12 23:17:54 2010, Zach, Update, elog, restarted 
    Reply  Thu Aug 12 23:41:48 2010, Jenne, Update, elog, restarted 

    Reply  Fri Aug 13 13:11:30 2010, Dmass, Update, elog, restarted 

Entry  Mon Aug 16 23:13:25 2010, Zach, Update, elog, e to the log 

    I get so many freebies it's ridiculous
Entry  Tue Aug 17 09:06:08 2010, Alberto, Update, elog, elog was down 
I just restarted the elog after I found it down a few minutes ago.
Entry  Tue Aug 17 23:59:46 2010, Katharine, Update, elog, Maglev update repulsiveforce.pngOSEMcalibration.pngOSEMslopes.png
Katharine, Sharmila

Entry  Wed Aug 18 19:14:59 2010, Jenne, Update, elog, elog dead again 
The elog was so dead this time that the restart script didn't work.  I followed the restart-by-hand instructions instead, with success.
    Reply  Thu Aug 19 01:49:14 2010, Jenne, Update, elog, elog dead again 

            The elog was so dead this time that the restart script didn't work.  I followed the restart-by-hand instructions
    Reply  Thu Aug 19 09:51:43 2010, josephb, Update, elog, elog dead again 
I found the elog dead again this morning, and the script didn't kill again.  I modified the script to use the following line instead of "pkill elogd":
kill `ps -ef | grep elogd | grep -v grep | grep -v start-elog-nodus | awk '{print $2}'`
Hopefully the script will be a bit more robust in the future.
Entry  Thu Aug 19 21:56:02 2010, Zach, Update, elog, restarted 
Entry  Fri Aug 20 13:09:53 2010, josephb, Update, elog, Rebooted elog 
I had to restart the elog again.
At this point, I'm going to try to get one of the GC guys to install gdb on nodus, and run the elog in the debugger, that way when it crashes the
next time, I have some error output I can send back to the developer and ask why its crashing there.
Entry  Sun Aug 22 16:20:24 2010, Zach, Update, elog, restarted (with my phone this time) 
Entry  Mon Aug 23 00:08:24 2010, Jenne, Update, elog, Joe, I think this's your cue... 
Entry  Tue Aug 24 14:29:18 2010, josephb, Update, elog, Elog down for 1 minute 
I'm going to take the elog down for one minute and restart it under gdb (using a copy of gdb stolen from fb40m since I couldn't figure out how to install
an old enough version on nodus from source).  The terminal with information is running on Rosalba under the "Phase Noise" panel, so please
don't close it.  Ideally, the next time the elog crashes, I'll have some output indicating why or at least the line in the code.  I can then
Entry  Tue Aug 24 17:57:57 2010, Zach, Update, elog, restarted 
 Restarted the elog using the script. I had to do it twice for it to work. This is not the first time this has happened---does anyone know why this
might be?
    Reply  Tue Aug 24 22:26:16 2010, Zach, Update, elog, restarted 
took two again

Entry  Wed Aug 25 12:18:47 2010, josephb, Update, elog, Trying new version of elog to see if it helps stability 
So unfortunately, I made the start-elog-nodus script smart enough to kill the debugging run I had (although thats probably good since there might have
been issues with continuing to run - just poor timing on part of the crash).
In related news, I have gotten the latest version of the elog code to actually compile on Nodus.  I had to hack the cryptic.c file (elog/src/cryptic.c)
Entry  Wed Aug 25 12:40:28 2010, josephb, Update, elog, Reverted back to 2.7.5 until further testing is done 
So apparently the themes/configurations didn't work so nicely on some of the logbooks with 2.8.0, so I'm reverting to 2.7.5 until I can figure out (assuming
I can) how to get them to display properly.
Entry  Wed Aug 25 15:55:33 2010, josephb, Update, elog, Staying with 2.7.5 until passwords sorted out 
Turns out the elog version 2.8.0 uses a different encryption method than 2.7.5.  This mean the encrypted passwords stored in the elogd.cfg don't
work with the new code.  elogd includes functionality to generate encrypted passwords, but unfortunately I don't know the administration passwords
for some of the logbooks.  So I'm going to leave 2.7.5 running until I can get those added properly to the 2.8.0 cfg file.
ELOG V3.1.3-