40m QIL Cryo_Lab CTN SUS_Lab TCS_Lab OMC_Lab CRIME_Lab FEA ENG_Labs OptContFac Mariner WBEEShop
  40m Log, Page 330 of 339  Not logged in ELOG logo
    Reply  Tue Feb 16 09:51:22 2010, Alberto, Update, Green Locking, take some optics away from the ETM end table 


    
        
            Quote:
        
        
            
            In the last two days Steve and I took some optics away from the both ETM end
    Reply  Wed Oct 19 05:15:44 2011, kiwamu, Update, SUS, taking care of SRM f2pSRM.png
I made some efforts to fix the situation of SRM but it is still bad.
The POS motion wasn't well damped. Something is wrong either (maybe both) sensing part or actuation part.
I am going to check the sensing matrix with the new free swinging spectra (#5690)
    Reply  Wed Oct 19 15:46:49 2011, kiwamu, Update, SUS, taking care of SRM SRM.png


    
        
            Quote from #5691
        
  
     
            
            I am going to check the sensing matrix with
    Reply  Fri Aug 31 07:32:49 2012, Steve, Update, SUS, target for BS 


    
        
            Quote:
        
        
            

           We installed beam targets on PRM and BS suspension cages.
Entry  Thu Aug 30 20:35:09 2012, jamie, Update, SUS, target installed on PRM, temporary earthquake stops in place 
We installed beam targets on PRM and BS suspension cages.
On both suspensions one of the screw holes for the target actually houses the set screw for the side OSEM.  This means that the screw on one
side of the target only goes in partial way.
Entry  Tue Jun 12 13:49:32 2012, Jamie, Configuration, Computer Scripts / Programs, tconvert 
A nicer, better maintained version of tconvert is now supplied by the lalapps package.  It's called lalapps_tconvert. 
I installed lalapps on all the workstations and aliased tconvert to point to lalapps_tconvert.
Entry  Fri Jun 5 02:59:03 2009, pete, alberto, Update, Locking, tdsavg failure in cm_step script 
the command
tdsavg 5 C1:LSC-PD4_DC_IN1
was causing grievous woe in the cm_step script.  It turned out to fail intermittently at the command line, as did other LSC channels. 
    Reply  Fri Jun 5 13:51:49 2009, rob, Update, Locking, tdsavg failure in cm_step script 


    
        
            Quote:
        
        
            
            the command
    Reply  Fri Jun 5 16:45:28 2009, rob, pete, HowTo, Computers, tdsavg failure in cm_step script 


    
        
            Quote:
        
        
            
            
            
  
Entry  Mon Jun 11 22:51:11 2012, Jenne, Update, Computers, tdsavg not working 
tdsavg isn't working:
controls@rossa:/opt/rtcds/caltech/c1/scripts/LSC 6$ tdsavg 10 C1:LSC-ASDC_IN1
ERROR: LDAQ - Unable to find NDS host "fb0"
    Reply  Mon Jun 25 11:23:14 2012, Jenne, Update, Computers, tdsavg not working 


    
        
            Quote:
        
        
            

           LSCoffsets script, and any others depending on tdsavg will not work until this is fixed.
Entry  Fri Feb 24 23:14:09 2012, kiwamu, Update, CDS, tdsavg went crazy 
I found that the LSCoffset script didn't work today. The script is supposed to null the electrical offsets in all the LSC channels.
I went through the sentences in the script and eventually found that the tdsavg command returns 0 every
time.
Entry  Fri Dec 5 01:58:58 2008, Yoichi, Configuration, ASC, tdscntr.pl now works at 40m 
Tobin gave me the perl version of tdscntr some time ago.
Pinkesh and I modified and tested it at LHO.
I further modified it today and now it runs fine on the linux machines at the 40m. I haven't tested it with the Solaris machines.
Entry  Thu Mar 5 23:18:38 2009, Kakeru, Configuration, Computers, tdsdata doesn't work 
I found that tdsdata doesn't work.

When I star tdsdata, he takes a few ~ 10 seconds of data, and he dies with a message "Segmentation fault".
    Reply  Sun Mar 8 23:14:52 2009, rana, Update, Computer Scripts / Programs, tdsdata doesn't work 
Matt logged in and rebuilt the TDS stuff for us on Mafalda in /cvs/cds/caltech/apps/linux/tds_090304. 
He says that he can't build his stuff on 64-bit because there's not a sanctioned 64-bit build of GDS yet.
This should have all the latest fixes in it. I tried using both the old and new code from allegra and they both are fine:
    Reply  Mon Mar 9 14:57:30 2009, Kakeru, Update, Computer Scripts / Programs, tdsdata doesn't work oldtds.pngnewtds.png
I tested new tdsdata and found it was working well.
I excited C1:SUS-ITMY_SUSPIT_EXC with tdssine, and get data from C1:LSC-TRY_OUT (testpoint) and C1:SUS- ITMY_OPLEV_PERROR (recorded point)
with new and old tdsdata.
    Reply  Mon Mar 9 16:54:52 2009, Kakeru, Rana, Update, Computer Scripts / Programs, tdsdata doesn't work 
We confirmed that new tds(/cvs/cds/caltech/apps/linux/tds_090304/) works well on linux 64, and replaced it to /cvs/cds/caltech/apps/linux/tds/
The old /cvs/cds/caltech/apps/linux/tds is put in /cvs/cds/caltech/apps/linux/tds.bak
    Reply  Mon Mar 9 23:13:22 2009, Yoichi, Update, Computer Scripts / Programs, tdsdata doesn't work 


    
        
            Quote:
        
        
            
            We confirmed that new tds(/cvs/cds/caltech/apps/linux/tds_090304/) works well on linux 64, and replaced it to /cvs/cds/caltech/apps/linux/tds/
Entry  Fri Feb 20 01:54:18 2009, Kakeru, Update, Computer Scripts / Programs, tdsdata might have a bug jumped_data.png
I found a strange jump of value in my data taken with tdsdata.
I couldn't find same jump in a playback of DataViewer, so I think this is a problem of tdsdata. 
Be careful when you use tdsdata!
Entry  Sun Apr 20 20:29:46 2008, rana, Update, Computer Scripts / Programs, tdsread bugs 
[COLOR=darkred]There seems to be a problem with reading the C1:IOO-MASTER_OVERFLOW field 
when it is read in as part of an array. The only way for me to describe it
is to just attach the terminal output in this entry...this is mainly [B]for
    Reply  Mon Apr 21 13:12:21 2008, rob, Update, Computer Scripts / Programs, tdsread bugs 
[quote][COLOR=darkred]There seems to be a problem with reading the C1:IOO-MASTER_OVERFLOW field 
when it is read in as part of an array. The only way for me to describe it
is to just attach the terminal output in this entry...this is mainly [B]for
Entry  Fri Dec 7 14:14:48 2007, rob, Metaphysics, Computer Scripts / Programs, tdsread problems on Solaris 

[COLOR=darkblue]tdsread[/COLOR] has developed a strange new illness, whereby it cannot read EPICS values from [COLOR=red]two subsystems at once[/COLOR]
(e.g., getting an LSC and SUS value simultaneously).  I thought this might have something to with the fact that both [COLOR=purple]losepics[/COLOR] and
    Reply  Thu Jun 25 17:27:42 2009, rana, Update, Computers, tdsresp on linux  
I downloaded the tdsresp.pl from LLO and put it into the various TDS/bin paths. Also updated the LLO specific path stuff. It runs.
Entry  Wed Jun 24 14:43:19 2009, rob, Update, Computers, tdsresp on linux => pzresp 
 
tdsresp is broken on our linux control room machines.  I made a little perl replacement which uses the DiagTools.pm perl module, called pzresp. 
It's in the $SCRIPTS/general directory, and so in the path of all the machines.  I also edited the cshrc.40m file so that on linux machines tdsresp
    Reply  Tue Nov 6 23:45:38 2007, tobin, Configuration, Computers, tektronix scripts! 
I cooked up a little script to fetch the data from the networked Tektronix scope.  Example usage:

[FONT=Courier]linux2:scripts>[b]tektronix/tek-dump scope0 ch1 foo.csv[/b][/FONT]
Entry  Tue Jul 21 17:01:18 2009, pete, DAQ, DAQ, temp channel PEM-PETER_FE 
I added a temporary channel, to input 9 on the PEM ADCU.    Beware the 30, 31, and 32 inputs.  I tried 32 and it only gave noise.
 
 
Entry  Wed Aug 16 16:05:53 2017, Kira, Update, PEM, temp sensor PCB IMG_20170816_154514.jpgIMG_20170816_154541.jpg
Tried taking the circuit from the breadboard to the PCB. I attached all the components to adapters that would allow them to be connected to the PCB.
From the first picture, the first component is AD586, the second is AD590, and the third is LT1012, along with a resistor across it. I then soldered
the connections between the components, as can be seen in the second picture. When I tested out this version of the circuit by hooking it up to the
    Reply  Thu Aug 17 10:41:58 2017, Kira, Update, PEM, temp sensor PCB IMG_20170817_095917.jpg
Got it to work. One of the connections was faulty. I decided to check the temperature measured against a thermometer. The sensor showed 26.1 C,
but the thermometer showed 25.8 C after I let them both cool down after heating them up. The temperature of the thermometer was dropping at the time of
measurement, but the temperature of the sensor was not. This is still a rough version of the final sensor, so I'm not sure what exactly causes this
    Reply  Mon Aug 21 13:07:08 2017, Kira, Update, PEM, temp sensor PCB IMG_20170821_124121.jpgIMG_20170821_124429~2.jpgIMG_20170821_124108.jpg
On Friday, I cleaned up the circuit so that there are only three connections needed (+15V, -15V, GND) and a BNC connector for reading the output. Today,
I added in bypass capacitors. The small yellow ones are 0.1 microF ceramic, and the large ones are 100 microF electrolytic. They are used to stabilize
the +15V and -15V inputs to the OP amp and minimize fluctuations, since it doesn't have a regulator for stability. I have also attached the circuit
Entry  Tue Aug 21 15:26:04 2012, Steve, Update, PEM, temp sensor for vacuum 
Temperature sensor for vacuum. How many : 2 or 3 ?  $350 each
Glass encapsulated thermistor #55007  with
Ceramabond 835-m glued onto spade
    Reply  Thu Feb 22 16:16:43 2018, Kira, Update, PEM, temp sensor input IMG_20180222_160602.jpg
Rewired the temperature sensor inputs to Molex connectors so that we can now attach them to the +/- 15V Sorensens for input instead of using a power
supply.
    Reply  Mon Feb 26 16:22:10 2018, Kira, Update, PEM, temp sensor input 1.jpgIMG_20180226_154649.jpgIMG_20180226_154720.jpg
[Kira, Gautam]

We began the setup for the lab temperature sensor today. First, we needed to add in a DIN fuse for both temperature sensors, which required us
to shut down everything else first. To avoid having to do that next time, we made three instead of two spaces where we have + and - 15V. Attachment 1 shows
    Reply  Wed Feb 28 12:31:28 2018, Kira, Update, PEM, temp sensor input 
I switched out the DIN fuses for the long cables and it fixed the issue of them not showing any votage on the other end. At first, the +15V cable
worked and the -15V didn't, but when I switched the fuse for the -15V it began working, but the +15V stopped working. I then switched out the fuse
for +15V and both cables began showing voltage. But for both the long cables and the shorter ones, they show +13.4V instead of +15V. Not sure what's
Entry  Tue Aug 15 11:50:21 2017, Kira, Summary, PEM, temp sensor packaging/mount 
For the final packaging/mounting of the sensor to the seismometer, I have thought of two options.

1. Attach circuit to a PCB board and place it inside the can, while leaving the AD590 open to the air inside the can.


This makes sure that the sensor gets a direct measurement of the temperature of the air in the can, as it is exposed to the air. 
But,
Entry  Fri Sep 1 15:46:12 2017, Kira, Update, PEM, temp sensor update IMG_20170901_144729.jpg
I took off the AD590 and attached it to two long wires leading out from the board. This will allow us to attach the sensor to a metal block and
not have to stick the whole board to it. I have also completed three identical copies of this and it's pretty much ready to be tested. According to
Craig and Andrew's elog here, the sensor is very noisy and they added in a low pass
    Reply  Tue Sep 5 17:18:17 2017, Kira, Update, PEM, temp sensor update IMG_20170905_144924.jpgIMG_20170905_165042.jpg
Today, I stuck on the sensors to a metal block using a flag, rubber bands, and some thermal paste (1st attachment). I then wrapped the whole thing in
about 4 layers of insulation and a lot of tape (2nd attachment). The only things leading out of the box were the three connections to the sensors and a
thermometer. I then connected the wires to their respective places on the board of the sensor. To get the readings out we would need to use an ADC. Gautam
    Reply  Tue Sep 5 17:52:06 2017, Kira, Update, PEM, temp sensor update 
to get the sensors to read the same values they have to be in direct thermal contact with the metal block - there can't be any adapter board in-between

for the 2nd attempt, I also recommend encasing it in a metal block rather than just one side. You can drill some 7-10 mm diameter holes in an
aluminum or copper block. Then put the sensors in there and plug it up with some thermal paste.
    Reply  Fri Sep 8 10:22:30 2017, Steve, Update, PEM, temp sensor update 
The weight of SS can with copper liner  is 12.2 kg

Is 1 Amp for the heating jacket going to be enough? We should have some headroom.




    Reply  Tue Sep 12 11:44:16 2017, Kira, Update, PEM, temp sensor update 
Got it to work. A cable was broken and the AD586 also broke at the same time so it took a while to find the problem. I had to create a makeshift cable
out of three parts so once I replace it for an actual cable, it will be good to go for a test.




Entry  Mon Nov 24 19:15:16 2008, rana, alberto, john, Configuration, Environment, temperature 
The PSL Room Temperature was alarming because it had gone above 23 C. This set off an unfortunate chain of events:

We found that the PSL HEPA was set low (20%). This is a fine setting for when no one is working in there but it
    Reply  Tue Nov 25 19:29:15 2008, rana, alberto, john, Configuration, Environment, temperature 
[quote]The PSL Room Temperature was alarming because it had gone above 23 C. This set off an unfortunate chain of events:

We found that the PSL HEPA was set low (20%). This is a fine setting for when no one is working in there but it
    Reply  Thu Nov 27 22:56:42 2008, rana, Configuration, Environment, temperature mc.png
8-)
Entry  Tue Feb 6 16:58:19 2018, Kira, Update, PEM, temperature measurements temps.png
I decided to plot the temperatures measured over two days for the sensor inside the can and inside the lab just to see if there was any significant difference
between the two, and obtained the following plot. This shows that there is a difference in measurements of a few 0.01 C. The insulated seismometer can
didn't change temperature as much as the lab did, which is as expected. I'll work on properly calibrating the sensors sometime in the future so
Entry  Sun Feb 22 23:43:07 2009, caryn, Summary, General, temperature sensor 12x
Comparing  PSL-FSS-RMTEMP and PEM-MC1-TEMPS
So, to compare temp channels, I made a plot of PSL-FSS_RMTEMP and PEM-MC1_TEMPS(the test temp sensor channel after converting from cts to degC).
This plot begins about 2 months ago t_initial=911805130. The temperature channels look kinda similar but MC1-TEMPS (the temp sensor clamped to MC1,3 chamber)
Entry  Thu Aug 10 14:13:23 2017, Kira, Summary, PEM, temperature sensor IMG_20170810_121637~2.jpgIMG_20170810_134422~2.jpg
Goal is to build a temperature sensor accurate to 1 mK. Schematic is shown below. This does not take into account the DC gain that occurs.

Parts that would be used for this: LM317 regulator, AD592
temperature transducer, OP amp (low input noise and high impedance), 100K (or maybe 10k) resistor. This is what is currently proposed, but the
    Reply  Thu Aug 10 21:22:06 2017, rana, Summary, PEM, temperature sensor tempsensnoise2.pdftempnoise_final.pdf

Should we use the AD590 or the AD592? They're sort of the same, but have slightly different packages and specs.
Given the sensitivity
of the AD590 to power supply drift, I would recommend using a precision voltage reference like the AD581 or AD587. Take a look at the datasheets and order
a few different varieties so we can see what works best for us. I believe that the voltage regulators have too much drift to use for precision temperature
Entry  Fri Aug 11 10:27:49 2017, Kira, Update, PEM, temperature sensor 
Since there seems to be little difference between AD590 and AD592, I guess we could just go with the AD590. The temperature noise spectrum in the first
graph are for the AD590, so if we want to reproduce those results, we should use AD590.

For the AD581/AD587, we could go with a few varieties that have the least output voltage drift, although I am not sure what precision we will
Entry  Fri Aug 11 10:48:39 2017, Kira, Update, PEM, temperature sensor 
Quick update: we actually have AD587KRZ and AD592, so we could start by using that and seeing how it works.
    Reply  Fri Aug 11 11:56:02 2017, rana, Update, PEM, temperature sensor 
Might as well order several of a few different varieties today. Its good to have some extra in stock; we don't always want to have to wait days for
parts to show up. If you give Steve a list of parts to buy he can order them today or Monday.

There should also be some precision 5V sources (e.g. AD586) that you can try.
Entry  Fri Aug 11 12:27:25 2017, Kira, Update, PEM, temperature sensor IMG_20170811_121608.jpgIMG_20170811_121619.jpg
Used AD592CNZ and AD586 (5V output) to create a circuit that works and is responsive to temperature changes. At room temp, using ~1K resistor,
it showed ~0.3V across it, as expected. The voltage went up when we heated it with a heating gun. Next step will be to add in an OP amp and design some
experiments to check to see how accurate it is. Thanks to Gautam for helping me with it!
ELOG V3.1.3-