40m QIL Cryo_Lab CTN SUS_Lab TCS_Lab OMC_Lab CRIME_Lab FEA ENG_Labs OptContFac Mariner WBEEShop
  40m Log  Not logged in ELOG logo
Entry  Thu Sep 2 21:22:31 2010, Sanjit, Koji, Configuration, Computers, rossa nvidia driver and dual monitor configuration 
    Reply  Thu Sep 2 23:35:33 2010, rana, Configuration, Computers, rossa nvidia driver and dual monitor configuration 
       Reply  Fri Sep 3 11:23:16 2010, josephb, Configuration, Computers, rossa nvidia driver and dual monitor configuration 
    Reply  Sun Sep 5 21:35:41 2010, rana, Configuration, Computers, rossa notes 
       Reply  Tue Sep 7 10:50:53 2010, josephb, Configuration, Computers, rossa notes 
          Reply  Sat Sep 11 03:16:51 2010, rana, Configuration, Computers, rossa notes 
             Reply  Sun Sep 12 22:36:03 2010, rana, Configuration, Computers, rossa notes 
       Reply  Tue Sep 7 23:17:45 2010, sanjit, Configuration, Computers, rossa notes 
Message ID: 3517     Entry time: Thu Sep 2 21:22:31 2010     Reply to this: 3518   3524
Author: Sanjit, Koji 
Type: Configuration 
Category: Computers 
Subject: rossa nvidia driver and dual monitor configuration 

 

Simple steps (but don't try these on a working computer without getting some experience on a spare one, you may find it difficult to restore the system if something goes wrong):

  1. download the appropriate driver from NVIDIA website for this computer
    • we did: NVIDIA GeForce 310 64bit Linux, version: 256.53, release date 2010.08.31
  2. keep/move the driver in /root (use "sudo" or "su")
  3. reboot the computer in "single user" mode
    • in the GRUB screen edit the boot command by pressing the appropriate key listed in the screen
    • in the boot command-line put " single" in the end (no other change is normally needed), don't save
    • press ENTER and the system will reboot to a root shell (# prompt)
  4. cd /root
  5. run the NVIDIA driver script
  6. exit the shell (ctrl-d), let the system reboot
    • it should flash (mostly green) "nvidia" screen before starting X
    • in case of problems run system-config-display and revert to vesa driver
  7. login as "root" and run "nvidia-settings" from command line or GUI menu to add/configure display

 

ELOG V3.1.3-