40m QIL Cryo_Lab CTN SUS_Lab TCS_Lab OMC_Lab CRIME_Lab FEA ENG_Labs OptContFac Mariner WBEEShop
  40m Log  Not logged in ELOG logo
Entry  Fri Feb 19 13:28:44 2010, Koji, Update, General, Prep for Power Supply Stop  screen_shot.png
    Reply  Sun Feb 21 17:44:35 2010, rana, Update, General, Prep for Power Supply Stop  
       Reply  Mon Feb 22 07:25:58 2010, rana, Update, General, Prep for Power Supply Stop  
          Reply  Mon Feb 22 09:45:34 2010, josephb, Update, General, Prep for Power Supply Stop  
             Reply  Mon Feb 22 11:42:48 2010, Koji, Update, General, Prep for Power Supply Stop  
Message ID: 2621     Entry time: Mon Feb 22 07:25:58 2010     In reply to: 2620     Reply to this: 2622
Author: rana 
Type: Update 
Category: General 
Subject: Prep for Power Supply Stop  

Autoburts have not been working since the network changeover last Thursday.

Last snapshot was around noon on Feb 11...  


It turns out this happened when the IP address got switched from 131.... to 192.... Here's the horrible little piece of perl code which was failing:

$command = "/usr/sbin/ifconfig -a > $temp";
   system($command);

   open(TEMP,$temp) || die "Cannot open file $temp\n";
   $site = "undefined";
   #                                                                                                     
   # this is a horrible way to determine site location                                                   
   while ($line = <TEMP>) {
     if ($line =~ /10\.1\./) {
       $site = "lho";
     } elsif ($line =~ /10\.100\./) {
       $site = "llo";
     } elsif ($line =~ /192\.168\./) {
       $site = "40m";
     }
   }
   if ($site eq "undefined") {
     die "Cannot Determine Which LIGO Observatory this is\n";

I've now put in the correct numbers for the 40m...and its now working as before. I also re-remembered how the autoburt works:

1) op340m has a line in its crontab to run /cvs/cds/caltech/burt/autoburt/burt.cron (I've changed this to now run at 7 minutes after the hour instead of at the start of the hour).

2) burt.cron runs /cvs/cds/scripts/autoburt.pl (it was using a perl from 1999 to run this - I've now changed it to use the perl 5.8 from 2002 which was already in the path).

3) autoburt.pl looks through every directory in 'target' and tries to do a burt of its .req file.

Oh, and it looks like Joe has fixed the bug where only op440m could ssh into op340m by editing the host.allow or host.deny file (+1 point for Joe).

But he forgot to elog it (-1 point for Joe).®

ELOG V3.1.3-