40m QIL Cryo_Lab CTN SUS_Lab TCS_Lab OMC_Lab CRIME_Lab FEA ENG_Labs OptContFac Mariner WBEEShop
  40m Log  Not logged in ELOG logo
Message ID: 2045     Entry time: Fri Oct 2 18:04:45 2009
Author: rob 
Type: Update 
Category: CDS 
Subject: DTT no good for OMC channels 

I took the output of the OMC DAC and plugged it directly into an OMC ADC channel to see if I could isolate the OMC DAC weirdness I'd been seeing.  It looks like it may have something to do with DTT specifically.

Attachment 1 is a DTT transfer function of a BNC cable and some connectors (plus of course the AI and AA filters in the OMC system).  It looks like this on both linux and solaris.

Attachment 2 is a transfer function using sweepTDS (in mDV), which uses TDS tools as the driver for interfacing with testpoints and DAQ channels. 

Attachment 3 is a triggered time series, taken with DTT, of the same channels as used in the transfer functions, during a transfer function.  I think this shows that the problem lies not with awg or tpman, but with how DTT is computing transfer functions. 

 

I've tried soft reboots of the c1omc, which didn't work.   Since the TDS version appears to work, I suspect the problem may actually be with DTT.

Attachment 1: omc_dac_dtt.png  59 kB  Uploaded Fri Oct 2 19:06:48 2009  | Show | Hide all | Show all
Attachment 2: omc_dac_sweepTDS.png  26 kB  Uploaded Fri Oct 2 19:06:56 2009  | Hide | Hide all | Show all
omc_dac_sweepTDS.png
Attachment 3: omc_dac_dtt_ts.png  77 kB  Uploaded Fri Oct 2 19:07:06 2009  | Hide | Hide all | Show all
omc_dac_dtt_ts.png
ELOG V3.1.3-