40m QIL Cryo_Lab CTN SUS_Lab TCS_Lab OMC_Lab CRIME_Lab FEA ENG_Labs OptContFac Mariner WBEEShop
  40m Log  Not logged in ELOG logo
Entry  Sat Feb 26 01:01:40 2022, Tega, Update, VAC, Ongoing work to get the FRG gauges readouts to EPICs channels 
    Reply  Sat Feb 26 15:45:14 2022, Tega, Update, VAC, Ongoing work to get the FRG gauges readouts to EPICs channels Vac-gauges-flow-diagram.png
       Reply  Mon Feb 28 19:15:10 2022, Tega, Update, VAC, Ongoing work to get the FRG gauges readouts to EPICs channels 
       Reply  Tue Mar 1 20:38:49 2022, Tega, Update, VAC, Ongoing work to get the FRG gauges readouts to EPICs channels Working_Serial_Port_List_1.pngWorking_Serial_Port_List_2.pngWorking_Config_Ports#1-5.pngWorking_Config_Ports#7-8.png
          Reply  Wed Mar 2 11:50:39 2022, Tega, Update, VAC, Ongoing work to get the FRG gauges readouts to EPICs channels XGS600_IOLAN_settings_1.pngXGS600_IOLAN_settings_2.pngXGS600_USBserial_settings.pngXGS600_comm_test.pyXGS600_comm_test_result.txt
             Reply  Wed Mar 2 12:40:08 2022, Tega, Update, VAC, Ongoing work to get the FRG gauges readouts to EPICs channels 6x
                Reply  Sun Mar 6 18:14:45 2022, Tega, Update, VAC, Ongoing work to get the FRG gauges readouts to EPICs channels iolan_xgs_comm_investigation.pdf
                   Reply  Mon Mar 7 13:53:40 2022, Tega, Update, VAC, Ongoing work to get the FRG gauges readouts to EPICs channels iolan_xgs_comm_live.pdf
                      Reply  Mon Mar 7 14:52:34 2022, Koji, Update, VAC, Ongoing work to get the FRG gauges readouts to EPICs channels 
                         Reply  Tue Mar 8 12:08:47 2022, Tega, Update, VAC, Ongoing work to get the FRG gauges readouts to EPICs channels XGS600_calibration.pdf
Message ID: 16691     Entry time: Tue Mar 1 20:38:49 2022     In reply to: 16683     Reply to this: 16692
Author: Tega 
Type: Update 
Category: VAC 
Subject: Ongoing work to get the FRG gauges readouts to EPICs channels 

During my investigation, I inadvertently overwrote the serial port configuration for the connected devices. So I am now working to get it all back. I have attached screenshots of the config settings that brought back communication that is not garbled. There is no physical connection to port 6, which I guess was initially used for the UPS serial communication but not anymore. Also, ports 9 and 10 are connected to Hornet and SuperBee, both of which have not been communicating for a while and are to be replaced, so there is no way to confirm communication with them. Otherwise, the remaining devices seem to be communicating as before.

I still could not establish communication with the XGS-600 controller using the serial port settings given in the manual, which also happen to work via Serial to USB adapter, so I will revisit the problem later. My immediate plan is to do a Serial Ethernet, then Ethernet to Serial, and then Serial to USB connection to see if the USB code still works. If it does then at least I know the problem is not coming from the Serial to Ethernet adapters. Then I guess I will replace the controller with my laptop and see what signal comes through when I send a message to the controller via the IOLAN serial device server. Hopefully, I can discover what's wrong by this point.

 

Note to self: Before doing anything, do a sanity check by comparing the settings on the IOLAN SDS and the config settings that worked for the Serial to USB communication and post an elog for this for reference.

Attachment 1: Working_Serial_Port_List_1.png  225 kB  | Hide | Hide all
Working_Serial_Port_List_1.png
Attachment 2: Working_Serial_Port_List_2.png  223 kB  | Hide | Hide all
Working_Serial_Port_List_2.png
Attachment 3: Working_Config_Ports#1-5.png  306 kB  | Hide | Hide all
Working_Config_Ports#1-5.png
Attachment 4: Working_Config_Ports#7-8.png  126 kB  Uploaded Tue Mar 1 22:30:47 2022  | Hide | Hide all
Working_Config_Ports#7-8.png
ELOG V3.1.3-