40m QIL Cryo_Lab CTN SUS_Lab TCS_Lab OMC_Lab CRIME_Lab FEA ENG_Labs OptContFac Mariner WBEEShop
  40m Log  Not logged in ELOG logo
Entry  Mon Apr 8 11:53:17 2019, gautam, Update, CDS, c1oaf needs debugging c1oaf_sat.pngMCL_FF_TF.pdf
    Reply  Wed Oct 2 23:23:02 2019, gautam, Update, CDS, c1oaf DC indicator needs to be green MCL_FF_Test.pdf
Message ID: 14927     Entry time: Wed Oct 2 23:23:02 2019     In reply to: 14522
Author: gautam 
Type: Update 
Category: CDS 
Subject: c1oaf DC indicator needs to be green 

Today, I found out that this type of "0x2bad" DC error is connected to the 1e+20 cts output. The solution was to bite the bullet and stop/start the c1oaf model (at the risk of crashing the vertex FEs). Today, I was lucky and the model came back online with all CDS indicators green. At which point I was able to engage length feedforward to MC2 (with some admittedly old filter). Some subtraction is happening, see Attachment #1. This was just meant to test whether the signal routing is happening - the feedforward signal goes to the "ALTPOS" input of the suspension CDS block, which AFAIK does not have a corresponding MEDM EPICS indicator. So I couldn't figure out whether the feedforward control signal was in fact making it to the suspension. On the evidence of the suppression of MCL in the 1-3 Hz band, I would conclude that it is. Useful to be able to engage these FF filters for better lockability.

Quote:

Attachment #1 - the vertex seismometer input produces 1e+20 cts at the output of the feedforward filter. Attachment #2 shows the shape of the feedforward filters - doesn't explain the saturation. Since this is a feedforward loop, a runaway loop can't be the explanation either.

Attachment 1: MCL_FF_Test.pdf  33 kB  Uploaded Thu Oct 3 00:27:19 2019  | Hide | Hide all
MCL_FF_Test.pdf
ELOG V3.1.3-