40m QIL Cryo_Lab CTN SUS_Lab TCS_Lab OMC_Lab CRIME_Lab FEA ENG_Labs OptContFac Mariner WBEEShop
  40m Log  Not logged in ELOG logo
Entry  Fri Nov 17 16:31:11 2017, aaron, Omnistructure, Computers, Acromag wired up AcromagWiringMaps.pdf
    Reply  Fri Nov 17 17:10:53 2017, rana, Omnistructure, Computers, Acromag wired up 
    Reply  Wed Nov 22 00:54:18 2017, johannes, Omnistructure, Computers, Slow DAQ replacement computer progress 
       Reply  Wed Nov 29 21:40:30 2017, johannes, Omnistructure, Computers, Slow DAQ replacement computer progress 
          Reply  Mon Dec 4 22:06:07 2017, johannes, Omnistructure, Computers, Acromag XEND progress 
             Reply  Thu Dec 7 22:24:04 2017, johannes, Omnistructure, Computers, Acromag XEND progress sourcing_input.pngsourcing_to_sourcing_with_common_supply.pngIMG_20171207_193128928.jpg
                Reply  Fri Dec 8 12:06:59 2017, johannes, Omnistructure, Computers, c1auxex2 ready - but need more cables 
Message ID: 13469     Entry time: Fri Dec 8 12:06:59 2017     In reply to: 13468
Author: johannes 
Type: Omnistructure 
Category: Computers 
Subject: c1auxex2 ready - but need more cables 

The new slow machine c1auxex2 is ready to deploy. Unfortunately we don't have enough 37pin DSub cables to connect all channels. In fact, we need a total of 8, and I found only three male-male cables and one gender changer. I asked Steve to buy more.

Over the past week I have transferred all EPICS records - soft channels and physical ones - from c1auxex to c1auxex2, making changes where needed. Today I started the in-situ testing

  1. Unplugged ETMX's satellite box
  2. Unplugged the eurocrate backplane DIN cables from the SOS Driver and QPD Whitening filter modules (the ones that receive ao channels)
  3. Measured output voltages on the relevant pins for comparison after the swap
  4. Turned off c1auxex by key, removed ethernet cable
  5. Started the modbus ioc on c1auxex2
  6. Slow machine indicator channels came online, ETMX Watchdog was responsive (but didn't have anything to do due to missing inputs) and reporting. PIT/YAW sliders function as expected
  7. Restoring the previous settings gives output voltages close to the previous values, in fact the exact values requested (due to fresh calibration)
  8. Last step is to go live with c1auxex2 and confirm the remaining channels work as expected.

I copied the relevant files to start the modbus server to /cvs/cds/caltech/target/c1auxex2, although kept local copies in /home/controls/modbusIOC/ from which they're still run.

I wonder what's the best practice for this. Probably to store the database files centrally and load them over the network on server start?

ELOG V3.1.3-