40m QIL Cryo_Lab CTN SUS_Lab TCS_Lab OMC_Lab CRIME_Lab FEA ENG_Labs OptContFac Mariner WBEEShop
  40m Log  Not logged in ELOG logo
Entry  Mon Nov 30 12:19:38 2015, yutaro, Update, Computer Scripts / Programs, image capture 
    Reply  Sat Dec 5 12:02:25 2015, yutaro, HowTo, Cameras, When image capture does not work... 
       Reply  Sat Dec 5 21:28:33 2015, Koji, HowTo, Cameras, When image capture does not work... 
          Reply  Sat Dec 5 21:57:32 2015, yutaro, HowTo, Cameras, When image capture does not work... 
Message ID: 11851     Entry time: Sat Dec 5 12:02:25 2015     In reply to: 11824     Reply to this: 11852
Author: yutaro 
Type: HowTo 
Category: Cameras 
Subject: When image capture does not work... 

Today image capture did not work again, though it had worked 3 days before. I also found that red indicator light on the front pannel of SENSORAY was not turned on, which had been turned on 3 days before (you can find SENSORAY on the floor near Pianosa). Possible reason that it did not work again was I restarted Pianosa last night. Anyway, it works now. Here I report what I did to make it work.

 

I ran thes commands in shell, following the instruction of the manual of SENSORAY 2253 (Page 5; link or you can find the manual in /users/sensoray; I put it there). 

> cd /users/sensoray/sdk_2253_1.2.2_linux

> make all

> sudo make install

> modprobe s2253

Then the red light got turned on, and image capture worked.

 

If you recieve an error like "No such file or directory: /dev/video0" at the beginning of the error message when you run image capture scripts from the medm screen, or if you notice that the red indicator light of SENSORAY is not on, this procedure could help you. 

ELOG V3.1.3-