40m QIL Cryo_Lab CTN SUS_Lab TCS_Lab OMC_Lab CRIME_Lab FEA ENG_Labs OptContFac Mariner WBEEShop
  40m Log  Not logged in ELOG logo
Entry  Tue Jun 10 11:54:36 2014, Zach, Configuration, Wiki, DokuWikis are still down 
    Reply  Tue Jun 10 19:11:27 2014, Evan, Configuration, Wiki, DokuWikis are back up 
       Reply  Wed Jun 11 05:16:14 2014, Zach, Configuration, Wiki, DokuWikis are back up 
          Reply  Wed Jun 11 10:15:15 2014, Evan, Configuration, Wiki, DokuWikis are back up 
             Reply  Wed Jun 11 20:09:37 2014, Zach, Configuration, Wiki, DokuWiki situation 
             Reply  Mon Aug 11 23:50:38 2014, rana, Configuration, Wiki, DokuWikis are back up 
                Reply  Mon Apr 10 15:22:46 2017, rana, Configuration, Wiki, DokuWikis are back up 
Message ID: 10029     Entry time: Wed Jun 11 20:09:37 2014     In reply to: 10024
Author: Zach 
Type: Configuration 
Category: Wiki 
Subject: DokuWiki situation 

I have been looking into the DokuWiki situation, with no great progress so far.

The problem is with authentication. When you try to access the wiki, you get: "User authentication is temporarily unavailable. If this situation persists, please inform your Wiki Admin."

 As Evan points out, this goes away if you turn off ACL (Access Control Lists), but---as he also mentions---that just means that authentication is disabled, so the wiki becomes open. All signs point to this being a problem with the authentication mechanism. We use the 'authplain' plaintext method, where the usernames and hashed passwords are stored in a plaintext file.

Evan and I have both done plenty of testing with the config settings to see if the problem goes away. Even if you restore everything to default (but enable ACL using authplain and the existing user file), you still get an error.

I went as far as installing a brand new wiki on the web server, and, surprisingly, this also exhibits the problem. Interestingly, if I install an old enough version (2012-10-13), it works fine. After this revision, they transitioned their authentication methods from "backends" to "plugins", so this is a clue. As a side note, the other wikis on nodus (ATF and Cryo) are running earlier versions of DokuWiki, so they have no problems.

As it stood, our options were:

  1. No wiki (not even read-only, since the issue prevents logging in and also prevents anonymous reading, somehow)
  2. No ACL = open wiki. Also not good.

So, I created a temporary read-only version of the wiki using the aforementioned earlier DokuWiki release. It has a soft link to the real wiki data, but I deleted the user database so no one can log in and edit (I also disabled registration). It can be found at https://nodus.ligo.caltech.edu:30889/wiki_ro/.

I also created a backup of the real wiki as wiki_bak to avoid any potential disasters.

The simplest thing to do would be to just roll the wiki back to this working version, but that doesn't sound so smart. Clearly, it was working with the plugin structure before our snafu, and somehow our fixing everything else has broken it.

Quote:

Quote:

It looks like auth is broken on the AIC wiki (though working fine on ATF and Cryo). I did some poking around but can't see how anything we did could have broken it.

I went into local.php and changed $conf['useacl'] = 1; to $conf['useacl'] = 0; and it looks like the auth issue goes away (I've changed it back). This isn't a fix (we want to use access control), but it gives us a clue as to where the problem is.

 

ELOG V3.1.3-